Announcement

Collapse
No announcement yet.

Event engine going wrong, completly....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event engine going wrong, completly....

    So this is me, frustrated as nothing else!!!

    Background: Was watching the Formula-1 race, and when I tried to turn off the projector (which is controlled with a Virtual Device in HomeSeer Zee S2 in my case) I got all sorts of problems... Don't know where to start even...

    1) When trying to send "OFF" to the projector, thru IP command with the excellent plugin "drhsIpPlugIn" (which works perfect for me, never had any issues), well then the event engine decided to substitute the call to the plugin with a Z-wave "turn lamp off" and an "turn lamp on" - in the closet. This has NOTHING to do with the projector, and the event connected to the two lamps just mentioned, well they was never triggered. So what ever triggered the wrong events to happen, was created within the event engine which replaced what should have been done with something completely random. Lucky I was home, what if something worse had turned on or off?

    2) After a few minutes the HomeSeet web front page goes dark, with no response. To solve this I had to pull the power out of the HomeSeer Zee S2 box. I saw no other way, since nothing was going correct within the software of the HomeSeer, nor did any lamps actually work correct anymore... Well actually by this time close to NOTHING worked:

    3) After a few hours I noticed that a few events was not running, which should have been running. I can not say why this happens, but all of a sudden I notice that a few VD's hade the wrong status - it's like when I pulled the plug of the Zee S2 it restarted with random values on the VDs instead of the last ones.

    4) When I digged into #3 above, I also noticed another couple of things regarding events not run correctly - not even triggered "last" correctly - something did happen during the reboot of the Zee S2, and it was not good.

    5) A few of my events actually lost the last couple of changes, one specific VD lost ALOT changes and changes that I was sure was committed simply gone up in the air....

    6) A bunch of my light sensors stopped collecting light reading, well the sensors tried to work of course, but HomeSeer Zee S2 just stopped listening to the transmissions. After a brutal wakeup on EACH sensor, it seems to work again.

    I am 100% sure I have missed a few important details. So why Do I post here? Well Support@HomeSeer.com simply refereed me over to this forum, and decided it was not there case to help me....

    So far I have been impressed with the stability of the HomeSeer, however after everything above, I consider this to be just as bad as anyone else out there. I can not trust that the event engine will trigger the correct events, since it seems to forget what to do and what to trigger and decides by itself to randomly trigger what ever it feels to...

    This is bad behavior, and frankly this is a BIG disappointment. Not being able to trust the Event engine - the most central part of all.

    #2
    Which version of HS3 are you running?
    Originally posted by rprade
    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

    Comment


      #3
      Colin's question above is important because there have been some problems, especially relating to Linux that have been addressed over the last few months.

      Your symptoms would seem to point to a corrupted database.
      Originally posted by larhedse View Post
      Well Support@HomeSeer.com simply refereed me over to this forum, and decided it was not there case to help me....
      I think the email address has an auto responder that suggests checking this forum for additional help. They will still respond to emails within 1-2 business days. They are closed on Saturday and Sunday.

      Comment


        #4
        Current version is:

        Current Date/Time: 2016-08-28 16:31:33
        HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.293
        Linux version: Linux HomeTrollerZeeS2 3.18.11-v7+ #781 SMP PREEMPT Number of Devices: 209
        Number of Events: 167
        Available Threads: 280
        License: Registered
        Location: (Latitude) 59,20 (Longitude) -18,03

        Enabled Plug-Ins
        0.0.0.21: drhsIpPlugIn
        3.0.1.83: Z-Wave

        Comment


          #5
          Originally posted by rprade View Post
          I think the email address has an auto responder that suggests checking this forum for additional help. They will still respond to emails within 1-2 business days. They are closed on Saturday and Sunday.
          And support did write this in an email:

          I would recommend posting this question in our Event Clinic here:
          http://board.homeseer.com/forumdisplay.php?f=1250

          We do not troubleshoot events via the help desk but have a technician that works the event clinic to assist in these situations.

          Comment


            #6
            There are a few things in there that do point to perhaps there being a database issue however there are other things (like the web page going, the web UI is nothing to do with the DB) that say there may be more at play but at a loss to think of what could cause a widespread issue. Are you still within your warranty period?

            For such a simple setup (in terms of plugins and amount of devices/events) then I am surprised at this but there are no ability to really debug database issues because of the fact that there are custom data storage methods inside the DB that end users don't have knowledge of.

            Comment


              #7
              If you do not think it's an event configuration issue then respond to your ticket and attach your config database for support to review.
              -Rupp
              sigpic

              Comment


                #8
                Originally posted by Rupp View Post
                If you do not think it's an event configuration issue then respond to your ticket and attach your config database for support to review.

                Comment


                  #9
                  Just your config database and yes a backup will work or just shut down HS3 and copy the config database.
                  -Rupp
                  sigpic

                  Comment


                    #10
                    Had another strange Z-Wave event happening today:

                    One of my lamps was turned on at 10:53:09 - except NO event was triggered. There is NO reason for WHY this lamp was turned on (to 50% I might add...).

                    Yet another random thing that SHOULD NOT HAPPEN!!!!

                    Comment


                      #11
                      HomeSeer: This is not funny, I have heard NOTHING from you on all five outstandig issues I have with YOUR product. I have given you everything you have been asking for, and then some more - but still nothing.

                      Comment


                        #12
                        You are not going to get a response from any of the HS techs as they rarely frequent the message board. Your best bet is to continue to respond to your help desk emails or if you are within your 30 day support window call in to HST.
                        -Rupp
                        sigpic

                        Comment

                        Working...
                        X