Announcement

Collapse
No announcement yet.

Event - device has been/for at least

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event - device has been/for at least

    I have a HS switch that is not responding to the device has been/for at least that I have that's set to 1 hour. I think it has to do with the z-wave controller polling the device and changing the Last Change date/time.

    It seems that every time the controller sends something to the switch the last change date gets updated. If I run the event manually it will work.

    I'm new to all of this so I'm thinking there's an option or something that I need to do to get past this?

    I have another HS switch that is a "neighbor" to this switch and it works just fine.

    Thanks
    Attached Files

    #2
    If the last update time does keep changing, you can do something like this:

    Click image for larger version

Name:	Capture.jpg
Views:	1
Size:	53.6 KB
ID:	1187133

    Just change the 20 minutes to 1 hour.

    Cheers
    Al
    HS 3.0.0.548: 1990 Devices 1172 Events
    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

    Comment


      #3
      You need to check the box "Do not update device last change time if device value does not change:" on the device's configuration page. Or you can use Al's suggestion.

      Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	43.2 KB
ID:	1187134

      Comment


        #4
        Wow, that was fast. Thank you both.

        I knew it had to be something simple.

        Is one method preferred over the other?

        Comment


          #5
          Originally posted by facke02 View Post
          Wow, that was fast. Thank you both.

          I knew it had to be something simple.

          Is one method preferred over the other?
          It is a matter of preference. For the type of event you are creating, the method you used will work fine. I tend to avoid using "This device has been/for at least..." because of the possibility of repeat triggers. Your event is controlling the device used as a trigger, so it will be fine. I would put 10 seconds in the "Cannot Re-Run For:" in the advanced options of the event just to compensate for any Z-Wave status reporting lag.

          The way Al does it would be my preference (of the two), but it does take two events. The first event is just housekeeping, but is a good idea.

          Comment


            #6
            Thanks Randy and Al


            I used Al's approach and created two new events. Seems more straight forward.

            I also checked the box "Do not update device last change time if device value does not change:" on the device's configuration page. Not sure if I should be doing this or not. I know the new events will handle it if it's not checked.

            Comment

            Working...
            X