Announcement

Collapse
No announcement yet.

Light Off Event Triggering Before Elapsed Time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Light Off Event Triggering Before Elapsed Time

    I created a simple event to turn off my garage light if it was left on for 2 hours. Now, when I turn on the light, it immediately triggers the event and turns off the light. I can then turn the light back on, and it will stay on. After a couple of hours, the same problem will occur. I tried deleting the event and re-creating it, but I get the same behavior.

    This is a simple event that just says 'if the light is on for at least two hours then turn it off'.

    There is also a remote switch for this light. The remote and master are associated with each other. Other than this problem with the event, the light operates fine from either switch.

    This is my first post. I've hopefully attached a file that shows a screen shot of the event.

    Appreciate any help.

    Current Date/Time: 11/28/2016 12:43:45 PM
    HomeSeer Version: HS3 ZEE Edition 3.0.0.297
    Linux version: Linux HomeTrollerZEE 3.12.28+ #709 PREEMPT Mon Sep 8 15:28:00 BST 2014 armv6l GNU/Linux System Uptime: 10 Days 18 Hours 20 Minutes 19 Seconds
    IP Address: 192.168.1.106
    Number of Devices: 26
    Number of Events: 7
    Available Threads: 99

    Enabled Plug-Ins
    3.0.0.72: HSTouch Server
    3.0.1.73: Z-Wave
    Attached Files

    #2
    Hi, welcome to the forum!

    Do your light switches support instant status? When you turn them on and off, does the status get updated on the Device Management page right away?

    Cheers
    Al
    HS 3.0.0.548: 1990 Devices 1172 Events
    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

    Comment


      #3
      Originally posted by sparkman View Post
      Hi, welcome to the forum!

      Do your light switches support instant status? When you turn them on and off, does the status get updated on the Device Management page right away?

      Cheers
      Al
      Sorry, should have mentioned that. Yes, they do support instant status. I confirmed that the switch status is showing as 'off' just before turning on the light and triggering the event. The log also shows the switch being turned on and then the event triggering. The switch is a Cooper RF9501DW.

      Comment


        #4
        I just created a test event like yours (minus the notification) and it works fine for me. I used a 5 minute interval:

        Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	18.2 KB
ID:	1187918

        You may want to try .300 of HS and/or .95 of the z-wave plugin. Not sure if .300 is available for the Zee yet.

        Cheers
        Al
        HS 3.0.0.548: 1990 Devices 1172 Events
        Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

        Comment


          #5
          This one is a little perplexing. I can't see how the event could trigger as soon as the light is turned on, unless the "Last Change" Date/Time is not updating. I would open the device manager on a tablet or phone, so you can see what is happening in HomeSeer when you turn the light on. If it is working correctly, the device should show "Off", then the text and icon will change to "On" and the Last Change show show the date and time as now when the status changes. The trigger "This device has been for at least..." uses that timestamp to determine how long it has been on. If that date is not updating it would cause the problem you describe. If you find it is not updating and is a Z-Wave device, I would try rescanning and optimizing. If the date is still not updating you could try excluding the device and including it again Note: this will break every event that uses the device.

          If the date and status are behaving properly and you are still getting this instant off and you see in the log that the event is indeed triggering, I would delete and rebuild the event from scratch. There is a known bug where if you ever delete a trigger from an existing event, the event becomes corrupted and cannot be repaired.

          This should have nothing to do with the problem you are having, but another problem that can be caused is by that date being updated whenever the device is polled or set, even if the value doesn't change. There is a checkbox: "Do not update device last change time if device value does not change:" to prevent that behavior.

          Click image for larger version

Name:	Capture1.png
Views:	1
Size:	54.0 KB
ID:	1187921

          Comment


            #6
            That's the frustrating thing about this. It's about as simple of an event as you can get. When I check for updates, it says that none are available.

            Comment


              #7
              The zwave plugin needs to be updated using the Plug-Ins - Manage page. The latest is .95 listed under the beta section.

              Cheers
              Al
              HS 3.0.0.548: 1990 Devices 1172 Events
              Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

              Comment


                #8
                Randy, thanks for the suggestions. I will check it out and post back. On the 'Last Change Date/Time', why would that matter in this case? If the device is in the 'off' state to start with, it seems like there's no way that the event should trigger immediately when the light is turned on....unless the last change date is getting set to more than 2 hours in the past when the light is turned on which does not seem to be the case.

                Comment


                  #9
                  Originally posted by fschwing View Post
                  Randy, thanks for the suggestions. I will check it out and post back. On the 'Last Change Date/Time', why would that matter in this case? If the device is in the 'off' state to start with, it seems like there's no way that the event should trigger immediately when the light is turned on....unless the last change date is getting set to more than 2 hours in the past when the light is turned on which does not seem to be the case.
                  My only thought (and I've never seen it) is that the date is not getting updated with the status change, so it might be more that 2 hours in the past.

                  Comment


                    #10
                    Originally posted by sparkman View Post
                    The zwave plugin needs to be updated using the Plug-Ins - Manage page. The latest is .95 listed under the beta section.

                    Cheers
                    Al
                    Thanks for bearing with me on this. Apologize that I'm still a bit of a newbie. I can't see anywhere on the Plug-Ins Manage page where I can update z-wave. I thought that the update on HS3 also updated the Plug-Ins at the same time because I don't see any separate update option for the plug-ins. Could this be a difference with the Zee? I've attached what I see on the Manage page.
                    Attached Files

                    Comment


                      #11
                      Originally posted by rprade View Post
                      My only thought (and I've never seen it) is that the date is not getting updated with the status change, so it might be more that 2 hours in the past.
                      Randy,

                      I've turned the device on and off a few times, and the log shows the status update immediately. So it appears that the status is instant.

                      Comment


                        #12
                        Originally posted by fschwing View Post
                        Thanks for bearing with me on this. Apologize that I'm still a bit of a newbie. I can't see anywhere on the Plug-Ins Manage page where I can update z-wave. I thought that the update on HS3 also updated the Plug-Ins at the same time because I don't see any separate update option for the plug-ins. Could this be a difference with the Zee? I've attached what I see on the Manage page.


                        There should be more info below that even on a Zee AFAIK. Which browser are you using. I'v seen reports of some browsers not displaying that properly. Try Chrome if you are using something different.


                        Sent from my Phone using Tapatalk
                        HS 3.0.0.548: 1990 Devices 1172 Events
                        Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                        Comment


                          #13
                          Thinking that since you are limited to 5 plugins on a Zee, it may not display everything since you already have 5 plugins installed. Maybe remove one that you are not using.


                          Sent from my Phone using Tapatalk
                          HS 3.0.0.548: 1990 Devices 1172 Events
                          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                          Comment


                            #14
                            Originally posted by sparkman View Post
                            Thinking that since you are limited to 5 plugins on a Zee, it may not display everything since you already have 5 plugins installed. Maybe remove one that you are not using.


                            Sent from my Phone using Tapatalk
                            Al,

                            It is my understanding that the Zee has those 5 fixed plug-ins. You can't remove any or add any. You can just disable and enable. I was using Explorer but tried Chrome and see exactly the same page. So I guess the question is how to update Z-wave plug-in on the Zee. I will search the forum. Sure would be nice to have some good documentation.

                            Comment


                              #15
                              Originally posted by fschwing View Post
                              Al,



                              It is my understanding that the Zee has those 5 fixed plug-ins. You can't remove any or add any. You can just disable and enable. I was using Explorer but tried Chrome and see exactly the same page. So I guess the question is how to update Z-wave plug-in on the Zee. I will search the forum. Sure would be nice to have some good documentation.


                              From my understanding it is any 5 plugins. The Zee guides seems to support that as they talk about installing plugins: http://www.homeseer.com/guides/HomeT...Guide-rev4.pdf and
                              http://www.homeseer.com/guides/HomeT...tart-Guide.pdf

                              Sent from my Phone using Tapatalk
                              Last edited by sparkman; November 28, 2016, 10:29 PM.
                              HS 3.0.0.548: 1990 Devices 1172 Events
                              Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                              Comment

                              Working...
                              X