Announcement

Collapse
No announcement yet.

hs3 web access SUDDENLY hyper slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hs3 web access SUDDENLY hyper slow

    Hi

    After a security update from windows 10 on my server, the acces to my HS# from CERTAIN devices via web acces is extremely slow, screens are taking forever to show up.

    I tried on 2 windows 10 devices with chrome, firefox and edge and the screen altways take forever to show up.

    If I start a web page directly on the server the pages are shown immediatly ALSO, If I connect to my HS3 server via my safari on my iphone on the wifi the speed is really fast

    anyone have any idea on the issue ?

  • #2
    Slow page update.

    Hi Goldriver,
    I have had this problem which although not solved is in my case due to an update/upgrade of Avast free antivirus. Obviously not at all sure if this is your problem but thought I would add this for any one else who might read this thread.
    Peter

    Comment


    • #3
      Originally posted by Pervez2602 View Post
      Hi Goldriver,
      I have had this problem which although not solved is in my case due to an update/upgrade of Avast free antivirus. .......
      The Avast issue exists with both free and paid versions. Thus far I find no movement on Avast's part to correct the issue. (Stand to be corrected.)
      HomeSeer Version: HS3 Pro Edition 3.0.0.500
      Operating System: Microsoft Windows 10 Pro - Work Station

      Enabled Plug-Ins:
      2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

      Comment


      • #4
        Same issue on my W10 computer with Avast.
        A week ago it was quick to open up the top of the HS page but then it was taking long time to load sensors.
        Today it got slower. Just accessing the HS page took 3 minutes, getting sensors status - another 3 minutes

        Comment


        • #5
          If you don't already have this working....

          From my testing:
          Unpaid Avast, Turn off Web Shield

          Paid Avast, you must turn off Web Shield and Real Site
          HomeSeer Version: HS3 Pro Edition 3.0.0.500
          Operating System: Microsoft Windows 10 Pro - Work Station

          Enabled Plug-Ins:
          2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

          Comment


          • #6
            Here is the situation:

            -Web shield was already deactivated
            -I completely deactivated Avast - same issue

            What I don't understand is that if I connect via my iphone through Safari on my WIFI network, I have no waiting time, it seems to only be when I connect through a windows machine

            my next step is to completely remove the anti virus and see if the problem is still there, will keep you posted

            Comment


            • #7
              I got it workink BUT ...

              - I removed Avast
              - I de-activated windows firewall
              - re-installed Avast
              Tried connecting from a LAN windos machine to HS3 : everything was back to normal

              - Re-Starteed windows firewall on HS3 server
              Tried connecting from a LAN windos machine to HS3 : back to turtle speed :-(
              I now have to find a way to fix this windows 10 firewall issue that seems to have appear in the latest security update, I'll keep diging

              Comment


              • #8
                I run clamwin on my servers. Lightweight and no issues.

                Sent from my SM-G935V using Tapatalk

                Comment


                • #9
                  hs3 web access SUDDENLY hyper slow

                  Normally you set your AV/AM exclusions to include the .exes, and program folders that your third party software has, then set your scan schedules to not occur during production hours. The other thing you want to create exclusions for is active scanning. After that I usually punch holes in my Windows firewall that match software required ports. Lastly, you may also want to check process priority related to your HS3 .exe and any plugin executables. The only other thing I can think of would to do on the OS would be to set power management on the system to high performance and disable Intel speed step/AMD cool n quiet.


                  Sent from my iPhone using Tapatalk
                  Last edited by Kerat; April 22nd, 2017, 11:23 PM.

                  Comment


                  • #10
                    No anti viris and super slow

                    I am having the same issue with loading speed being very slow. When I access HS3 on the actual computer the web page loads very fast. However, when I try accessing through another computer it is extremely slow. I do not have any anti virus installed on the HS3 computer.
                    I only noticed this when I recently updated HS3 to the new version.
                    Any idea of what might be causing this?
                    Thanks

                    Comment


                    • #11
                      Originally posted by nofreeze View Post
                      I am having the same issue with loading speed being very slow. When I access HS3 on the actual computer the web page loads very fast. However, when I try accessing through another computer it is extremely slow. I do not have any anti virus installed on the HS3 computer.
                      I only noticed this when I recently updated HS3 to the new version.
                      Any idea of what might be causing this?
                      Thanks
                      Try de-activating windows firewall on HS3 server and see if things come back to normal first.

                      Comment


                      • #12
                        Normal offenders are:
                        1. a TCP/UDP port port change in your application that may be getting slowed by your firewall.
                        2. windows firewall was off and turned back on.
                        3. BIOS changes that cause Intel speedstep/AMD cool'n'quiet to be re-enabled.
                        4. Power options being set to allow CPU frequency to be stepped down (set your power profile back to high performance)
                        5. Your HS3 processes are set to a lower priority than others and are stuck waiting for CPU time.
                        6. System may need disk cleanup/disk defragmenter ran (don't run defray on SSD)


                        Sent from my iPhone using Tapatalk

                        Comment


                        • #13
                          hs3 web access SUDDENLY hyper slow

                          Originally posted by goldriver View Post
                          Here is the situation:



                          -Web shield was already deactivated

                          -I completely deactivated Avast - same issue



                          What I don't understand is that if I connect via my iphone through Safari on my WIFI network, I have no waiting time, it seems to only be when I connect through a windows machine



                          my next step is to completely remove the anti virus and see if the problem is still there, will keep you posted


                          Probably doesn't help any, but I have noticed this in general with Apple products. My Mac using Chrome loads stupid fast on everything for my HS server. My win 10 with chrome is much much slower. I have not investigated yet, just observed.

                          I am not running any AV right now on my HS server other then what comes with the win 2016 OS (defender). I know I know....

                          Comment


                          • #14
                            Originally posted by goldriver View Post
                            Try de-activating windows firewall on HS3 server and see if things come back to normal first.
                            Yes that did it. As soon as I turned off windows firewall it was back to super fast load times. Any ideas on what files/ folders or ports need to be bypassed so I dont have to keep the firewall turned off?

                            Thanks for the help!

                            Comment


                            • #15
                              Originally posted by nofreeze View Post
                              Yes that did it. As soon as I turned off windows firewall it was back to super fast load times. Any ideas on what files/ folders or ports need to be bypassed so I dont have to keep the firewall turned off?



                              Thanks for the help!

                              Comment

                              Working...
                              X