Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

hs3 web access SUDDENLY hyper slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    hs3 web access SUDDENLY hyper slow

    I would add HS3's exes to the automatically allow application in your Windows firewall. This will help with outbound connections from the HS3 application. Also, you need to determine which port your HS3 management interface is running on. It could be running on 80, 8080, 443). I run HS3 for Linux and left it defaulted to port 80. You should be able to tell from your HS3 setup.

    It may also be worth checking into plugins as they may interface with the main application on a separate ports

    You could disable any 3rd party applications, turn off your windows firewall and run a wireshark for a bit to get a better idea.


    Sent from my iPhone using Tapatalk

    Comment


    • #17
      [QUOTE=Kerat;1303610]I would add HS3's exes to the automatically allow application in your Windows firewall. This will help with outbound connections from the HS3 application. Also, you need to determine which port your HS3 management interface is running on. It could be running on 80, 8080, 443). I run HS3 for Linux and left it defaulted to port 80. You should be able to tell from your HS3 setup.

      It may also be worth checking into plugins as they may interface with the main application on a separate ports


      Thanks for the info and help. I will give this a try.

      Comment


      • #18
        I have tried allowing all HS3 exes and plugins and still no luck. It is still super slow. I have created rules within windows firewall and that still does nothing. As soon as I turn off firewall completely it is back to super fast. I noticed that when access on a web browser from Android it has no problem at all and is very fast. Only problem is when using another windows PC.

        Comment


        • #19
          hs3 web access SUDDENLY hyper slow

          I have detected the exact same behaviour, the connection is very slow from window based computer to window based server, I can connect at normal speed from my IPhone, android and Firefox on my Linux box.

          Until I found an issue to this problem, I re-Inforced my router firewall
          Last edited by goldriver; April 26th, 2017, 06:09 AM.

          Comment


          • #20
            Here only utilize Linux / Firefox (not Chrome) to get to the HS3 web page. While I am committed to utilizing W10 (trimmed down) for HSTouch; HSTouch does run better for me still in embedded windows of old.

            Concurrently as golddriver mentions above over the years here have gone to beefing up the protection on the PFSense firewall for all devices on the network.

            Try as you want though as W10/IE does do it's own thing once connected in an effort to protect the user 3rd party software or not.
            - Pete

            Auto mator
            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
            HS4 pro - 4.0.3.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X

            X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

            Comment


            • #21
              Did anybody fix this?

              Hi All,
              Well I am running HS3 Pro v .318 on Win 7 x64 with avast freebie.
              That said with the firewall on is O.K. from my android but not from another windows machine. Turn the firewall off and every thing from the windows machine works.
              Had a look at the firewall settings, I am no expert here but every thing looks OK I think!

              So any pointers?

              Peter

              Comment


              • #22
                hs3 web access SUDDENLY hyper slow

                I would expressly permit your HS3 related executable to pass through the firewall.

                In your advanced firewall settings I would create an explicit inbound rule that Allows access to your management UI port (could be 80, 8080, 443 you will need to check your configuration). If you run plugins that communicate on a specific ports you will need to create inbound/outbound rules to open communication ports. If they have separate executables i would allow them explicitly as well.

                Additionally, I think you should create exclusions in your antivirus software for the executables, config files, and DB files.


                Sent from my iPhone using Tapatalk

                Comment


                • #23
                  I too have the same issue. Win10 client connecting to homeseer machine.
                  Irrespective of browser all have super slow connections and/or total timeouts.

                  Avast is to blame.

                  Any other machine windows, android etc all connect quickly with no changes to the server machine.

                  Like posted above .. if I turn off webscreen and real time shields on he problem win10.. everything is good.

                  I also needed to stop automatic port scan detection in the Avast settings.

                  It appears that the latest Avast is treating your local network as unfriendly.

                  I raised a case with Avast, did a bunch of testing with them interactively and they escalated to third level support. 2 days later they responded with "its a bug it will be fixed in a coming release.

                  Comment


                  • #24
                    OK I will check this out.

                    Hi Kerat

                    Thanks for the info.

                    I will lurk back in to the firewall and check this. I must admit I really feel a little uncomfortable messing with the firewall have never done it before but my management ui is not on any of the normal ports, thing left over from HS2 and another program conflict.

                    You say:-
                    In your advanced firewall settings I would create an explicit inbound rule that Allows access to your management UI port.

                    Will have a go at this first as may need some help, will probably be tomorrow as I am out today, so will update on my progress.

                    Peter

                    Comment


                    • #25
                      hs3 web access SUDDENLY hyper slow

                      No problem, you could turn off the firewall and any Antivirus software and test. That would tell us if we are on the right path.


                      Sent from my iPhone using Tapatalk

                      Comment


                      • #26
                        Firewall.

                        Hi Kerat,

                        Did turn off just the firewall. With it off every thing is fine. Did have a look at the advanced setting and thought everything looked as it should be but will have another go and try to add an inbound exclusion for my management UI. Strange thing although the only thing that is different is avast has been updated nothing else.
                        Switching off the firewall is what helps so don't quite understand, excuse my ignorance but would avast change the firewall?

                        Thanks
                        Peter

                        Comment

                        Working...
                        X