Announcement

Collapse
No announcement yet.

email problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    email problem

    I am using a Gmail account to "talk" to HS, problem is HS is leaving the messages on the server and re=downloads them!

    Current Date/Time: 13/05/2017 16:55:19
    HomeSeer Version: HS3 Pro Edition 3.0.0.318
    Operating System: Microsoft Windows XP Professional - Work Station
    System Uptime: 0 Days 0 Hours 22 Minutes 18 Seconds
    IP Address: 192.168.x.x
    Number of Devices: 430
    Number of Events: 223
    Available Threads: 400

    Enabled Plug-Ins
    2.0.39.0: BLBackup
    2.0.8.0: BLCpuAdvisor
    2.0.5.0: BLGarbage
    2.0.127.0: BLRadar
    2.0.91.0: BLRF
    1.0.3.0: BLShutdown
    3.0.0.104: HSTouch Server
    3.0.0.20: ImperiHome
    3.0.6265.20586: UltraWeatherWU3
    3.0.0.42: X10
    3.0.1.114: Z-Wave
    sigpic
    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

    #2
    Its been a month or so ago here that I played with default HS3 GMail settings and adding email settings on HS3.

    I got it working fine BUT...wanted to proxy email via STunnel any hoot so I tested an STunnel set up on one Ubuntu server that is now a proxy server for all of the email on the boxes down der (server room).

    I do not utilize POP with HS rather just SMTP. There is a setting in GMail for less secure email apps to use email. You have to turn this on to get email working.

    The setting is buried there on your GMail settings. Try it and see if that works for you.

    Might abandon Outlook email on the desktop, tired of threads now using the web gmail stuff and might go to Thunderbird in Linux.

    p.

    PS

    Googled gmail less secure apps configuration

    and got:

    If you want to allow access anyway, follow these steps:
    Go to the "Less secure apps" section in My Account.
    Next to "Access for less secure apps," select Turn on.
    (Note to G Suite users: This setting is hidden if your administrator has locked less secure app account access.)
    Last edited by Pete; May 13, 2017, 01:02 PM.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
    HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
    6.10.0.104
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #3
      I posted this a while back so I thought I would try again. If you are trying to use gmail in HS email you may have to go through a few steps to get it to work.

      1. log into your gmail account with your current email address and pw
      2. click on Sign-in & Security
      3. select app passwords
      4. have to put in your current gmail pw again
      5. under 'select app' choose one of the entries or choose other and enter a name
      6. under 'select device' you can do the same as with 'select app'
      7. click on 'generate'

      Use this code as your pw in HS for gmail instead of your usual gmail pw - THIS DOES NOT CHANGE YOUR ORIGINAL GMAIL PW TO LOG IN TO YOUR MAIL FROM A BROWSER. IT IS ONLY FOR APPS. GMAIL IS GIVING HS3 A SPECIAL PW TO USE THE MAIL.
      Attached Files

      Comment


        #4
        Originally posted by cowinger View Post
        I posted this a while back so I thought I would try again. If you are trying to use gmail in HS email you may have to go through a few steps to get it to work.

        1. log into your gmail account with your current email address and pw
        2. click on Sign-in & Security
        3. select app passwords
        4. have to put in your current gmail pw again
        5. under 'select app' choose one of the entries or choose other and enter a name
        6. under 'select device' you can do the same as with 'select app'
        7. click on 'generate'

        Use this code as your pw in HS for gmail instead of your usual gmail pw - THIS DOES NOT CHANGE YOUR ORIGINAL GMAIL PW TO LOG IN TO YOUR MAIL FROM A BROWSER. IT IS ONLY FOR APPS. GMAIL IS GIVING HS3 A SPECIAL PW TO USE THE MAIL.
        One additional note to the above from cowinger. You must have "2-Step Verification" turned on within Gmail in order to see the "app passwords" option. If you do not see the "app passwords" as an option be sure to enable 2-Step. You should have 2-Step enables anyway to truly secure your Gmail acct.

        -Paul

        Comment


          #5
          Originally posted by pohoda View Post
          One additional note to the above from cowinger. You must have "2-Step Verification" turned on within Gmail in order to see the "app passwords" option. If you do not see the "app passwords" as an option be sure to enable 2-Step. You should have 2-Step enables anyway to truly secure your Gmail acct.

          -Paul
          pohoda, good catch. I had forgot about that part. You are absolutely right about how it can add to the security of gmail.

          Did it work?

          Comment


            #6
            Originally posted by cowinger View Post
            pohoda, good catch. I had forgot about that part. You are absolutely right about how it can add to the security of gmail.

            Did it work?
            Yes. All working great now. Thanks again.

            Sent from my SM-G955U using Tapatalk

            Comment


              #7
              So when you configure gmail-HS3 like this, do the emails get downloaded onto HS3?

              Comment


                #8
                Originally posted by tome10 View Post
                So when you configure gmail-HS3 like this, do the emails get downloaded onto HS3?
                I think this is just for sending something from HS3 to your gmail address. There is a section in setup that is for receiving but I have never used it.

                Someone who has will have to explain that one.

                Comment


                  #9
                  Originally posted by cowinger View Post
                  I posted this a while back so I thought I would try again. If you are trying to use gmail in HS email you may have to go through a few steps to get it to work.

                  1. log into your gmail account with your current email address and pw
                  2. click on Sign-in & Security
                  3. select app passwords
                  4. have to put in your current gmail pw again
                  5. under 'select app' choose one of the entries or choose other and enter a name
                  6. under 'select device' you can do the same as with 'select app'
                  7. click on 'generate'

                  Use this code as your pw in HS for gmail instead of your usual gmail pw - THIS DOES NOT CHANGE YOUR ORIGINAL GMAIL PW TO LOG IN TO YOUR MAIL FROM A BROWSER. IT IS ONLY FOR APPS. GMAIL IS GIVING HS3 A SPECIAL PW TO USE THE MAIL.

                  Unfortunately, this no longer seems to work. Since a few days ago, nothing goes through on GMail, and the following error is generated:

                  Exception sending email via smtp.gmail.com (To:xxxxxxxx@xxx.com, cc:, bcc:, Sub:Test Alert, Attach = Authenticate as SSL client failed. You might be connecting to non SSL port.

                  This is using port 465, SSL enabled, using the generate application password for GMail.

                  I wish HomeSeer would setup and provide SMTP services for the users. It is getting to be so difficult to get SMTP services anymore without paying high rates for them, due to all of the spammers forcing everyone to close down free services.

                  Comment


                    #10
                    Just tested - still working. Settings attached

                    I don't do incoming.
                    Attached Files

                    Comment


                      #11
                      That's a SMTP server name I have never seen anywhere. Every reference states to use smtp.gmail.com. I will try that.

                      Comment


                        #12
                        Nope. Eventually, the connection timed out. I am surprised to find an open port 25 relay still in existence for Google, but it doesn't work for me.

                        Comment


                          #13
                          I checked the outbound firewall logs, and nothing on my side is blocking the traffic to smtp.gmail.com. It seems to be an authentication issue with GMail, but I tried both setting up the less secure app password, and disabling 2-Factor Authentication and allowing less secure apps.

                          The odd thing is, this worked fine until I upgraded to a newer version of HS3 (I think it was .409). When that was installed, I lost all of my custom log settings, my e-mail settings, energy settings, etc. I have made too many changes to try and roll back to a backup now.

                          xxx.xxx.x.xxx 173.194.197.108 ssmtp Allowed

                          Comment


                            #14
                            Much more straightforward if you just opt to use gmail's less secure apps configuration. If you use less secure apps, you won't have to worry about the HS email settings which I've always found to be flaky. See screenshot for auto settings. I have it working for both outgoing and incoming (see log).

                            You can avoid worrying about security issues by setting up a dedicated gmail account just for use on HS. This is what I've done from the start. This way, I keep all my HS alert emails and commands separate from my normal gmail account which is setup with 2 factor authentication.
                            Attached Files
                            Last edited by abwyatt; February 19, 2018, 02:45 AM.

                            Comment


                              #15
                              Originally posted by bebaldin View Post
                              I checked the outbound firewall logs, and nothing on my side is blocking the traffic to smtp.gmail.com. It seems to be an authentication issue with GMail, but I tried both setting up the less secure app password, and disabling 2-Factor Authentication and allowing less secure apps.

                              The odd thing is, this worked fine until I upgraded to a newer version of HS3 (I think it was .409). When that was installed, I lost all of my custom log settings, my e-mail settings, energy settings, etc. I have made too many changes to try and roll back to a backup now.

                              xxx.xxx.x.xxx 173.194.197.108 ssmtp Allowed
                              Could be, I'm still on .368.

                              I don't have two factor auth turned on, and I don't allow less secure apps. Frankly, I'm kind of surprised it works. I don't use it, but its nice to have.

                              BTW, the server name is aspmx.l.google.com - that's a lower case L, not a one (1) or uppercase I. All the password fields are blank.

                              Comment

                              Working...
                              X