Announcement

Collapse
No announcement yet.

Why is Duplicate Timer Device Created

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why is Duplicate Timer Device Created

    All:

    I searched the forums for something like this, but didn't find anything. I had a timer running when I stopped and then restarted HomeSeer yesterday. When HS came back up, there was indeed a timer device that had "persisted" over the restart, but it was a second device with the same name as the original device, but with a different Reference ID. The value/string of the newest timer device continues to increment, while the first device's value has stopped at the value it had just before the shut down. Is this the way timers "persist" over an HS shutdown? Can I just delete the older (first) device? Any information would be appreciated.

    Regards,
    BBB

  • #2
    That is not normal behavior. Sounds like a bug to me. Don't delete the original timer. See if you can reproduce this in a reliable way. If you can then submit a bugzilla report on it.
    Originally posted by rprade
    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

    Comment


    • #3
      Just to be clear, are you saying that the timer itself was duplicated (listed under the Timers tab) or that the HS device that matches the timer time reading (listed on the Device Management tab) was duplicated?
      If the latter, did the underlying timer continue to run after restart, and which timer device matches the underlying timer?

      _
      Attached Files
      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

      Comment


      • #4
        When you create a timer (or counter), HS3 will automatically create a device for it. This was behavior was added a year or two ago to provide a means of displaying realtime timer and counter data in HSTouch without having to resort to running a script continuously.
        Learn About HomeSeer

        Comment


        • #5
          Mark,
          That was my first reaction as well, but this line seems to imply it's something else, because both devices have RefIDs.
          . . .but it was a second device with the same name as the original device, but with a different Reference ID.
          That's what has me confused.
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

          Comment


          • #6
            All:

            Sorry to be unclear - hopefully the pictures will help. Under the Timers tab there is one timer named "RoombaTimer" - but in the devices tab there are two devices with the name "RoombaTimer".

            Click image for larger version

Name:	One_Timer.PNG
Views:	1
Size:	7.4 KB
ID:	1190931
            Click image for larger version

Name:	Two_Timer_Devices.PNG
Views:	1
Size:	14.3 KB
ID:	1190932

            The bottom device has Ref Id = 564, and the top one has a Ref Id = 570. After my initial post to this thread today, the "Let's Get Ready to Roomba!" event has occurred, which reset and restarted the RoombaTimer. The bottom RoombaTimer device has been locked at the 1:09:58:59 value since I shutdown and restarted HS yesterday afternoon; the top RoombaTimer device continues to match the value of RoombaTimer shown on the Timer tab. Note - the times of the timer and top device don't match in the pictures - I captured them at slightly different times - I guess I should have paused the timer...

            Regards,BBB

            Comment


            • #7
              One other note - the top device did not appear until HS was restarted yesterday afternoon.

              BBB

              Comment


              • #8
                Thank you for the carification. I agree with S-F. That is not normal behavior. I have never had that happen with any of the timers I have.

                Have you tried restarting HS since this happened to see if you can reproduce it?
                Mike____________________________________________________________ __________________
                HS3 Pro Edition 3.0.0.548

                HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

                Comment


                • #9
                  All:

                  I have tried reproducing the problem, but have been unable to. I guess I chalk it up to "software spirits" unless it happens again.

                  BBB

                  Comment

                  Working...
                  X