Announcement

Collapse
No announcement yet.

Fibaro Dimmer/Relay switch not sending status to HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fibaro Dimmer/Relay switch not sending status to HS3

    Hi all,

    So I am finally stabilising my Z-wave network since moving to z-net. I have an issue with the current stable release of the z-wave plug-in and have had to go on the beta version so whether this is the issue I'm not sure. Having said that, between the stable and latest beta, there are a lot of release log entries to do with fixing Fibaro module compatibility so I would expect it would work better.

    So in short, the issue is that none of the relays or dimmer 2 modules send HS3 the status when controlled by the switch connected to the module.

    Example:
    Via HS3 Web: Turn on changes icon and status to On also showing monitoring for power consumption.

    Turn off via wall switch: HS3 still shows it as on and even shows power consumption even though light is off.

    Turn off via HS3 Web: HS3 shows off and power consumption stops

    Turn on via wall switch: Light is on but HS3 thinks it's still off.

    I came across a thread regarding group 3 associations but I have no idea what I am doing.
    I did attempt it yesterday and I think it did work but I'm unsure what exactly I did as I can't see the changes.

    What I did:
    1. Went to the root device for a light module>zwave tab
    2. Rescan and opened up Associations
    3. Deleted Group 5,4,3,2
    4. Set Association Group to 3 in the drop down box. Left everything else I think to default and hit Add Association.
    5. This now seemed to pick it up the status.

    I've just gone back to that root device and did a rescan to find all 5 groups are back under Existing Associations. I will test again tonight when I get home if the switch status even works anymore to confirm...


    So am I on the right track and if so, what exactly am I meant to do with the associations?
    I'm convinced this group 3 association is what I want, just don't know what I am supposed to do or how it should look at the end

    Thanks all!

  • #2
    Maybe this is the same problem as my post that the Fibaro relay always shows status "Unknown" : https://forums.homeseer.com/node/1239269, although I'm getting OK control just the wrong visual indication.

    Comment


    • #3
      In my case it was not unknown but just would not move the status to on/off despite the change unless done by HS.
      My issue is resolved now - I ditched the Homeseer z-net and went to a USB Aeotec z-stick. I always had this device but went to z-net for the network ability but with all these issues and not much hope in resolving it both from forum threads (not the fault of anyone here!) and HS themselves, I ditched it and went back knowing before I switched, it DID work.

      Soon as I switched, things have all worked - all instant status has worked straight away without any changes or polling enabled.
      Even the stabiltiy has been much better and all the delays both random and long term vanished too.

      I may if I get a chance insert the z-stick where the znet was and report back especially on the instant status side of things.

      Comment


      • #4
        You should still file a bug - HomeSeer don't seem to understand they have a problem here, and it's horrific given if you were to buy a Z-Wave.ME UZB for example (or the stick you have bought) with latest ZDK on it that HomeSeer doesn't detect live changes. Actually it DOES - for FIVE seconds after inclusion, after that it stops. Using any stick that has an older ZDK works, newer exhibits this problem. So out of the box you can't actually use HomeSeer with latest release sticks, and they aren't understanding or caring about that.

        HOWEVER, the problem seems to be fixed in HomeSeer's S1 Z-Wave beta - but while fixing that, the beta introduces a new problem - the second switch on dual switch devices is missing. eg you install a dual-switch or dual-relay device and only one of them shows. Likewise hitting an incredibly hard brick wall trying to sort that with HomeSeer support.

        Having just defected from Vera who are losing customers faster than you can count because of exactly this kind of customer service, I'm incredibly disappointed and concerned...

        So file bug reports so they hopefully realise how big an issue these are...

        Comment


        • #5
          Originally posted by Tillsy View Post
          eg you install a dual-switch or dual-relay device and only one of them shows. Likewise hitting an incredibly hard brick wall trying to sort that with HomeSeer support.
          I had a issue some time ago with a Aeon dual switch, and only 1 switch being created in HS. Updating the switch firmware and re including it into the network resolved it.

          Comment


          • #6
            In the case of the issues I had, HS are fully aware of it as we had a long standing support email game of tennis going on trying different things etc without avail.

            Megaman: in the case of your comment, I guess this is fine if the devices are homeseer. Unless I am missing something, with Fibaro devices, you need a fibaro controller to update the firmware.
            If it's Aeotec, you need a aeotec z-stick to update those - From what I gather, this is because Fibaro/Aeotec and others do not share the firmware files but happy to be corrected.

            Comment


            • #7
              Quick update on this - Ever since I moved from Fibaro to Homeseer, I have never got the status updates to work with my relay switches (Fibaro).
              We tried a whole host of things and Homeseer support were for this issue, not at all helpful. Vesternet did help a fair bit more but we never got this resolved.
              Fibaro being Fibaro, unless anything has changed, you cannot update the firmware on Fibaro devices unless you use a Fibaro controller so that was out the window.

              I tried a whole load of z-wave versions from signed-off to beta to signed-off but no luck.
              We changed associations etc but no luck.

              What this essentially meant is anything switch related whereby I wanted to create events based on whether a switch was on/off could never be done. My motion events I created from a fantastic thread on here also has an over-ride for toggle switch (to switch off motion) but that never worked with the relays as HS could not tell the status.

              Polling was not an option for obvious reasons.

              Fast forward to yesterday, had a bit of time and started messing around with associations again. Despite doing this numerous times from advice on here previously and failing, I could not believe my luck when it worked.

              My steps:
              By default there were 3 existing associations on all 8 of my Fibaro relays:
              Group 1: HomeSeer (ID:1, endpoint=1)
              Group 2: HomeSeer (ID:1, endpoint=2)
              Group 3: HomeSeer (ID:1)

              I deleted Group 3
              On refresh, I could see only Group 1 and 2 as expected.

              I then added Group 3 > Homeseer > Endpoint 1

              On adding it, it came back saying Associate <Device> with HomeSeer at Endpoint 1 at group 3
              Result: Associate set successfully.

              This does NOT seem to create a Group 3 when the page refreshes despite the message above however...status callback now works!

              I went around to the other 7 relays and every single one now works.

              For the double switch relays, I did exactly the same but on adding the new one:
              Group 3 > Homeseer > Endpoint 1
              Group 3 > Homeseer > Endpoint 2

              (Added it for both Endpoints). Again, it came back saying it did it but does not show on the screen.

              Much much happier now that it works !


              Sorry for the long reply but hopefully it helps others out

              Comment


              • #8
                Originally posted by aj84 View Post
                Sorry for the long reply but hopefully it helps others out
                A long reply is absolutely not a problem when it helps so much !! Thanks a lot. It works for my 14 Fibaro Relay. It as been a long time that it didn't work so smooth.
                Thanks again.
                Hope the next Zwave plugin won't destroy all again...

                Comment


                • #9
                  Thx for sharing. Hope this fixes my issue where the state of a toggle switch is sometimes not updated...

                  Comment

                  Working...
                  X