Announcement

Collapse
No announcement yet.

Alexa device type is other

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alexa device type is other

    My friend uses Nexia and has his z wave devices connected to Alexa. He has an echo in each of his groups (e.g. his kitchen lights) and when he talks to that echo, he can just say "turn off/on the lights" and it does because it knows that echo is in a group.

    Mine doesn't do that...and we traced it to the fact that all of my switches in Alexa connected through homeseer are of type Other. Not type Light (or switch). Is this a bug in the Homeseer integration? How do I get these types updated so Alexa sees them properly?

  • #2
    This is not a direct answer to your question, but may be of use. I'm using the SmartHome skill (only) and haven't tried the other two.

    Have you tried to change the device type in the Alexa app? I'm able to click on the Type in device settings and select Light or Switch. But all mine came in as either lights or switches so I don't have an "Other" to test my ability to change it, and that may make a difference.

    I've "forgotten" and re-added my devices (90 or so) several times and they have all always come in as switches or lights. If you haven't done it yet, you might try forgetting and refinding them and see if they come in again as Other. You could also try disabling and reenabling the Alexa skill. I find it easiest to forget large numbers of devices using the alexa web interface (alexa.amazon.com) using the "forget all" button at the bottom of the device list.
    Last edited by cc4005; July 27th, 2018, 02:52 PM. Reason: revised # devices
    -Wade

    Comment


    • #3
      Unfortunately tried that. Can't change from other, and rediscovering has same issue

      Comment


      • #4
        bump

        Comment


        • #5
          Which Alexa skill are you using, "HomeSeer" or "HomeSeer SmartHome"?

          Have you confirmed in the device properties (in HS3 UI) that the "Is Light" check box is ticked on the configuration tab?

          Comment


          • #6
            Hi Fellhahn - I have both "HomeSeer" and "HomeSeer Home Automation Skill" installed.

            Didn't know the "Is Light" checkbox was a thing. Looks like none of my switches have that checked. I added all of those using Z-Tool, and they are Homeseer HD200 and HS100 switches. Is that maybe a bug in z-tool?

            I can go manually update them (ugh; I have like 94).....which devices need to be set that way? Just the light objects, or also their associated root and central scene devices?

            Comment


            • #7
              Hmm - I tried changing a light object to IsLight = checked and then did a rediscover but it's still listed as type=other....

              Comment


              • #8
                Anyone else having this issue? Should IsLight be enough to fix it? I tried updating devices in Alexa multiple times (and I know it worked because I also minorly adjusted the name at the same time) but it’s still coming in as device other.

                Comment


                • #9
                  Originally posted by larrywal32 View Post
                  Hi Fellhahn - I have both "HomeSeer" and "HomeSeer Home Automation Skill" installed.

                  Didn't know the "Is Light" checkbox was a thing. Looks like none of my switches have that checked. I added all of those using Z-Tool, and they are Homeseer HD200 and HS100 switches. Is that maybe a bug in z-tool?

                  I can go manually update them (ugh; I have like 94).....which devices need to be set that way? Just the light objects, or also their associated root and central scene devices?
                  Hi, sorry I missed this initial response and only read your second one.

                  You should see three HomeSeer skills available within Alexa:



                  "HomeSeer Home Automation" is the "ask homeseer" skill that allows detailed control/event triggers.

                  The other two are variations of the same skill, allowing native control of HS devices from Alexa "... turn on the kitchen light".

                  Why there are two and why HST hasn't removed the older one, I don't know. I've been told in other threads that "HomeSeer SmartHome" is the newer of these two skills. That's the one I currently use and all my virtual devices and z-wave switches appear as device type "switch" within the Alexa app. I have the option of changing this to type "Light" within the Alexa app.

                  If you are going to disable one skill and enable another, be cautious. I would suggest deleting all your discovered devices from within Alexa before disabling. When I switched, I had to deal with a weird buggy effect where Alexa would say "a few devices share that name" to every command. Seems disabling the old skill without deleting the devices left some phantom entries within Alexa's database.

                  Comment


                  • #10
                    What the hell am I doing wrong with the photo embedding? This used to be easy.

                    Comment


                    • #11
                      Hmmm. I don’t see homeseer smarthome. Any clue why? Weird.
                      Attached Files

                      Comment


                      • #12
                        Originally posted by larrywal32 View Post
                        Hmmm. I don’t see homeseer smarthome. Any clue why? Weird.
                        Be sure you're searching "All Skills". Looks like you may be searching "Your Skills" in which case it would mean you have both those skills installed.
                        -Wade

                        Comment


                        • #13
                          BTW, I've read that having both Homeseer SmartHome and Homeseer skills installed at the same time can lead to problems. So you may want to remove any/all Homeseer skills you have installed before installing Homeseer SmartHome...subject to Fellhan's caution a couple posts back.
                          -Wade

                          Comment


                          • #14
                            Wow. Definite facepalm. Good catch, thanks cc and Fellhan.

                            So I think I've got this:
                            1. Remove all devices
                            2. Remove Homeseer skill
                            3. Add Homeseer smart home skill

                            Wish me luck. Also....assuming this works, would be great for Homeseer to comment on why this confusion exists....I can't be the only one to get bitten by it.

                            Comment


                            • #15
                              Hmm - another dumb question - is there an easy way to remove all devices other than 1 by 1?

                              Comment

                              Working...
                              X