Announcement

Collapse
No announcement yet.

Startup Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Startup Problem

    Getting the following on startup:

    7/30/2018 10:05:47 AM ~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. The requested address is not valid in its context
    7/30/2018 10:05:47 AM ~!~Warning~!~Web Server Stopped


    I have changed the port # from 80 to 81, to no avail.

    The last time this happened (just a few weeks ago), it was because I had started fooling around with Blue Iris, and apparently that raises a webserver by default, so I had an IP conflict. This time, it's a port conflict, even though Blue Iris is not even running.

    Is there a way of telling what programs are using a particular port #?



    Jim Speiser
    30-year veteran of Home Automation
    Still don't know squat

  • #2
    https://superuser.com/questions/1025...hem-in-windows

    Comment


    • #3
      OK. I used perfmon /res to look up network connections. It says nothing is using port 80 or 81.

      Now what?


      Jim Speiser
      30-year veteran of Home Automation
      Still don't know squat

      Comment


      • #4
        Hmm, how are you reading the log, if the web server isn't running?

        Comment


        • #5
          The startup log.


          Jim Speiser
          30-year veteran of Home Automation
          Still don't know squat

          Comment


          • #6
            Originally posted by JimSpy View Post
            OK. I used perfmon /res to look up network connections. It says nothing is using port 80 or 81.
            What if you try a higher port, say 8008 or 8080?

            Mike____________________________________________________________ __________________
            HS3 Pro Edition 3.0.0.548

            HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

            Comment


            • #7
              Worth a try. Will report back soonest.


              Jim Speiser
              30-year veteran of Home Automation
              Still don't know squat

              Comment


              • #8
                Ok, new problem. I can't stop HomeSeer.

                I bring it down, edit the settings.ini, and click it on again, it says "HomeSeer HS3 is already running!" I look in Task Manager, it's not there as an application, but the process shows up, so I "End Task," it won't stop. I can stop the Speaker.exe and the Insteon plugin, but not the HS3 process.

                This tells me we have a major FUBAR somewhere. Anyone have any experience with this?



                Jim Speiser
                30-year veteran of Home Automation
                Still don't know squat

                Comment


                • #9
                  The good news is, port 8008 works, I can pull up the web interface now. So there's that...


                  Jim Speiser
                  30-year veteran of Home Automation
                  Still don't know squat

                  Comment


                  • #10
                    Do you have the HSSentry enabled? (Setup->General tab). If so, I think that needs to be stopped via taskmgr before HS3 can be stopped.

                    Comment


                    • #11
                      I don't think so, but I will check...


                      Jim Speiser
                      30-year veteran of Home Automation
                      Still don't know squat

                      Comment


                      • #12
                        I don't know what this is, but I have the feeling it has to do with an IP Camera, which also uses Port 80 (but always has, and was never a problem.) In any case, we can close this discussion.


                        Jim Speiser
                        30-year veteran of Home Automation
                        Still don't know squat

                        Comment

                        Working...
                        X