Announcement

Collapse
No announcement yet.

HS3 Pro Keeps crashing every few days

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Pro Keeps crashing every few days

    Hi all

    In the last few weeks I have been experiencing repeating crashing of the HS3 Pro Software

    Anyone can help as the system is becoming unusable and it use to be very robust and dependant

    I ran HS3 Pro Version 3.0.0.425 - on HomeTroller S6 PRO Windows Embedded PC 2010 SP1

    See the latest info I got in the attachment/picture below

    The problem signature displays the following:
    "Problem signature:
    Problem Event Name: APPCRASH
    Application Name: HS3.exe
    Application Version: 3.0.0.425
    Application Timestamp: 5ace2b62
    Fault Module Name: KERNELBASE.dll
    Fault Module Version: 6.1.7601.24168
    Fault Module Timestamp: 5b1aa77b
    Exception Code: e0434352
    Exception Offset: 0000845d
    OS Version: 6.1.7601.2.1.0.320.65
    Locale ID: 2057
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?link...8&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt"

    Click image for larger version

Name:	HS3 Crash.JPG
Views:	100
Size:	60.5 KB
ID:	1237238

    After I clear the message and restart HS3 then a error message also appears as shown below, and I am forced to reboot the whole system?

    "Starting up....
    30/07/2018 19:23:18 ~!~Error~!~Unable to start plug-in API: Only one usage of each socket address (protocol/network address/port) is normally permitted
    Startup Complete, 1 errors detected, check the log for more information."


    Any help is greatly appreciated to resolve this

    Thank you in advance

    ​​​​​​​Vas


  • #2
    Yes, for the first time ever for me, HS3 is crashing randomly and daily; using .460

    Comment


    • #3
      I am not seeing crashes: but every so often the HSPI Zwave process goes to 100%: and then occasionally my UPS plugin will misbehave: and I cannot reboot homeseer as after I close it: it tells me it is still running when I reopen it. I can't manually kill it and it calls for a reboot. I installed jon00 performance tools and will see if I can find any connections....
      HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

      Plug-Ins Enabled:
      Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
      weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

      Comment


      • #4
        Might be worth reverting to the last stable version of HS3 unless you are helping with beta testing or need your current version for some particular reason. Beta versions shouldn't be used in a stable working environment and you can expect crashes for no particular reason.

        Comment


        • #5
          I am not aware I am on a beta version - I have only updated HS through the online update the system proposes and nothing else?

          Is version 3.0.0.425 a beta version? Is it the latest version?

          How can I go back and to which version?

          Thanks

          vas

          Comment


          • #6
            I am having crashes suddenly as well.

            Comment


            • #7
              MY HS3 on Win7 recently started BSODing regularly. Crashdmp pointing to vmware vmmect.sys

              Comment


              • #8
                The VMWare tools update recently? I imagine you are running under ESXi.

                I have stopped logging into my Homeseer box through Remote Desktop and instead use VMWare if I need access. Some of my issues seemed to have improved since I have been doing so.
                HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                Plug-Ins Enabled:
                Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                Comment


                • #9
                  Interesting. I am running under ESXi as well.

                  wpiman you figured out it was a VMWare tools update??!!! :O

                  Comment


                  • #10
                    Have you tried to update the NET Framework and Java?

                    Comment


                    • #11
                      So I just had one of my "events" where HS will lose its mind. The CPU jumps up and for some reason the APC Plugin is the first victim. It reports it cannot talk to the UPS, but the connection is fine. I cannot reboot any plugin or Homeseer to get it to work-- but a reboot of the VM will do it.

                      I checked the windows log-- and I noticed some HCMON event warnings in the log. I looked into it: and I am trying to shut off the service "VMWARE USB ARTIBITRATION SERVICE". Not sure if anyone else has this service running or not.



                      Originally posted by fksk View Post
                      Interesting. I am running under ESXi as well.

                      wpiman you figured out it was a VMWare tools update??!!! :O
                      I am not 100% sure. I don't think VMWare tools updated recently-- though I will check when I get home.

                      I did have a Anywhere USB that was incompatible with VMWare tools. I had to upgrade the firmware on the box. That was a couple of months ago.

                      Are you using any USB devices? How so? Pass thru?

                      My problem was the hspi_zwave task would just consume 100%: and that seems to have subsided. I also have an issue where I will quit Homeseer, and I cannot reboot it as the process is still running. I can kill it and HS Sentry and it still perisists. Takes a reboot.

                      I have actually been running Blue Iris on the same VM and the process utilization has gone up quite a bit. That seems to have made things better actually...
                      Last edited by wpiman; August 27th, 2018, 10:45 AM.
                      HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                      Plug-Ins Enabled:
                      Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                      weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                      Comment


                      • #12
                        Anyone figured anything else out?

                        I am getting fairly disparate issues all of the sudden. Some of the things that have happened more than once, with some happening frequently:

                        1. HS3 Pro locks up when started manually.
                        2. HS3 Pro locks up when being managed/started/controller by FireDaemon
                        3. Losing connectivity to my OmniPro II panel via OMNI plugin.
                        4. Z-Wave plugin pooping the bed.
                        5. This morning I logged on and ALL of my plugins went goofy, AKA when I go to the plugin management page via the webtop, it gave the 'waiting for plugin to start' or whatever that status message is for all of them. I killed the FireDaemon process and restarted HS3 with it. Boom everything up.

                        Comment


                        • #13
                          What is your base OS?
                          Are you running 32 bit or 64 bit?

                          I used to use FireDaemon many many years ago running HS3 on Windows Server 32 bit and did not have issues.

                          Today to autostart my Homeseer Windows touchscreen HSTouch and HS-Speaker tabletop touchscreens utilize R2 Studios Start up delayer free.

                          Tested HS3 running in XP SP3, W7 Pro 32bit or 64bit and W10 Pro 32bit or 64 bit in Oracle Virtual box running on Ubuntu 18.04 64 bit to run fine.

                          Remote plugins run here on a mini Windows Server 2003 lite 32 bit (VB or standard hardware) Windows 10 32 bit (VB or standard hardware).

                          My personal preference is to run any HS3 stuff in Windows 32 bit. I am though running HS3 Pro / Lite in Linux Ubuntu 18.04 64 bit today.

                          - Pete

                          Auto mator
                          Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
                          Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

                          X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                          Comment


                          • #14
                            Win Server 2012 64 as a VM on VMWare ESXi.

                            Need to get this stable and then will enable it for VMotion to ensure uptime even with server hardware failures.

                            Comment


                            • #15
                              Here running .435 on Windows 2016 Server (64 bit of course), running as a Fire Daemon service.
                              As you can see, it's kinda rock solid. Need to take down this weekend for updates.
                              I'd go with updating the .NET framework personally...

                              Robert
                              System Information
                              Current Date/Time: 8/17/2018 3:05:36 PM Eastern Daylight Time
                              HomeSeer Version: HS3 Pro Edition 3.0.0.435 (Windows)
                              HomeSeer: Is Registered
                              Operating System: Microsoft Windows Server 2016 Standard - Server
                              OS Version: 10.0.14393 Service Pack: 0.0
                              System Uptime: 47 Days 2 Hours 40 Minutes 12 Seconds
                              HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                              Comment

                              Working...
                              X