Announcement

Collapse
No announcement yet.

Homeseer 200 dimmer does not trigger events

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Homeseer 200 dimmer does not trigger events

    I have an event that I would like to trigger whenever the value of my 200 series dimmer changes (whether an event changes it, or directly in homeseer, or manually by pushing the toggle, or by holding the toggle to update dim level). All of these seem to work except the last one. When holding up or down on the switch to adjust dim setting, it will not trigger an event with any of these triggers:
    This device changes and becomes...
    This device had its value set to...
    This device just had its value set or changed.

    Am I doing something wrong?

  • #2
    Originally posted by smikkelsen View Post
    I have an event that I would like to trigger whenever the value of my 200 series dimmer changes (whether an event changes it, or directly in homeseer, or manually by pushing the toggle, or by holding the toggle to update dim level). All of these seem to work except the last one. When holding up or down on the switch to adjust dim setting, it will not trigger an event with any of these triggers:
    This device changes and becomes...
    This device had its value set to...
    This device just had its value set or changed.

    Am I doing something wrong?
    On a dimmer, this is a very timing critical function. On mine, the key held down scenes are only sent if the button is held for slightly longer than it takes to start dimming level change. It takes a second or two before the dim level begins changing. I would guess the button has to be held for a second or two longer than it takes to begin changing dim level. It will not register key held down when slightly adjusting dim level. The dimmer will register the key released scene after the key is held long enough to adjust dimming. If you could take a tablet or laptop near the dimmer and watch the dimmer in the Device Manager, you can get a handle on the timing of these scenes.

    These scenes are only sent when the device is controlled locally, they are not sent when the device is controlled by an event.

    There is a trigger “This device has a value that just changed” which could be used to trigger when the device is controlled locally or by event.
    Last edited by rprade; August 23rd, 2018, 08:29 AM.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      As mentioned above, one of the 3 triggers i tried is "This device just had its value set or changed" and this does not fire holding down the dimmer to set the level. It does not matter how long or short I hold the switch down to set brightness level, this trigger will not run.

      Thanks
      Attached Files

      Comment


      • #4
        The Central Scene Device on all of my HomeSeer dimmers trigger correctly on every value. I have no idea why yours don’t, if you see the Central Scene Device changing values. Can you post a screenshot of the entire event that doesn’t run?
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          I think we are talking about two different things. You are referring to the central scene device, i'm referring to the device that has the light value associated with it (not the scenes).

          I understand that I can trigger events on toggle held down on central scene, but that is not what I want. I simply want an event to trigger when the light value on my light device changes (for any reason).

          Example:
          my light device is set to 100% (full bright)
          i go hold down the down toggle till it reaches 50%
          my light device now says 50%
          Seeing as how that device changed in value, I very much expect the trigger "this device just had its value set or changed" to do something.

          Am I wrong in this thinking?

          Thanks for the replies.

          Comment


          • #6
            Got it. I was misreading your question in the first post. I made the mistake of assuming because it was an HS-WD200+ that you were using the Central Scene Device. Any of the triggers you mention should work. I just built a test event using an HS-WD200+ and it triggers on “set”, “set or changed”, “set to greater than” and “set to less than” and they all worked as expected.

            Could you post a screenshot of an event that doesn’t work? These things are usually easy to diagnose by looking at the Event, log entries and device behavior in the Device Manager.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Click image for larger version  Name:	 Views:	1 Size:	33.9 KB ID:	1243242
              See attachment. This event works just fine. I've tried it with both 100 and 200 series dimmers. So, if it's not working for you, update your Z-Wave plug-in (if it's older) and check the HS3 status of the device after you control it manually. Make sure the status is actually updating.
              website | products | support | youtube

              Comment

              Working...
              X