Announcement

Collapse
No announcement yet.

Setting up Windows 10 for HS3 Pro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting up Windows 10 for HS3 Pro

    So I've been going through all the pages in this area and can not seem to find any specifics on steps to take to help HS3 Pro function at it's max on Windows 10.

    What I've done so far:
    Windows 10 Pro

    -Edit Power Plan > Advanced > High Performance > Hard Disk: 0 > Sleep: Never (all options) > Processor Power Management: 100% (all options)

    -Device Manager > USB Controllers > (check each item under this section for Power Management tabs) > un-check "Allow the computer to turn off this device to save power".

    -Device Manager > Network Adapters > (check each item under this section for Power Management tabs) > un-check "Allow the computer to turn off this device to save power".


    -Create a Task in Task Scheduler to Run at Startup > un-check "End Task after 3 days" > finish creating the task > select the task >
    1. Right click on the task and "export" it
    2. Edit the task.xml file that you just exported
    3. You will find a line similar to <Priority>7</Priority>
    4. Change the value to a normal priority (between 4-6). A table of the potential values: TaskSettings.Priority property
      • A value of 4 will have the same I/O and memory priority as an interactive process. Values of 5 and 6 will have lower memory priority
      • I set it to 4
    5. In the task scheduler, delete the task you initially created
    6. In the task scheduler, in the actions area, import the task from the XML file

    -Turn off windows Tips: Start > Settings > System > Notifications & actions and toggle off "Get tips, tricks and suggestions as you use Windows"

    -Uninstall Windows Apps: Start > Settings > Apps > Apps & features > remove all the apps you can.


    Any other ideas to help stop the system from lagging or doing something other then just working on HS3 Pro?
    Last edited by Integraoligist; November 16th, 2018, 10:49 AM.

  • #2
    Originally posted by Integraoligist View Post
    Device Manager > Network Adapters > (check each item under this section for Power Management tabs) > un-check "Allow the computer to turn off this device to save power".
    If you're using an Aeotec z-wave controller, also do the above for Ports > Silicon Labs CP210x USB to UART bridge

    Fred
    Fred

    HomeSeer Pro 3.0.0.478, HS3Touch, Zwave 3.0.1.252, Envisalink DSC 3.0.0.40, WeatherXML, Z-stick, HS phone, Way2Call

    Comment


    • #3
      If you are using Task Scheduler, be sure it isn't configured to end the task after 3 days. That is the default for some versions of the Windows OS.

      Comment


      • #4
        Thanks! Yes I did have it starting with Task Scheduler and already had the "end task after" un-checked... but I did not know about the Prioritization. I changed it to 4 as they says that for an "interactive task". Would setting it to 0, "REALTIME_PRIORITY_CLASS" cause issues with the system?

        Still crawling the web to see if there are any other things to make 10 as bare bones as possible for HS3... other thoughts? I'm updating the OP at I go.

        Comment


        • #5
          Don't forget to enter the HomeSeer 3 directory ( i.e. C:\Program Files (x86)\HomeSeer 3) without quotes in the Action->Start In (optional) field.
          I would have thought that it would have assumed the start directory to be the same as the exe directory, but without specifying that, I would get errors in the log saying that Scheduler.dll could not be found.

          Comment

          Working...
          X