Announcement

Collapse
No announcement yet.

Z-NET IP-enabled Z-Wave interface

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Z-NET IP-enabled Z-Wave interface

    I purchased this to try to improve the transmissions to some areas of my property.
    I have added as a controller ok using dhcp, static and wifi, but it always comes in as main. I was planning on leaving my existing UZB as 'master' and having this as a 'slave'.
    As slave it would have 0 nodes (except self) until I added to it
    So obviously I have misunderstood the usability of the Z-Net particularly as it came with a UZB attached.
    So can I use Z-net as a slave in my network or do I replace my current controller with Z-net+UZB. If the latter then I am probably no better off as I an just moving the radio point about.
    Would appreciate advice on where I am getting this wrong.

  • #2
    You have a couple options actually.

    1. Add it as a primary to it's own network. This can co-exist with your UZB but they will be on different z-wave networks. You can still control all devices and get status from the HS3 interface.

    2. Add it as a secondary inclusion controller for the main UZB. This will show as a 'controller' in the list but it can be used to add/remove devices and you can set devices to use this for the return routes.

    I have tried both methods and I prefer option 1. It segments the z-wave network and provides benefit of 2 networks thus also doubling the number of devices you can have. A Z-wave controller or network has a limit of 252 devices. So having 2 networks gives twice the device capability. The downside to option 1 is that you must specify which controller you are adding/removing a device to and then you must be somewhat near that device. As they are two networks traffic does NOT route between them and they are independent.

    I'm sure others will add more to this.

    Comment


    • #3
      So decided to try option 2 to see how it went.
      Include/Exclude ok and improved comms to remote nodes seems better.
      However I keep getting the following in the log.
      It can go on for a couple of hours then the interface reloads and its normal for many hours.
      Feb-28 19:18:39 Z-Wave Warning Z-Net Interface Dining Room: Cannot connect to Z-Wave Ethernet at IP 192.168.1.16 port: 2001, Ex=No connection could be made because the target machine actively refused it 192.168.1.16:2001
      Feb-28 19:18:33 Z-Wave Warning Trying to re-connect to Ethernet interface at IP 192.168.1.16...
      Feb-28 19:18:33 Z-Wave Note: Only one system may connect to an Ethernet interface at one time. If 2 systems are connecting to your Z-Wave interface, HomeSeer will not connect.
      Feb-28 19:18:21 Z-Wave Z-Net Interface Dining Room: Getting node information from controller...
      Feb-28 19:18:21 Z-Wave Z-Net Interface Dining Room: Z-Wave Ethernet at IP 192.168.1.16, connected to interface ok.
      Feb-28 19:18:10 Z-Wave Warning Z-Net Interface Dining Room: Cannot connect to Z-Wave Ethernet at IP 192.168.1.16 port: 2001, Ex=No connection could be made because the target machine actively refused it 192.168.1.16:2001

      What is the significance of only one Ethernet connection at a time.
      The warning comes with static IP and DCHP.
      Doesnt seem to effect performance but it is clogging up the log.

      Appreciate any advice

      Comment


      • #4
        What version of the z-wave plugin are you running?

        Comment


        • #5
          Sorry - keep forgetting

          Current Date/Time: 01/03/2019 05:36:49
          HomeSeer Version: HS3 Pro Edition 3.0.0.500
          Operating System: Microsoft Windows 10 Pro - Work Station
          System Uptime: 0 Days 17 Hours 18 Minutes 35 Seconds
          IP Address: 192.168.1.44
          Number of Devices: 129
          Number of Events: 137
          Available Threads: 400
          HSTouch Enabled: True
          Event Threads: 0
          Event Trigger Eval Queue: 0
          Event Trigger Priority Eval Queue: 0
          Device Exec Queue: 0
          HSTouch Event Queue: 0
          Email Send Queue: 0
          Anti Virus Installed: Windows Defender
          In Virtual Machine: No MFG: dell inc.
          Enabled Plug-Ins
          2.0.59.0: BLBackup
          1.0.4.0: BLShutdown
          5.0.0.59: Global Cache Pro
          5.0.0.22: Global Cache
          3.9.610.5: HSBuddy
          1.0.0.7: Restart
          3.0.6.8: SDJ-Health
          3.0.0.36: X10
          3.0.1.252: Z-Wave

          Comment


          • #6
            If you are connecting via wifi, you might benefit from the "communication patch". This was added to the Z-Net firmware as result of investigations by various board members back in 2016. For reasons unknown it was left out of the current Z-Net 1.0.23 build.

            You'll need to gain command line access. Try username=pi password=raspberry

            Once you gain access, I can guide you on what changes to make. Alternately you can download the znetcare package from here: https://forums.homeseer.com/forum/ho...33#post1094633

            Comment


            • #7
              Thanks for the reply.
              Am able to access z-net as administrator using command line.
              Have also downloaded znetcare but its not obvious what to do.
              So I am up for guidance if you are

              Comment


              • #8
                You'll need to copy the znetcare-r2.zip file over to the Z-Net. You can use WinSCP for this.

                Once you get the file transferred, unzip and run as follows

                Code:
                unzip znetcare-r2.zip -d znetcare
                cd znetcare
                make info
                Post results and I'll advise on following steps.

                Comment


                • #9
                  OK
                  This is the result

                  pi@Z-NETv2DiningRoom:~ $ unzip znetcare-r2.zip -d znetcare
                  Archive: znetcare-r2.zip
                  inflating: znetcare/Makefile
                  inflating: znetcare/ser2net.md5
                  inflating: znetcare/znet_info.sh
                  inflating: znetcare/znet_patch.sh
                  inflating: znetcare/zled
                  pi@Z-NETv2DiningRoom:~ $ cd znetcare
                  pi@Z-NETv2DiningRoom:~/znetcare $ make info
                  ./znet_info.sh

                  Z-Net version 2 revision 1.0.23

                  No internal (GPIO) serial device detected.
                  External (UZB) device detected.

                  ser2net port 2001 timeout (seconds): 0 - (per rev. 1.0.18 and prior, and 1.0.23) - not recommended (timeout disabled)
                  /usr/local/sbin/ser2net does not have the patch added in rev. 1.0.21/1.0.22.
                  pi@Z-NETv2DiningRoom:~/znetcare $ pi@Z-NETv2DiningRoom:~/znetcare $ make info
                  -bash: pi@Z-NETv2DiningRoom:~/znetcare: No such file or directory
                  pi@Z-NETv2DiningRoom:~/znetcare $ ./znet_info.sh

                  Z-Net version 2 revision 1.0.23

                  No internal (GPIO) serial device detected.
                  External (UZB) device detected.

                  ser2net port 2001 timeout (seconds): 0 - (per rev. 1.0.18 and prior, and 1.0.23) - not recommended (timeout disabled)
                  /usr/local/sbin/ser2net does not have the patch added in rev. 1.0.21/1.0.22.
                  pi@Z-NETv2DiningRoom:~/znetcare $
                  pi@Z-NETv2DiningRoom:~/znetcare $ Z-Net version 2 revision 1.0.23
                  -bash: Z-Net: command not found
                  pi@Z-NETv2DiningRoom:~/znetcare $
                  pi@Z-NETv2DiningRoom:~/znetcare $ No internal (GPIO) serial device detected.
                  -bash: syntax error near unexpected token `('
                  pi@Z-NETv2DiningRoom:~/znetcare $ External (UZB) device detected.
                  -bash: syntax error near unexpected token `UZB'
                  pi@Z-NETv2DiningRoom:~/znetcare $
                  pi@Z-NETv2DiningRoom:~/znetcare $ ser2net port 2001 timeout (seconds): 0 - (per rev. 1.0.18 and prior, and 1.0.23) - not recommended (timeout disabled)
                  -bash: syntax error near unexpected token `('
                  pi@Z-NETv2DiningRoom:~/znetcare $ /usr/local/sbin/ser2net does not have the patch added in rev. 1.0.21/1.0.22.


                  Comment


                  • #10
                    OK, as expected you don't have the patch installed. To install,

                    Code:
                    sudo make install
                    Then run the previous command to verify

                    Code:
                    make info

                    Comment


                    • #11
                      And below confirms patched

                      pi@Z-NETv2DiningRoom:~/znetcare $ make info
                      ./znet_info.sh

                      Z-Net version 2 revision 1.0.23

                      No internal (GPIO) serial device detected.
                      External (UZB) device detected.

                      ser2net port 2001 timeout (seconds): 120 - recommended value
                      /usr/local/sbin/ser2net has the patch added in rev. 1.0.21/1.0.22.
                      pi@Z-NETv2DiningRoom:~/znetcare $

                      Thanks for your help.
                      Will monitor the log today and see how it goes
                      Appreciate the guidance

                      Comment


                      • #12
                        Great! FYI, the benefit of the patch is to allow faster reconnection after a communication interrupt. It you are having frequent interruptions, it might be due to spotty wifi coverage. If you can manage to run it wired it will most likely eliminate that.

                        Comment


                        • #13
                          Just added the patches to my three Z-Nets without any hitches. Instructions were easy to follow. Thanks zwolfpack!

                          Comment

                          Working...
                          X