Announcement

Collapse
No announcement yet.

HS3Pro always has a lag in both Windows 10 and Server 2016

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3Pro always has a lag in both Windows 10 and Server 2016

    Hi all, so I'm always running the latest updates for HS3Pro and using the SmartStick+ USB. The server is located right in the middle of the home and almost all (33 out of 36 devices) connect to the SmartStick+ directly (no hops).

    The issue has always been that HS3 lags like 60% of the time. So when I open a door, sometimes the speaker will say "door open" immediately... but most of the time it will lag and not say it for maybe 10-20 seconds. Sometimes it will even build up commands and all do them at once, example... open door 1, then door 2 then door 3... then when door 3 opens it will say Door 3 open, door 1 open, door 2 open. You get the idea.

    I originally had my setup on a standard desktop running Windows 10 Pro with all my other apps... and I thought this was the cause of the lag issue. But about 3 months ago I added a fully blown Server with Windows Server 2016 on it. I installed HS3Pro and recreated the entire setup from scratch because my original setup was not that heavily involved, but the lag continues. It is bare bones software in the server right now, nothing else installed until i figure out what the HS lag issue is. Nothing going to "sleep" on the server that i can find, all power management to the USB is off... I have no idea what is causing this lag.

    All of the devices in the system are Zwave+, except 1 that I just added so that didnt make a difference.

    I do not have any add-ons to HS3Pro, just the SmartStick+

    When I go into the log, there are no issues... the time and events keep rolling and when the event or device works, it will then log and continue on like it's normal. I also thought maybe there were not enough devices for the Mesh network to have the proper speed? So I added 20 more from my original set, but it didnt do anything either.

    Even when entering the app and trying to turn on a light, 60% of the time it will either not do it, or it will lag then eventually do it.

    Is Windows just the problem here? I was thinking of changing over to Linux which I don't know to much about... but would rather stick with Windows... or am I better off just getting a HomeTroller Zee S2 to control everything? I removed devices and nothing changed so I know it's not a Zwave Device problem... only thing I can't test is if it's just Windows in general causing this.

    Thanks all!

  • #2
    Are you running any antivirus software? I had this issue years ago and it turned out to be my AV software was aggressively scanning my IO and caused this issue. I have HS3 running on a very old W10 laptop and do not experience this issue so it has to be something about the hardware or some software interfering. I've also seen where newer SSD drives are pegged at 100% disk usage causing lags as well. Check your disk usage with the task manager. Lastly check the event viewer for any issues as well.
    -Rupp
    sigpic

    Comment


    • #3
      I seriously don't think the issue is with windows. I too run WIn2k16 and the response is immediate. The only difference I can suspect is that I'm using a Z-Net. I'd hold off on moving to Linux for a variety of reasons which I also considered moving to from Win2k3. Are you monitoring any performance metrics?
      HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

      Comment


      • #4
        I use Windows 10 on an old laptop and have extremely fast response (no noticeable lag) so what you are experiencing isn't normal.

        It looks like you've already checked your "Power Options" settings, but just to be sure - under the "Hard disk" setting, check the "Turn off hard disk after" setting and set it to "Never". If your hard drive is turning off, that can cause a lag (in my system, I have a SSD rather than "traditional" hard drive so I don't get any disk-related lag).


        Also, this may be a routing database issue. Are your devices all Z-Wave Plus, or do they also include "old" Z-Wave (non-Plus)? If they include the non-Plus versions, you may need to optimize your network (perform "Optimize a Network, No Return Route Changes" three (3) times, followed by "Fully Optimize a Network"). From Z-Wave plugin, perform a "Test Node Connectivity on a Network" - do you notice any problem (unreachable) nodes? If all your devices are Z-Wave Plus, you shouldn't need to do a manual optimization.


        Finally, if these steps don't work, then you might try deleting and re-creating the Z-Wave2.db routing database (this has worked for me in the past):
        1. First backup your HomeSeer system from HomeSeer's [Tools] -> [Setup] menu..
        2. Shutdown HomeSeer
        3. Delete the Z-Wave routing database (C:\Program Files (x86)\HomeSeer HS3\Data\Z-Wave\Z-Wave2.db). Be Absolutely Sure you have a backup before doing this as sometimes things go wrong in its re-creation.
        4. Re-Start HomeSeer and it should re-create the database
        5. Optimize the network if you have any non-Plus devices.
        6. Make sure all of your devices are connected (from your Z-Wave Plugin, do a "Test Node Connectivity on A Network").

        Comment


        • #5
          RUPP - I DO have the standard Windows Defender still on... I just turned that off, we'll see if that fixes it. As for the HDD, it's a regular unit not an SSD. I always have Resource Monitor open checking to see if anything ever maxes out... nothing ever does. The only time there is any significant usage on anything in the system is when there are Windows updates.

          IANDENET - Yes I always have Resource Monitor open just to check everything especially when the lags are going on.

          JVM - Yes the HDD setting is Never... and as for the database, I've actually preformed that procedure probably 10 times over the past few months trying to get everything tuned it just right to get rid of this issue. It has never fixed it. Yes all devices as + devices except 1 that I just added... this has been going on since I first started installing Zwave with only 3-4 devices... I'd added a lot more since then and it's never changed the issue.

          Comment


          • #6
            I also just changed the Priority of the following:

            HS3.exe set to "Realtime"
            HSPI_ZWave.exe set to "Realtime"

            I don't see any other processes that I can change that have to deal with HS3... unless I'm missing something?

            Comment


            • #7
              Originally posted by Integraoligist View Post
              I also just changed the Priority of the following:

              HS3.exe set to "Realtime"
              HSPI_ZWave.exe set to "Realtime"

              I don't see any other processes that I can change that have to deal with HS3... unless I'm missing something?
              Check ALL your z-wave devices for "polling". In general they should all(including child devices) be set to NO polling. Often the default setting has everything polling and that can bring your z-wave system to it's knees---causing long delays. I agree with others above that HS3 is unlikely to require a lot from your PC.

              Comment


              • #8
                Originally posted by BobSpen View Post

                Check ALL your z-wave devices for "polling". In general they should all(including child devices) be set to NO polling. Often the default setting has everything polling and that can bring your z-wave system to it's knees---causing long delays. I agree with others above that HS3 is unlikely to require a lot from your PC.

                I'd modify Bob's instructions a bit. Polling can be useful for making sure your HomeSeer system stays synchronized. Instead of no polling, I'd say the issue is to avoid frequent / fast polling. E.g., if your devices are polling every 30 seconds, you may have a problem. On the other hand, if you have Z-Wave Plus devices polling every 20 minutes, that will have little burden on a Z-Wave Plus network. And if you aren't using Z-Wave Plus, you may need to poll a bit more often (say every 5 minutes).

                Comment


                • #9
                  Hey all, finally getting back to trying to figure out the lagging issues....

                  Bobspen, I went into PLUGINS > ZWAVE > NODE INFORMATION to check the Polling on all the devices. The only devices that ARE polling are the battery operated devices "Child Device: Battery" and they are all set to 12h. There are about 16 battery operated devices (door and window sensors, flood sensors, smoke/detectors.

                  jvm, everything is zw+ except for one relay (not battery operated) and no polling on it.



                  While I was in the Node Information I did notice that many of the "Last Working Routes" we're really bizarre. I mean that the routes would travel back and forth across the house instead of right to the ZStick. Even dimmers less the 5' away from the Zstick would travel all the way to one of the house then back to talk. It made no sense... so a couple of weeks ago I found this procedure on the forum which I then fine-tuned for HS3 being on Windows Server to clear out all of the routes and have them all try to Direct connect to the Zstick. Here is the procedure:

                  ---
                  Plugins > zwave > controller management > zwstick > "backup this interface"

                  Tools > setup > "Backup Config"

                  Close Homeseer on Server

                  On Server, go to C:\Program Files (x86)\HomeSeer HS3\Data\Z-Wave
                  Copy contents of Z-Wave folder to desktop as a backup... then deleted everything in the Z-Wave folder which contains the database.

                  Reboot the Server. This will cause HomeSeer to re-create the Z-Wave database. Give it a few minutes - say 5-10

                  Plugins > zwave > controller management > zwstick > "Optimize A Network, No Return Route Changes"
                  Repeat this about 5 times

                  Then do "Fully Optimize A Network"

                  Then do "Test Node Connectivity On a Network" - if any of your nodes aren't connected, you may not have run "Optimize A Network, No Return Route Changes" enough times to compute a path to all your devices. Then redo the "Fully Optimize A Network" and "Test Node Connectivity On a Network"

                  Then do "Scan Existing Devices (Full Scan)"

                  If good, then everything should work, if issues, restore both backups from step 1 and 2.
                  ---

                  So everything was communicating except for the 2 dimmers furthest away from the Zstick. They would not talk to the network at all, but everything else seemed to be working fine but the lag was STILL THERE. I then picked a dimmer that was between the furthest 2 dimmers and the Zstick and did a "Full Optimize" just on that node so it would act as a repeater. Nope, still would not connect to the 2 far dimmers. The system sat like this until 2 days ago when I started working on it again because the lag is driving me insane. I just went right back into PLUGINS > ZWAVE > CONTROLLER MANAGEMENT > ZWAVE STICK > FULLY OPTIMIZE A NETWORK. And I did this 6 times in a row. This took forever, but I did it. Now after doing that, the 2 far dimmers WORK, but the lag is still there... even worse then before. I can turn off maybe 3 lights within a few seconds of each other before the system stalls for a good minute or two... or just locks up entirely and I have to go to PLUGINS > MANAGE and Disable Z-Wave wait, then re-enable it to get the system working again.

                  **** is driving me nuts!

                  Comment


                  • #10
                    Could this be caused by the proverbial rogue zwave device flooding the network? Not sure how to diagnose, but there are a lot of experts on the forum that should be able to advise.

                    Comment


                    • #11
                      Maybe its a sleeping hard drive and it takes a while to wake up? You can fix this by changing the hard drive "sleep' setting to "never" in the advanced Power Options settings as shown below (To get to this setting panel go to: Control Panel -> Hardware and Sound -> Power Options -> Change Plan Settings -> Change Advanced Power Settings)

                      Click image for larger version

Name:	Power Management.PNG
Views:	185
Size:	20.4 KB
ID:	1315011

                      Comment


                      • #12
                        How many of your devices have power meter capability? If you have a lot (power plugs?) then check the frequency they are reporting power information back to HS3. This could easily flood the z-wave network very quickly causing delays.

                        Comment


                        • #13
                          lveatch, I'm not sure if there is one or not. Per watching the log there doesn't seem to be an issue but who knows.

                          jvm, I've always had that set to never sleep and also have all power management items disabled. I did this months ago but just checked again to be safe in case a Windows update decided to change anything... but no, they are all still disabled.

                          simplextech, I only have 1 device which is one of the Aeon Gen5 Energy Meters. That pulls Wattage info every 2 minutes and Voltage and Amps every 10 minutes. I was worried this was causing the issue to begin with so I removed it completely from the system for a week a while back. It didnt change anything so I added it back to the system.

                          Comment


                          • #14
                            Have you tried the USB stick in a different port? Might be a bad/flaky USB port issue. Have you ever tried a new/different USB z-wave controller? Could be a bad/going bad USB stick?

                            Comment


                            • #15
                              Originally posted by Integraoligist View Post
                              I'm not sure if there is one or not. Per watching the log there doesn't seem to be an issue but who knows.
                              A rogue device flooding network will not show up in the HS log. Rather, it's broadcasting zwave packets and creating a denial of service effect

                              Comment

                              Working...
                              X