Announcement

Collapse
No announcement yet.

Port Problem Redux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port Problem Redux

    Once again I am unable to bind my HS server to port 80. Also port 88. Also port 8080. Etc....

    This time...it's complicated. Apparently a second network adapter has sprung to life, despite my disabling all of them except the one I want.

    The desired IP address is 192.168.1.121.

    6/25/2019 10:54:49 AM ~!~Web Server~!~Local IP address (subnet) is: 192.168.1.146 (255.255.255.0)
    6/25/2019 10:54:49 AM ~!~Web Server~!~The web server has been bound specifically to IP address 192.168.1.121
    6/25/2019 10:54:49 AM ~!~Web Server~!~Web Server started on IP Address 192.168.1.121, port 8088
    6/25/2019 10:54:49 AM ~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. The requested address is not valid in its context
    6/25/2019 10:54:49 AM ~!~Warning~!~Web Server Stopped


    As you can see, the local IP address is coming up as .146, for unknown reasons.

    Here is my ipconfig:
    Windows IP Configuration


    Wireless LAN adapter Broadcom WiFi Adapter:

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fe80::4976:de52:7f1e:b91f%17
    IPv4 Address. . . . . . . . . . . : 192.168.1.146
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1

    Tunnel adapter isatap.{7324C96E-16F4-44E3-8116-EFBD059728AB}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :


    ...but here is my DHCP reservations table (my server is SPEISERS-PC)::


    Click image for larger version  Name:	dhcp.png Views:	0 Size:	18.1 KB ID:	1312491

    ...and my network adapter configuration:

    Click image for larger version  Name:	Network.png Views:	0 Size:	20.5 KB ID:	1312492
    So....any ideas?


    Jim Speiser
    30-year veteran of Home Automation
    Still don't know squat

  • #2
    Originally posted by JimSpy View Post
    Once again I am unable to bind my HS server to port 80. Also port 88. Also port 8080. Etc....

    This time...it's complicated. Apparently a second network adapter has sprung to life, despite my disabling all of them except the one I want.

    The desired IP address is 192.168.1.121.

    6/25/2019 10:54:49 AM ~!~Web Server~!~Local IP address (subnet) is: 192.168.1.146 (255.255.255.0)
    6/25/2019 10:54:49 AM ~!~Web Server~!~The web server has been bound specifically to IP address 192.168.1.121
    6/25/2019 10:54:49 AM ~!~Web Server~!~Web Server started on IP Address 192.168.1.121, port 8088
    6/25/2019 10:54:49 AM ~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. The requested address is not valid in its context
    6/25/2019 10:54:49 AM ~!~Warning~!~Web Server Stopped


    As you can see, the local IP address is coming up as .146, for unknown reasons.

    Here is my ipconfig:
    Windows IP Configuration


    Wireless LAN adapter Broadcom WiFi Adapter:

    Connection-specific DNS Suffix . :
    Link-local IPv6 Address . . . . . : fe80::4976:de52:7f1e:b91f%17
    IPv4 Address. . . . . . . . . . . : 192.168.1.146
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1

    Tunnel adapter isatap.{7324C96E-16F4-44E3-8116-EFBD059728AB}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :





    ...but here is my DHCP reservations table (my server is SPEISERS-PC)::


    Click image for larger version Name:	dhcp.png Views:	0 Size:	18.1 KB ID:	1312491

    ...and my network adapter configuration:

    Click image for larger version Name:	Network.png Views:	0 Size:	20.5 KB ID:	1312492
    So....any ideas?
    Since your DHCP reservation is not being respected, is there any chance the MAC address is incorrect? Can you verify the MAC address of the WiFi adaptor? Did you change from wired to WiFi? As a last resort can you delete the reservation and create a new one?
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      Originally posted by rprade View Post
      Since your DHCP reservation is not being respected, is there any chance the MAC address is incorrect? Can you verify the MAC address of the WiFi adaptor? Did you change from wired to WiFi? As a last resort can you delete the reservation and create a new one?
      Click image for larger version

Name:	Broadcom.png
Views:	83
Size:	14.7 KB
ID:	1312503

      Very strange. I now believe that the DHCP reservation for the MAC address ending in 19:A3 is for the second adapter, the Microsoft Virtual WiFi Miniport, which as you can see above, is actually disabled. So I guess it searches for the only available adapter, the Broadcom; but since .121 is reserved for 88:81, it assigns the next available IP address, 146, to the Broadcom.

      So I try disabling the Broadcom, and what happens? It disables and disappears Wireless Connection 4 (the Microsoft Virtual) instead. Broadcom remains connected.

      I am now reaching above my pay grade. I know what to do when everything's working as it should, but when it gets confusing like this, I'm flummoxed. Help!


      Jim Speiser
      30-year veteran of Home Automation
      Still don't know squat

      Comment


      • #4
        Originally posted by JimSpy View Post

        Click image for larger version  Name:	Broadcom.png Views:	0 Size:	14.7 KB ID:	1312503

        Very strange. I now believe that the DHCP reservation for the MAC address ending in 19:A3 is for the second adapter, the Microsoft Virtual WiFi Miniport, which as you can see above, is actually disabled. So I guess it searches for the only available adapter, the Broadcom; but since .121 is reserved for 88:81, it assigns the next available IP address, 146, to the Broadcom.

        So I try disabling the Broadcom, and what happens? It disables and disappears Wireless Connection 4 (the Microsoft Virtual) instead. Broadcom remains connected.

        I am now reaching above my pay grade. I know what to do when everything's working as it should, but when it gets confusing like this, I'm flummoxed. Help!
        First, how do you want to connect - WiFi or wired?
        • Delete the current DHCP reservation from your router
        • Choose the connection type you want on the HS server, then disable the other connections
        • Restart the HomeSeer server
        • Confirm that the server obtains an IP address
        • Find the server in your router’s DHCP table and create a new DHCP reservation for 192.168.1.121 based on the currently connected MAC address
        • Restart the server and see if it obtains the correct IP address
        A DHCP reservation is based on the unique MAC address of the adaptor, not the computer name. It is issued by the DHCP server in your router. If you change adaptors, the reservation will not follow. If there is no reservation for the new adaptor, the IP address will be pulled from your DHCP server’s address pool.

        It also appears that you have two WiFi adaptors, one of them is virtual. Are you running the Hyper-v service?
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Originally posted by rprade View Post
          First, how do you want to connect - WiFi or wired?
          • Delete the current DHCP reservation from your router
          • Choose the connection type you want on the HS server, then disable the other connections
          • Restart the HomeSeer server
          • Confirm that the server obtains an IP address
          • Find the server in your router’s DHCP table and create a new DHCP reservation for 192.168.1.121 based on the currently connected MAC address
          • Restart the server and see if it obtains the correct IP address
          A DHCP reservation is based on the unique MAC address of the adaptor, not the computer name. It is issued by the DHCP server in your router. If you change adaptors, the reservation will not follow. If there is no reservation for the new adaptor, the IP address will be pulled from your DHCP server’s address pool.

          It also appears that you have two WiFi adaptors, one of them is virtual. Are you running the Hyper-v service?
          I want to connect WiFi. Been doin it that way for years.

          It also appears that you have two WiFi adaptors, one of them is virtual. Are you running the Hyper-v service?
          No. I don't think it's actually virtual, it's a dongle I put in some time ago. I think that's what I've been connecting to, until lately.


          Jim Speiser
          30-year veteran of Home Automation
          Still don't know squat

          Comment


          • #6
            Originally posted by JimSpy View Post

            I want to connect WiFi. Been doin it that way for years.

            It also appears that you have two WiFi adaptors, one of them is virtual. Are you running the Hyper-v service?
            No. I don't think it's actually virtual, it's a dongle I put in some time ago. I think that's what I've been connecting to, until lately.
            Searching Google It appears that virtual adapter may have been created for WiFi sharing. It may have been created by the software installation of one of your WiFi adaptors. You should be able to just disable it and just use the Broadcom adapter, then set up a new DHCP reservation for your desired address.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Originally posted by JimSpy View Post
              Once again I am unable to bind my HS server to port 80. Also port 88. Also port 8080. Etc....

              This time...it's complicated. Apparently a second network adapter has sprung to life, despite my disabling all of them except the one I want.

              The desired IP address is 192.168.1.121.
              It is also worth noting that binding in HomeSeer will only work and is only needed if your machine has two active network adaptors. If there is only one IP address, binding should have no effect. You can only bind to an existing IP.

              Also, binding has no effect on the port used. That is dependent on the web server port in settings.
              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


              • #8
                Originally posted by rprade View Post
                It is also worth noting that binding in HomeSeer will only work and is only needed if your machine has two active network adaptors. If there is only one IP address, binding should have no effect. You can only bind to an existing IP.

                Also, binding has no effect on the port used. That is dependent on the web server port in settings.
                OK, back at it today.

                I have disabled all but the Broadcom connection.



                Here is my DHCP table. Apparently there are THREE reservations...

                Click image for larger version

Name:	ScreenShot_20190627124823.png
Views:	58
Size:	15.7 KB
ID:	1312992
                Click image for larger version

Name:	ScreenShot_20190627124836.png
Views:	54
Size:	13.6 KB
ID:	1312993
                I'm getting confused as to which is which. Can't remember how to determine MAC addresses for network adapters...? Obviously I want the MAC address for the Broadcom, reserve .121 to that, then...shut down/restart?


                Jim Speiser
                30-year veteran of Home Automation
                Still don't know squat

                Comment


                • #9
                  Delete the current reservation for .121 (assigned to MAC ending in 19:A3). Then create a new reservation for the MAC ending in 88:81, assigning it to .121. If you can’t see how to do it, post the brand and model of your router so we can get the manual.
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                  • #10
                    Originally posted by rprade View Post
                    Delete the current reservation for .121 (assigned to MAC ending in 19:A3). Then create a new reservation for the MAC ending in 88:81, assigning it to .121. If you can’t see how to do it, post the brand and model of your router so we can get the manual.
                    Compliance.

                    Failure.

                    The network adapter at 88:81 comes up 192.168.1.146, in spite of my reserving it for .121 in the DHCP client table.

                    I know, not possible. Welcome to my computer nightmare.


                    Jim Speiser
                    30-year veteran of Home Automation
                    Still don't know squat

                    Comment


                    • #11
                      Guessing you are using Windows 10 eh?

                      Go to a command line prompt and do an IP config.

                      Disable IP6 for a time.

                      Go to a command line prompt and do an IP config again.

                      Go to device manager / hardware and write down the hardware wireless MAC address and wired MAC address.

                      You want to see only two MAC addresses coming from your new server. One is the ethernet port and the other wireless port.

                      Don't play with DHCP reservation on your router until you have confirmed the two hardware mac addresses.



                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
                      Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                      Comment


                      • #12
                        Originally posted by Pete View Post
                        Guessing you are using Windows 10 eh?

                        Go to a command line prompt and do an IP config.

                        Disable IP6 for a time.

                        Go to a command line prompt and do an IP config again.

                        Go to device manager / hardware and write down the hardware wireless MAC address and wired MAC address.

                        You want to see only two MAC addresses coming from your new server. One is the ethernet port and the other wireless port.

                        Don't play with DHCP reservation on your router until you have confirmed the two hardware mac addresses.


                        Negative, Windows 7 (it's a long story). Does your suggestion still apply?


                        Jim Speiser
                        30-year veteran of Home Automation
                        Still don't know squat

                        Comment


                        • #13
                          Originally posted by Pete View Post
                          Guessing you are using Windows 10 eh?

                          Go to a command line prompt and do an IP config.

                          Disable IP6 for a time.

                          Go to a command line prompt and do an IP config again.

                          Go to device manager / hardware and write down the hardware wireless MAC address and wired MAC address.

                          You want to see only two MAC addresses coming from your new server. One is the ethernet port and the other wireless port.

                          Don't play with DHCP reservation on your router until you have confirmed the two hardware mac addresses.


                          Windows IP Configuration

                          Wireless LAN adapter Broadcom WiFi Adapter:

                          Connection-specific DNS Suffix . :
                          Link-local IPv6 Address . . . . . : fe80::4976:de52:7f1e:b91f%
                          IPv4 Address. . . . . . . . . . . : 192.168.1.146
                          Subnet Mask . . . . . . . . . . . : 255.255.255.0
                          Default Gateway . . . . . . . . . : 192.168.1.1

                          Tunnel adapter isatap.{7324C96E-16F4-44E3-8116-EFBD059728AB}:

                          Media State . . . . . . . . . . . : Media disconnected
                          Connection-specific DNS Suffix . :

                          Tunnel adapter Teredo Tunneling Pseudo-Interface:

                          Media State . . . . . . . . . . . : Media disconnected
                          Connection-specific DNS Suffix . :


                          C:\Users\Speiser's>ipconfig /release6 wireless*

                          Windows IP Configuration

                          The operation failed as no adapter is in the state permissible for
                          this operation.



                          How about /registerDNS?
                          "Refreshes all DHCP leases and re-registers DNS names"


                          Jim Speiser
                          30-year veteran of Home Automation
                          Still don't know squat

                          Comment


                          • #14
                            Cancel red alert, secure from General Quarters.

                            All is working now. Solving the DHCP quandry solved the port problem, as I thought it might. I still don't understand this stuff, but I'm figuring out the right buttons to push.


                            Jim Speiser
                            30-year veteran of Home Automation
                            Still don't know squat

                            Comment


                            • #15
                              Does your suggestion still apply?

                              Yes.

                              If you shut off IP6 on the box and it will be easier to deal with this sort of stuff.


                              or to find a mac address in windows type at a command line prompt. Noticed that ipconfig only shows the ip6 configuration.

                              If you type ipconfig /all or getmac /s viper you will see the mac address of the interface you are looking for.
                              - Pete

                              Auto mator
                              Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
                              Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

                              X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

                              Comment

                              Working...
                              X