Announcement

Collapse
No announcement yet.

Can't connect to HS3 Pro via local network, MyHS works fine, why - Solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't connect to HS3 Pro via local network, MyHS works fine, why - Solved!

    Background: At one point and for a long time, I was able to connect to HS3 on my local network, same subnet, via the web interface with no issues. As far as I know, the only changes were HS3 version updates. I do not recall making other changes and/or adding new plug-ins. One day I discovered that I can no longer get to the web interface via the local network. HS3 Pro is running on Windows 10 (headless). I can get to the host machine via RDP and the web interface runs fine on the HS3 machine itself. MyHS remotely works fine also. This is a dedicated machine with no 3rd-party security software running on it.

    Observations/actions: I have since disabled Windows Firewall (the result is "connection refused" when I try to connect to the web interface), with Windows Firewall enabled, the browser reports connection timed out. I can ping the machine. HS3 Pro can obviously make outbound local connections because it communicates with Rachio, Ecobee, etc. on the same network just fine.

    I added my subnet xxx.xxx and loopback 127.0. to the Subnet section under network settings, defaulted port to 80, but nothing has worked.

    My network integrity is fine and I can connect to every other host except HS.

    I have found a few threads with similar issues, but none provided a resolve.

    I would appreciate any help or ideas.

    Thanks.






  • #2
    On Setup/Network, do you have Enable Server for Remote Access unchecked? I've locked myself out that way a couple of times.
    Real courage is not securing your Wi-Fi network.

    Comment


    • #3
      Originally posted by Wadenut View Post
      On Setup/Network, do you have Enable Server for Remote Access unchecked? I've locked myself out that way a couple of times.
      No, Enable Server for Remote Access is checked (enabled). Also, there are no error logs that show any failed connection attempt. Any other ideas? Thanks.

      Comment


      • #4
        Sorry, that's all I had. Bit me a couple of times.
        Real courage is not securing your Wi-Fi network.

        Comment


        • #5
          I get similar behavior if I uncheck no password required. I had to move the backup of settings.ini and Z-Wave.ini after I tested to be able to get back in. I then had to login to the HS-Server to get it back to normal. Hope this helps.

          Click image for larger version

Name:	Screenshot from 2019-06-30 15-54-13.png
Views:	110
Size:	13.3 KB
ID:	1313401

          Comment


          • #6
            Originally posted by AllHailJ View Post
            I get similar behavior if I uncheck no password required. I had to move the backup of settings.ini and Z-Wave.ini after I tested to be able to get back in. I then had to login to the HS-Server to get it back to normal. Hope this helps.

            Click image for larger version

Name:	Screenshot from 2019-06-30 15-54-13.png
Views:	110
Size:	13.3 KB
ID:	1313401
            Thanks, I just resolved the problem. After seeing the post from Wadenut, I decided to toggle OFF the remote management. I then went to the ini file and changed it back to true so I can launch the web interface on the HS3 machine. Somehow, thereafter, it started to work. Go figure!

            Comment


            • #7
              Pretty much my experience, only I'd brought it on myself accidentally on a remote machine. Had to edit the file then restart HS thru VNC to fix it.
              Real courage is not securing your Wi-Fi network.

              Comment

              Working...
              X