Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

How to change some device settings after the device has been initially defined?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JKaplan
    replied
    Thanks gentlemen - Great advice and all working now!

    Leave a comment:


  • Uncle Michael
    replied
    Wireless X10 PIRs can (and should) be created as virtual devices without the X10 tab. If you want the light sensor function, you'll need to create two devices for each PIR. Their only connection with the RFXCOM plug-in is with the HC/UC signal. Only activate the house codes you actually use, and set them as 'Status Only' as Greg already noted. That should give you full control of the setup of the device.

    Click image for larger version

Name:	x10rf.PNG
Views:	98
Size:	60.8 KB
ID:	1314317

    Leave a comment:


  • Wadenut
    replied
    If you've changed that option on the affected housecodes in the PI as I mentioned, then you'll probably need to delete the devices and recreate them, as their options would have been previously set as Full Function. Note: Full Function also re-transmits the On/Off status received from the motion sensors onto the powerline if you have an X10 or CM15 PI as well.
    Failing this, I'd check in with @b_weijenberg - the RFXCOM Plugin Author, as this definitely is not normal behaviour.

    Leave a comment:


  • JKaplan
    replied
    Now I've tried both ... unless this has to be set before some other action, like initializing the interface or something. No change, clicking the "on" or "off" buttons on any of the motion detector devices has no effect.

    Leave a comment:


  • Wadenut
    replied
    On the RFXCOM General Configuration tab, have you defined the Housecode used by your motion sensors as "Full" or "Status Only". I think you want the latter.

    Leave a comment:


  • JKaplan
    replied
    Thanks for the reply, Michael. I'm not sure what it means to be "owned" by a plugin, so that's probably most of my problem.

    Indeed, the motion detectors are x10 wireless.

    I set up these motion detectors as devices long ago, now I'm converting to HS3 and renovating everything. I bought a W800 which picks up the RF and relays it to Homeseer. In Homeseer, I installed RFXCOM as the interface, which seems to work, as the motion detectors devices are turning "on" and sometimes "off" (which is a different problem). But I used to be able to set the motion detector devices to "off" and "on" manually (mainly to test events), but now I can't for some reason. (Perhaps because RFXCOM now claims ownership of my X-10 devices?)

    I'd like to get the device descriptions straightened out (i.e. these aren't "dimmable"), and if possible, to be able to continue to manually set their values from time to time - particularly when an "off" RF signal gets missed...

    Jerry

    Leave a comment:


  • Uncle Michael
    replied
    Are the devices owned by a plug-in? Which one? I assume they are X10 wireless, not X10 PLC, correct?

    Leave a comment:


  • How to change some device settings after the device has been initially defined?

    I've got a bunch of X10 motion detectors that show in "devices" as being dimmable, and a few other misc properties that are not correct. The corresponding checkbox on the device details page is greyed out, and I can't seem to figure out where/how to edit field/value pairs that appear on the advanced tab.

    How can I fix this?

    Thanks,

    Jerry
Working...
X