Announcement

Collapse
No announcement yet.

Windows 10 Update 1903 breaks port 80

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 10 Update 1903 breaks port 80

    Just in case anyone is in the same position as me and Windows 10 just updated itself to 1903 I thought I would make a quick post on how to fix the "port in use" error.

    It seems every time there is a major windows update World Wide Web Services (IIS) get re-enabled.

    See this post on how to fix it: https://forums.homeseer.com/forum/ho...il-2018-update

    Basically port 80 gets hijacked by World Wide Web Services and prevents HS using the default port 80. You will get this error in your startup log:

    Jul-19 9:01:34 PM Warning Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. An attempt was made to access a socket in a way forbidden by its access permissions
    Hope this helps other users.

    Marty.
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

  • #2
    Originally posted by mminehan View Post
    Just in case anyone is in the same position as me and Windows 10 just updated itself to 1903 I thought I would make a quick post on how to fix the "port in use" error.

    It seems every time there is a major windows update World Wide Web Services (IIS) get re-enabled.

    See this post on how to fix it: https://forums.homeseer.com/forum/ho...il-2018-update

    Basically port 80 gets hijacked by World Wide Web Services and prevents HS using the default port 80. You will get this error in your startup log:



    Hope this helps other users.

    Marty.
    Open the settings file in the HomeSeer/Config folder and edit the port to something else. Restart then navigate to the new port. You do get that on the Windows Server versions as well!



    Eman.
    The Closer.

    Comment


    • #3
      Originally posted by Eman View Post
      Open the settings file in the HomeSeer/Config folder and edit the port to something else. Restart then navigate to the new port. You do get that on the Windows Server versions as well!
      Yep.....if you want to change the port number. But I also use the HSMetro UI which uses port 80. So changing the HS port does not work for our situation. It's simpler just to disable the IIS of Windows.

      iCore5 Win 10 Pro x64 SSD

      HS3 Pro Edition 3.0.0.435 Windows

      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

      Comment


      • #4
        But how do you disable IIS in Windows 10 though? There is no "World Wide Web Service" listed in the Windows 10 services panel...

        Comment


        • #5
          Originally posted by mminehan View Post

          It's simpler just to disable the IIS of Windows.
          What service is this one?

          Comment


          • #6
            Originally posted by metkhoo View Post
            But how do you disable IIS in Windows 10 though? There is no "World Wide Web Service" listed in the Windows 10 services panel...
            Control Panel > Programs and Features > Turn Windows Features On or Off > Internet Information Services
            -Wade

            Comment


            • #7
              Originally posted by metkhoo View Post

              What service is this one?
              IIS is the same a World Wide Web Services. As cc4005 mentions you can turn off IIS via the "Windows Features" option. Or you can type 'services.msc' into your start menu and the look for "World Wide Web Services" and disable it......as per the instructions in the link in the first post.

              It may already be disabled, in which case it may not be in the list.
              iCore5 Win 10 Pro x64 SSD

              HS3 Pro Edition 3.0.0.435 Windows

              BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

              Comment


              • #8
                So just that you all know in my install of Windows 10 if I go to "Control Panel > Programs > Programs and Features > Turn Windows Features On or Off >", "Internet Information Services" and "World Wide Web Services were never on in the first place. But port 80 was certainly not working.

                For me the Windows 10 1903 update enabled the Windows firewall and blocked port 80. I needed to create a Firewall Port rule that re-opened up port 80 - Then it all worked again.

                Thanks for all the tips though ;-)

                Comment


                • #9
                  Oh yes and I also needed to open port 10200 for HS Touch...

                  Comment

                  Working...
                  X