Announcement

Collapse
No announcement yet.

HS3 will not send emails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 will not send emails

    HS3 will not send emails. Any help is appreciated. (gmail is set to allow less secure apps.)
    Attached Files

  • #2
    Anything getting posted to the log when you first check the enable Gmail checkbox?
    You might show how you are using HS3 to send email. Does the log show any errors when you try sending email?
    Blair

    HomeSeer: HS3 Pro 3.0.0.548
    Hometroller S6 | Devices: 832 | Events: 211
    Plug-Ins: Z-Wave .252 | HSTouch | RFXCOM | UltraRachio3 | Sonos
    BLLAN | BLPLEX | BLLOCK | NetCAM | Global Cache Pro | Blur-Iris4

    Comment


    • #3
      Originally posted by BlairG View Post
      Anything getting posted to the log when you first check the enable Gmail checkbox?
      You might show how you are using HS3 to send email. Does the log show any errors when you try sending email?
      I'm using the email feature to send emails to my phone after certain events run, such as codes entered on door, etc.

      I was using comcast, but they changed their security in early October, something about TLS 1.2. Everything was working fine prior to that, so I am certain my events are good.

      I have tried manually running some of the events that also send an email. The log shows the event ran, but nothing specific about the email.

      Comment


      • #4
        Log into your Gmail account and look in your sent box? Stuck in outbox?

        could comcast block less secure email?
        Blair

        HomeSeer: HS3 Pro 3.0.0.548
        Hometroller S6 | Devices: 832 | Events: 211
        Plug-Ins: Z-Wave .252 | HSTouch | RFXCOM | UltraRachio3 | Sonos
        BLLAN | BLPLEX | BLLOCK | NetCAM | Global Cache Pro | Blur-Iris4

        Comment


        • #5
          Under the Receiving Email. I do not have anything entered in mine. I notice you do not have box checked to receive email, so that should not apply.

          How are you trying to send the emails? From an event? Appears that you are trying to send the email to a SMS text message? I do this exactly the same for several notifications. I use Verizon. Have you checked to be sure ATT did not change anything about the MMS/SMS messaging? Tried going to Gmail account and run a test message to your phone MMS/SMS? Sounds simple, but has password been changed on Gmail by chance? Verified it is still correct in the email set up screen ( as posted above)?

          If your not using events to send the email. Try that method and see if it will work for you.

          Comment


          • #6
            Thank you for the suggestions. I had done all this, but re-did each one this morning to make sure.
            - nothing in gmail sent folder, from homeseer
            - sent an email from within gmail, to my AT&T SMS, worked fine
            - triple checked password
            - tried it with receive email both checked and un-checked
            - tried a different gmail email address

            Sidenote: Wish there was a "test email" button on the Setup>Email page

            Comment


            • #7
              GMail has security settings that prevent 3rd party applications from using the account. To make this work you will need to login to your GMail account.
              Go to https://myaccount.google.com/
              Select Security
              Ensure 2-Step Verification is Off.
              Scroll down farther and turn on Allow less secure apps
              -Rupp
              sigpic

              Comment


              • #8
                Originally posted by Rupp View Post
                GMail has security settings that prevent 3rd party applications from using the account. To make this work you will need to login to your GMail account.
                Go to https://myaccount.google.com/
                Select Security
                Ensure 2-Step Verification is Off.
                Scroll down farther and turn on Allow less secure apps
                This is terrible security advice. Turning off 2 factor completely is NOT NECESSARY. You can create an account exception in gmail to allow less secure email sending for HS3, AND keep strong 2 factor authentication at the same time.

                I strongly recommend you do not follow this advice!

                Comment


                • #9
                  Less secure app access is turned on.

                  Originally posted by mterry63 View Post

                  This is terrible security advice. Turning off 2 factor completely is NOT NECESSARY. You can create an account exception in gmail to allow less secure email sending for HS3, AND keep strong 2 factor authentication at the same time.
                  Can you elaborate on how to make the account exception in gmail? and hopefully how i can get this working. thanks.

                  Comment


                  • #10
                    How are you trying to send the email exactly? Are you using and event to do it?
                    Can you post a screen shot of your event/method? ( blacking out any security concerns of course)?

                    Comment


                    • #11
                      I have many events set to send an email. They were all working fine before Comcast changed their security features in early October. I've found more info on this on other threads, and the internet. But no help getting the normal gmail to work that Homeseer looks to be set up to do. I'd rather the gmail over Comcast anyway.

                      Comment


                      • #12
                        That part looks ok. I can say that I do not believe to have had to change any setting on gmail at all. Even if Comcast changed something, Is it possible to be affecting gmail? You stated you can manually send and email to your phone from your gmail account. So that indicates its working.
                        > Uncheck "Use SSL" and try to fire one just to see if it works? (test)
                        >Take everything out of email tab and start over?

                        ***CAUTION: Use at your own risk. I am the farthest from an expert!!

                        Comment


                        • #13
                          So, my Gmail send works perfectly, and it looks different than yours. First, try port 465. Also, I see that everything is filled out in terms of actually seeing smtp.gmail.com, smtp username, etc. If memory serves me correctly, I had to uncheck the gmail box at the top, fill in all the info in the “send” section based on a Google search of correct gmail settings, save it, and then go back and check the gmail box. It’s been a while since I did it, but that’s my recollection. I do have SSL checked. And yes, the override of 2FA for the HS address was necessary, but not my entire gmail presence as I recall (see others’ advice above). I set up a unique gmail address for HS, and did not use my “normal” gmail account. I recommend you do the same. Hope that helps.
                          Madcodger

                          This would be a lot easier if I knew what I was doing...

                          Comment


                          • #14
                            To enable HS3 to send via gmail when you have 2 factor enabled do the following:

                            1. Login to account.google.com
                            2. Select Security on the left side
                            3. Select "app passwords" under "Signing in to Google"
                            4. Select "Mail" and "Windows Computer" and click the "Generate" button
                            5. Use your mail address as the username and generated password as the password in HS3 under Settings and E-mail tab.


                            Comment


                            • #15
                              I did notice port was different from mine. Told ya I was not an expert. ha. I did not think that would matter. Hope that is it!

                              Thanks for that info as well mterry. I need to do that with mine probably!

                              Comment

                              Working...
                              X