Announcement

Collapse
No announcement yet.

HS3 Linux Find.HomeSeer.com issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Linux Find.HomeSeer.com issues

    Hi,

    I am very new to HomeSeer understand Linux well enough to get HomeSeer installed and "started" via cli. However, when I go to find.homeseer.com I can not find my system - there are no selection options, just a basic landing page (screen shot attached). I don't think it is my install steps, but I have outlined my steps below in case someone sees something I am missing. I have also attached my startup log which might provide additional clues to someone more versed in HomeSeer logs.

    Install steps:
    sudo apt update

    sudo apt install apt-transport-https dirmngr gnupg ca-certificates
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
    echo "deb https://download.mono-project.com/repo/debian stable-buster main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
    sudo apt update && sudo apt upgrade

    sudo apt install mono-complete mono-vbnc
    sudo apt install avahi-daemon
    sudo apt install unzip

    wget http://homeseer.com/updates3/hs3_linux_3_0_0_548.tar.gz
    tar zxvf hs3_linux_3_0_0_548.tar.gz

    ## START HOMESEER ##
    cd Homeseer
    sudo ./go &
    Attached Files

  • #2
    Have you tried opening the web api using a browser. Use the local web address of the machine HS is installed on. I imagine it’s installed on port 80 so no need to worry about that.

    Comment


    • #3
      There is no longer a "search" button on the find.homeseer.com page -- in the past there was, but the page was redesigned in the past couple of years. What you are seeing is now "normal" in the case where no HomeSeer systems (HS3, Z-Net) are detected.

      After you enter the 'go' command, there should be a fairly lengthy transcript produced. What does that say?

      Also, verify which version of mono got installed

      Code:
      mono -V

      Comment


      • #4
        The text startup-log should be attached to my original post, under the find.homeseer.com image.

        I tried accessing via the static IP assigned to the machine but did nothing.

        In a normal world - how would I login on my local network? Would it be via the myhs.homeseer.com url or is there another approach?

        Comment


        • #5
          Is there a firewall running on the box?

          Also this in the startup log

          11/10/2019 03:47:26 ~!~Warning~!~This version of HomeSeer is not registered and is currently disabled
          11/10/2019 03:47:26 ~!~Web Server~!~Local IP address is: 10.0.0.45

          Comment


          • #6
            From your log,

            Code:
            11/10/2019 03:47:26 ~!~Web Server~!~Local IP address is: 10.0.0.45
            So your web browser, open http://10.0.0.45

            Since you're going with a static IP, you need to setup default router and DNS servers in order for find.homeseer to work. Those are configured automatically by DHCP, but must be manually configured otherwise.

            Comment


            • #7
              Yes I am running a demo license, but I have no idea how to input the license credentials from the cli - I thought it was something I typed in when I log in.

              Comment


              • #8
                Originally posted by redoak View Post
                Yes I am running a demo license, but I have no idea how to input the license credentials from the cli - I thought it was something I typed in when I log in.
                You can't input the license credentials from the cli, as far as I know. You need to get to the web interface.

                What is the result when you access http://10.0.0.45 from your web browser?

                Comment


                • #9
                  Since you used apt to install packages I assume you have shell/command line access to your server from either a monitor and keyboard attached to your system or remote assess using SSH. For remote access you can use "putty" to SSH to a login prompt and login remotely. Just do a search for putty and install on your PC.

                  You said you have a static IP. How did you assign the static IP? Did you use a DHCP reservation in your router or did you manually configure the interface? If you used a DHCP reservation in your router it should have assigned a default route and DNS. If you manually configured the interface did you assign a default gateway and DNS?

                  You can use the ifconfig command to show what IP is assigned to your Ethernet. The output of the ifconfig command should show you the IP address

                  Code:
                  enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
                   inet 192.168.xxx.xx  netmask 255.255.255.0  broadcast 192.168.xxx.255

                  You can use the "ip route" command to see if you have a default route set. The output from the ip route command should return the default gateway

                  Code:
                  default via 192.168.xxx.xxx dev enp1s0 proto static
                  From the command line of your server can you ping out to the internet? Ping some common IP like Google DNS server at 8.8.8.8 or 8.8.4.4.If you get a response then you have Internet access from your machine and we can trouble shoot other things. If you did not get a response you will need to determine why your network is not working. Also try to ping the default gateway which is usually your router's IP address.

                  Comment


                  • #10
                    Static IP address was configured in the Debian interfaces file with the correct DNS gateway set up. I can bing both my gateway and Google’s DNS servers no problem.

                    When I use both Firefox and Chrome to go to 10.0.0.45 - I get an error “the server has stopped responding”.

                    I am using Mono version 6.4.0.198, tarball date of 9/24/2019.

                    Comment


                    • #11
                      Can you ping 10.0.0.45 from the machine you are running your web browser? Is the machine running the browser a different machine than the HomeSeer server?

                      Comment


                      • #12
                        The HomeSeer server is a headless box in my basement. I tried to access it via web browser from 2 separate laptops both wired and wireless along with my phone - all no dice.

                        I am half tempted just to spin up a Win7 VM from my server to test HomeSeer.

                        Comment


                        • #13
                          I forgot to mention, yes I can ping the 10.0.0.45 machine from other computers on the network with no issues.

                          Comment


                          • #14
                            After starting HomeSeer ("go" command), check that it stays running:

                            Code:
                            pgrep -af mono
                            Should list at least one process.

                            Comment


                            • #15
                              Command respknse

                              [
                              Code:
                              723 /usr/bin/mono /usr/lib/mono/4.5/xsp4.exe --port 8084 --address 0.0.0.0 --appconfigdir /etc/xsp4 --nonstop

                              Comment

                              Working...
                              X