Announcement

Collapse
No announcement yet.

HS Speaker has stopped playing WAV files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS Speaker has stopped playing WAV files

    About a couple of weeks ago HomeSeer stopped playing WAV or any Music files, TTS works perfectly! restarting does not solve it. I am running HS version 3.0.0.548 (Windows) on
    Microsoft Windows Server 2016 Standard - Server. anybody any thoughts.
    sigpic
    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

    #2
    Guessing you have tested out Microsoft Media Player in Windows 2016 to function fine eh?

    You can always add K-Lite codec pack from here:

    hxxps://www.codecguide.com/klcp_update.htm

    I have been using this for many years on Windows 2013 server (old Homeseer 2) and Windows 2016 server.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
    HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #3
      Media Player is not playing. Tried installing K-Lite, no luck still no Audio did not restart PC though.
      sigpic
      A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

      Comment


        #4
        Media Player is not playing. Tried installing K-Lite, no luck still no Audio did not restart PC though.

        Looking at control panel / device manager do you see the audio device?

        I am guessing you do see the device fine as you mentioned that TTS is working fine.

        Media player should play WAV files just fine. This is not an issue with Homeseer Speaker dot exe.

        Does the sound test work fine when testing audio properties?

        Check the volumes on the mixer; make sure all are turned up and not muted.

        Are you accessing the box via RDP or do you have a monitor connected to it.



        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
        HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
        HS4 Lite -

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


          #5
          Originally posted by Pete View Post
          Media Player is not playing. Tried installing K-Lite, no luck still no Audio did not restart PC though.

          Looking at control panel / device manager do you see the audio device?
          Yes they are there

          I am guessing you do see the device fine as you mentioned that TTS is working fine.

          Media player should play WAV files just fine. This is not an issue with Homeseer Speaker dot exe.

          Does the sound test work fine when testing audio properties?
          Sound does not work

          Check the volumes on the mixer; make sure all are turned up and not muted.

          Are you accessing the box via RDP or do you have a monitor connected to it.


          All volumes up and not muted, accessing direct not through RDP

          sigpic
          A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

          Comment


            #6
            Click image for larger version  Name:	sounds.jpg Views:	0 Size:	69.5 KB ID:	1407957 What happens when you run Microsoft Media player and open up a media file in the \Windows\media directory?

            That is where all of your windows sounds are at and they are all wav files. IE: start up, beep et al.

            Go to Settings> Apps> Default Apps> Scroll to the bottom and select "choose default apps by file type"

            Find .wav and see what it says the default app is for opening them.


            Click image for larger version  Name:	W2016WavFiles.jpg Views:	0 Size:	43.7 KB ID:	1407954
            - Pete

            Auto mator
            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
            HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
            HS4 Lite -

            X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

            Comment


              #7
              When I try to play default sounds nothing happens. WAV files are set to Windows Media Player.
              sigpic
              A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

              Comment


                #8
                Should work. Doesn't make sense if it worked before. W2016 is a much simpler base server than the W10 Pro desktop. Just the meat and no fluff.

                Are you using 2 USB sound cards plus internal sound card? You should be able to direct your wave sounds to play through any sound card you want.

                I have an old windows program which is called virtual audio which lets you mix and match different sound ports. I have it saved here. It is an old Windows program and will PM the link to it for you.

                Well actually here is the link for it. I have not used it in years now but it worked great.

                https://www.vb-audio.com/Cable/
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                HS4 Lite -

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                  #9
                  Thanks Pete, I will give it a try this weekend. Think it may be a RDP problem where the audio is not being handed back properly at the end of a session.
                  sigpic
                  A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

                  Comment


                    #10
                    I did not know you were using RDP. Well then it is better that you use VNC then to access the W2016 box. With VNC your sound will only come out of the W2016 server.

                    Yes using RDP and Audio is a whole different thing. RDP creates a virtual audio port which attaches to one of the audio cards. I would not use RDP to configure the audio.

                    Here use RDP for my box but I do not need audio on it. It is just a windows box which I use HSDesigner, Leviton HAI touchscreen designer, UPB Upstart, Leviton PCA, et al. These are programs which have to run in Windows.
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                    HS4 Pro - V4.1.10.0 - Ubuntu 18.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.12.x
                    HS4 Lite -

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment

                    Working...
                    X