Announcement

Collapse
No announcement yet.

Trouble Migrating HS3 Pro from Windows 7 32 bit to Windows 10 64 bit computer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble Migrating HS3 Pro from Windows 7 32 bit to Windows 10 64 bit computer

    I am getting an error after I migrated over to windows 10 64 bit system from windows 7 32 bit computer.

    I followed these guidelines from Homeseer

    https://helpdesk.homeseer.com/articl...ull-hs3-backup

    https://helpdesk.homeseer.com/articl...ull-hs3-backup

    I can see all my events and devices and scripts.

    I am getting an error whenever a script tries to run, including the startup script:

    Error Compiling script Startup.vb: could not find library 'C:\Program Files\HomeSeer HS3\Bin\System.Data.SQLite.dll'

    It would seem Homeseer compiler is still using the old file paths from Windows 7.

    All my files including scripts are currently in C:\Program Files(x86)\HomeSeer HS3

    How do I fix this without having to rebuild the whole thing?


    #2
    Unfortunately you'll have to edit each script path, as these are stored as absolute vs. relative paths by default. Poor design, and totally unnecessary.

    I make it a habit to change all my script paths to relative. As shown, click on the script selector Edit button, then enter ./scripts/ in the chooser. Then find and select the appropriate entry, then Submit.

    This works on HS3 Windows, but not Linux. There's an odd bug with the latter.
    Attached Files

    Comment


      #3
      How do I modify the script path for the startup script?

      Comment


        #4
        It seems even though I change the script file path in the events, I am still getting the same compiler error.


        Error Compiling script Startup.vb: could not find library 'C:\Program Files\HomeSeer HS3\Bin\System.Data.SQLite.dll'

        Comment


          #5
          I had a similar issue. Remember always back up your HSx directory to a new location.. just in case you need to revert.

          I fixed this by copying my HS3 backup into C:\Program Files(x86)\HomeSeer HS4. I preferred to have HS4 in an HS4 folder so I renamed it. I then downloaded the HS4 install file and installed into that (default) directory.


          Additional steps for win 10: I set up windows to log in automatically on start, I also had to set up a delay before starting HS4 to stop a scheduler.dll error.
          https://www.groovypost.com/howto/aut...in-windows-10/
          Jon00HS4StartupDelayer with default 30 sec delay

          I'm not sure if it was just late at night, but I initially tried to install my fresh install of HS4 into C:\Program Files\HomeSeer HS4; and I swear it decided on it's own to go to C:\Program Files(x86)\HomeSeer HS4
          HS4 Pro on Shuttle NC10U, Win10; Z-NET
          Number of Devices: 449
          Number of Events: 210

          Plug-Ins: Arduino, BLLock, DirecTv, EasyTrigger, Honeywell WiFi Thermostat, MeiHarmonyHub, PHLocation2, Pushover 3P, UltraM1G3, WeatherXML, Worx Landroid, Z-Wave

          External applications: Homebridge-homeseer, Geofency, EgiGeoZone.

          Comment


            #6
            So I created a folder in Program File/HomeSeer HS3/Bin and added the dll file and now scripting is working.

            I tried browsing the homeseer hsd file using browser sqlite but couldn't find where to change the path for this dll reference. Anyone know how I change this?

            Comment


              #7
              Originally posted by jmaddox View Post
              I had a similar issue. Remember always back up your HSx directory to a new location.. just in case you need to revert.

              I fixed this by copying my HS3 backup into C:\Program Files(x86)\HomeSeer HS4. I preferred to have HS4 in an HS4 folder so I renamed it. I then downloaded the HS4 install file and installed into that (default) directory.


              Additional steps for win 10: I set up windows to log in automatically on start, I also had to set up a delay before starting HS4 to stop a scheduler.dll error.
              https://www.groovypost.com/howto/aut...in-windows-10/
              Jon00HS4StartupDelayer with default 30 sec delay

              I'm not sure if it was just late at night, but I initially tried to install my fresh install of HS4 into C:\Program Files\HomeSeer HS4; and I swear it decided on it's own to go to C:\Program Files(x86)\HomeSeer HS4
              Im not upgrading to HS4. I'm just migrating HS3 from windows 7 32 bit to windows 10 64 bit.

              It would seem somewhere in the .hsd database is a filepath that references the System.Data.SQLite.dll. It is still trying to use the old windows 7 file path instead of the new windows 10 filepath. I worked around it as above, but would be nice to fix it correctly.

              Comment


                #8
                It is too late for you all now, but for other readers contemplating this issue, I would suggest that you install Homeseer in a brand new root level directory (i.e "C:\HomeSeer"), rather than in a subdirectory off of Program Files. It is easier to access when updating files within (such as new icon graphic files), copying to a new system (just create the "C:\HomeSeer" directory on the new system), backing up the whole kit and kadoodle, and best of all, not having to redo any paths.

                I did this on my original installation (Windows 10 32 bit system), and it was effortless to port to the new system (Windows 10 64 bit). And for those who already have it as a subdirectory under Program FIles, perhaps making the conversion to a new root level directory would mean it would be the last time you have to deal with path changes.

                And for those who ask, there is no Windows requirement that installs go into a Program Files subdirectory only.

                Comment


                  #9
                  Originally posted by aa6vh View Post
                  It is too late for you all now, but for other readers contemplating this issue, I would suggest that you install Homeseer in a brand new root level directory (i.e "C:\HomeSeer"), rather than in a subdirectory off of Program Files. It is easier to access when updating files within (such as new icon graphic files), copying to a new system (just create the "C:\HomeSeer" directory on the new system), backing up the whole kit and kadoodle, and best of all, not having to redo any paths.

                  I did this on my original installation (Windows 10 32 bit system), and it was effortless to port to the new system (Windows 10 64 bit). And for those who already have it as a subdirectory under Program FIles, perhaps making the conversion to a new root level directory would mean it would be the last time you have to deal with path changes.

                  And for those who ask, there is no Windows requirement that installs go into a Program Files subdirectory only.
                  I actually tried installing into "Program Files" instead of "Program Files(x86)" but Homeseer mangled things up big time. Files were placed in the root directory as well as in Program Files... so I started over... didn't try the root directory to begin with.

                  Comment


                    #10
                    Check file ./Config/settings.ini for any instances of 'C:\Program Files\...' and change to 'C:\Program Files(x86)\...'

                    Comment


                      #11
                      Originally posted by prsmith777 View Post

                      I actually tried installing into "Program Files" instead of "Program Files(x86)" but Homeseer mangled things up big time. Files were placed in the root directory as well as in Program Files... so I started over... didn't try the root directory to begin with.
                      Yes, the Windows installer will do that sort of thing when installing to a Program Files subdirectory, depending on if the to be installed program is a 32 bit program or a 64 bit program (HS is 32 bit). Should not happen when installing somewhere else other than a Program Files subdirectory (and it didn't for me).

                      Comment


                        #12
                        Originally posted by zwolfpack View Post
                        Check file ./Config/settings.ini for any instances of 'C:\Program Files\...' and change to 'C:\Program Files(x86)\...'
                        That what was I was looking for. Thanks !!

                        Comment

                        Working...
                        X