Announcement

Collapse
No announcement yet.

HS3 to HS2 to HS1 Interplay

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Had you previously updated to the earllier post
    Bidirection device support exists in the attached. There are changes from the database used in the single direction version of the plugin so it is not backward compatible with prior version. If you update then you likely will need to redefine your accepted messages and also will likley need to first delete/rename your existing mcsXap database. If uni-directional support is all you are wanting at this time then no point in using this bidirectional version. If you are starting then this is the best one to use.

    Comment


    • #77
      HS3 to HS2 to HS1 Interplay

      Michael, should this version of the plugin be able to create xap messages fromHS device too? I'd like to be able to set dim levels on my lights from HS as well as see their status as reported over xap.
      Author of Highpeak Plugins | SMS-Gateway Plugin | Blue Iris Plugin | Paradox (Beta) Plugin | Modbus Plugin | Yamaha Plugin

      Comment


      • #78
        Bump
        Originally posted by donstephens View Post
        Referring to Include content line. Argument not optional

        Didn't want to bug you with this, but I can't figure out how to trap for the blank device code. My log is full of the error messages. Is there a way to find the offending devices?

        Thanks?
        Don

        Comment


        • #79
          Originally posted by Michael McSharry View Post
          Had you previously updated to the earllier post
          No. But I deleted the database. I did it twice just to be sure.

          Comment


          • #80
            Bill, I reposted the zip file above after correcting the database schema. Delete your database again and the new one should be good. I had been focusingn on Events the past month and never went back to the setup page to confirm it still worked.

            beerygaz, The plugin is two-way so changes in HS will be reflected in xAP if the device has been selected to output via mcsXap.

            Don, I think I need a little hint as to what the error messages look like. mcsXap does not assign device codes, but does put the HS3 unique device reference id in the Address property.

            Comment


            • #81
              Michael:

              The error message in the HomeSeer Log is

              IncludeContent line 20. Argument not optional

              You suggested previously that there were devices with no house or device codes associated with them. This is with HS2.

              Originally posted by Michael McSharry View Post
              I added more info in the error message from IncludeContent. It appears that the device code for a message that is being sent via xAP is blank so when the hs function to get its current status is called (hs.DeviceStatus(sDC)) the error is raised..
              I have looked at all my devices, and all appear to have codes assigned to them. I have also turned on General Debug. Didn't see anything from there.
              I'm not sure how to proceed from here.

              Thanks

              Originally posted by Michael McSharry View Post
              Don, I think I need a little hint as to what the error messages look like. mcsXap does not assign device codes, but does put the HS3 unique device reference id in the Address property.
              Don

              Comment


              • #82
                I had posted a plugin version that had more information in the IncludeContent error message. I also posted one that should have it as well at http://board.homeseer.com/showthread.php?t=161128
                This should help with the islolation.

                Comment


                • #83
                  Thanks for the quick reply. Will give it a try.

                  I am getting the error message
                  Could not load file or assembly Mono.Data.Sqlite ver 2.0.0.0
                  I then downloaded mySQL SQlite.zip that you kindly provided another user. No luck. Tried downloading XapmscDatabase2009. Still can't load mcsXap plugin.

                  Is there some magic to loading Mono.Data.Sqlite? Do I need to register the dll?
                  Last edited by donstephens; July 24th, 2013, 02:38 PM.
                  Don

                  Comment


                  • #84
                    Did you already try the one with more info earlier and it was the one that identified that the DeviceCode was blank? If this is the case then the diagnostic process is to reduce the number of devices you have selected to be sent from HS2 via xAP. If you have only one then the analysis will be easier.

                    Comment


                    • #85
                      makes sense. I'll do that.
                      Don

                      Comment


                      • #86
                        That fixed it. I now have bidirectional information flowing between HS2 and HS3. Thanks Michael!

                        Bill

                        Comment


                        • #87
                          At your convenience can you try the xAP Receive or Timeout trigger and the xAP action to send a message. I have problems with HS3 remembering the setup. For the action the message is most easily formed by using xAP Message Viewer. For the trigger the address can use xAP wildcards of * and >. With HS2 the UI was individual text boxes for the parameters.

                          Comment


                          • #88
                            OK. Solved my problem. Thank you very much.

                            If you have a moment, could you advise me how to run the latest version of mcsXap? Running Version 1.6.6 successfully. Getting error

                            Could not load file or assembly Mono.Data.Sqlite ver 2.0.0.0 when trying to load 2.3.1.4.

                            I can use older version but would like to take advantage of 2.3.1.4.

                            Again, thanks for taking the time to help.
                            Last edited by donstephens; July 24th, 2013, 11:54 PM.
                            Don

                            Comment


                            • #89
                              I missed all this progress re a HS3 xAP plugin as there was no 'xAP' in the subject so it's great to discover the progress being made. I have purchased HS3, something I wouldn't have done without a xAP plugin.

                              It's always surprising the new applications that xAP is useful for - in this case a HS2>HS3 migration aid synching HS2 devices into HS3 and alleviating the wait on HS3 versions of many plugins.

                              Now I've found this thread if I can help on any general xAP questions I'll do my best. I know we haven't done the best work re a good getting started guide.

                              In reading through this thread I did notice this
                              Originally posted by billt View Post
                              In my experience the mcsxap stuff is very fussy about hubs and will only work with the mcsxaphub.
                              There should be no real difference in core functionality between xAP hubs and so if you do have anything specific you can detail it would help fix any issues.

                              Lastly can I just say a big thank you to Michael on behalf of xAPAutomation for all the work and effort you have put in for xAP, and the manner in which you respond so promptly to support questions - it's very much appreciated by us and I'm sure everyone here too.

                              Kevin

                              Comment


                              • #90
                                Don, if we need to continue this discussion could you open another thread in xAP Discussions so we do not confuse HS2 plugin vs. HS3 plugin. In the xAP Library is version 3 of mcsXap and the links contains all four files that should be needed to run that version. It should be the correct version of mono.data.sqllite and the compatible sqllite3.dll.

                                Before unzipping save off your current version of files with the same name so you will be able to go back if there are issues.


                                Originally Posted by billt
                                In my experience the mcsxap stuff is very fussy about hubs and will only work with the mcsxaphub.
                                I suspect the issue reported has to do with malformed xAP messages. At some time in the past the ones from Stuart and Edward had message validation. For those that are part of a development environment this is useful information, but for end users who have no clue then this is just an obstacle. mcsXapHub has minimal validation so malformed messages will typcially pass through.

                                Comment

                                Working...
                                X