Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mrhappy View Post
    You need at least one application set up for the sound loading and message sending to work, have you set one up with the application key entered into the plugin?
    uhhhh... set up the plug-in and android app
    did enter the appkey

    Made an event

    what did I miss ?

    trying to send a notification from HS to Droid...
    Last edited by gearyt; June 16, 2015, 06:10 PM.
    Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

    Comment


      now this...
      Attached Files
      Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

      Comment


        Missing application is the problem.. what is everyone using ?
        Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

        Comment


          Originally posted by gearyt View Post
          Missing application is the problem.. what is everyone using ?
          I'm using V15 from this thread. Just download the .exe file from that link and place it in your \Program Files\HomeSeer HS3\ root folder.
          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


            Originally posted by gearyt View Post
            Missing application is the problem.. what is everyone using ?
            Originally posted by rprade View Post
            I'm using V15 from this thread. Just download the .exe file from that link and place it in your \Program Files\HomeSeer HS3\ root folder.
            Randy has pointed to the last version - this version is a version that may be slightly problematic to old existing users and I need to test it when I get a couple of hours, new users however will be fine with it. The failed interface error status should not appear though, I thought I had fixed that but try the .15 version.

            Have you created your own application on the Pushover website (you cannot use one of the public applications) and then put a name and the application key into the plugin? The .15 version should tell you whether you put the correct key in as it will try and validate the key with Pushover.

            Comment


              Originally posted by mrhappy View Post
              Randy has pointed to the last version - this version is a version that may be slightly problematic to old existing users and I need to test it when I get a couple of hours, new users however will be fine with it. The failed interface error status should not appear though, I thought I had fixed that but try the .15 version.
              I'm not seeing any problems. Is there anything I should be looking out for?
              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


                Originally posted by rprade View Post
                I'm not seeing any problems. Is there anything I should be looking out for?
                Basically the issue now is that when you add a new application then it will download a list of devices to the plugin and automatically add these - this is great for new users but people who have added devices manually then it could present problems with case sensitivity OR devices in Pushover they don't want in the plugin (which are easy to delete as normal). People may already have 'iPad' in the plugin but the device may have been added to Pushover with 'ipad'. I tried my best to cater for all of this in numerous places (and basically ignore case - I can't think someone would call two iPads with the name 'iPad' and 'ipad' but instead use a more descriptive name) and I think I have I just need to sit down with new and old versions and test it, the last thing I want is to break someones 50/60 event actions.

                Comment


                  Gee,,,, RTFM and most the problems go away.... go figure
                  Attached Files
                  Last edited by gearyt; June 17, 2015, 10:02 AM.
                  Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                  Comment


                    Originally posted by rprade View Post
                    I'm just curious, many others have posted similar requests on other event construction, why the aversion to 2 events?

                    I'm not saying you are wrong for trying, but I am curious why I see so much effort given to reduce the number of events. -especially when it takes more time and effort to avoid the additional event than it does to build it. Multiple events are easier to track in the log, if they are carefully named they are easy to follow and annotate, delayed events are easier to cancel and events consume negligible amounts of memory and clock cycles.
                    Originally posted by S-F View Post
                    Personally the number of events I have is getting out of hand. It's becoming difficult to find them to edit them down the line. All of this could be solved by having sub groups but it doesn't seem like this is going to get any traction. I hear you that it is easier to debug when you have multiple events and this is why I think sub groups is the way to go. The way it is now I'm having to create tons of groups and that gets difficult to keep track of also. This one issue is holding me back from creating a few hundred more events right now.
                    Originally posted by rprade View Post
                    You know I'm 100% with you on subgroups. We dicussed it and I described it in this thread. I filed a Bugzilla enhancement request 2505 in January, two people piled on but it remains untouched since then.

                    I've gone to creating general groups, then additional groups under them such as
                    • Lighting Controls - General
                    • Lighting Controls - Location
                    • Lighting Controls - Motion
                    • Lighting Controls - Time

                    • Power Controls - General
                    • Power Controls - Location
                    • Power Controls - Seasonal
                    • Power Controls - Temperature
                    • Power Controls - Time
                    S-F made it real easy to answer your question... I think I'm using pretty good naming structures in the event system, but man-0-man it's becoming a pain to manage...
                    RJ_Make On YouTube

                    Comment


                      looks like I got out of HS.. Just not to Android
                      Attached Files
                      Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                      Comment


                        Originally posted by mrhappy View Post
                        The .15 version should tell you whether you put the correct key in as it will try and validate the key with Pushover.
                        where do I check ?
                        Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                        Comment


                          Would it be possible to run this plugin on the Zee2?
                          Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort

                          Comment


                            Originally posted by gearyt View Post
                            looks like I got out of HS.. Just not to Android
                            Originally posted by gearyt View Post
                            where do I check ?
                            I don't think the application key is correct, please can you double check it (make sure you have the user and application around the right way). The plugin is not talking to the application because the last messages remaining device is showing 0.

                            Originally posted by U5tabil View Post
                            Would it be possible to run this plugin on the Zee2?
                            Who knows, I have not seen any guidance for plugin authors for the Zee S2 and whether anything special needs to be done. The plugin itself should run on Linux fine (certainly did when I last tried) but I don't know if anything different is going to be done in terms of the Zee. There is also the issue of the updater, I don't use it so you would have to copy the file across manually using some method but it is only one file to copy across. Stands a good chance but I can't guarantee it.

                            Comment


                              looks ok to me
                              Attached Files
                              Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro

                              Comment


                                OK can you enable debug mode and try and send a message, it should put a load of stuff into the console window and I could do with looking at that. I'll get it working somehow! If you want to email me if that is easier then I can go through it there instead to solve you the hassle of editing out your user keys...

                                Comment

                                Working...
                                X