Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by mrhappy View Post
    I have fixed it in the new version posted above
    Awesome...I will test it out. Thanks!

    I have an unrelated feature suggestion...

    The plugin currently automatically sets the sound to "pushover" by default, and I always have to change it. Could you change this to "System Default"? Or better yet, make the default sound for new Pushover actions something that is configurable in the plugin options page (or directly via ini file)?

    Comment


    • One more feature suggestion...

      Would it be possible to make the message body entry element a textarea instead of a textbox? This would make the entry of multiline messages much easier.

      Comment


      • Originally posted by mrhappy View Post

        If there are no issues I will post it to the top post - here it is - https://drive.google.com/file/d/0B5D...ew?usp=sharing
        Installed it early this morning. It seems to be working well. I send URLs with location information as the message body from a PHLocation device and it is properly displaying the lines without overwriting them.
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • Originally posted by mrhappy View Post
          Here is a new version wondering if someone can try
          If there are no issues I will post it to the top post - here it is - https://drive.google.com/file/d/0B5D...ew?usp=sharing
          Did some testing. The Pushover app is now correctly displaying the line breaks. However, there is now a weird issue where the message overflows the table cell when viewing the message list. Everything seems correct when viewing the individual message.
          Attached Files

          Comment


          • Originally posted by teladog01 View Post
            Awesome...I will test it out. Thanks!

            I have an unrelated feature suggestion...

            The plugin currently automatically sets the sound to "pushover" by default, and I always have to change it. Could you change this to "System Default"? Or better yet, make the default sound for new Pushover actions something that is configurable in the plugin options page (or directly via ini file)?
            I will make the System Default the default sound, that is the easiest way to do it with the way I have written it.

            Originally posted by teladog01 View Post
            One more feature suggestion...

            Would it be possible to make the message body entry element a textarea instead of a textbox? This would make the entry of multiline messages much easier.
            I wanted to do this myself (because 512 characters on a single line can't be fun or easy) however there is no in built jQuery text area function (here is the list of jQuery controls http://homeseer.com/support/homeseer...y_controls.htm and unless I am missing it the only way is the text box control I already have). I don't know whether this is an oversight or the intention is to just embed a textarea tag, I will look further and see what I can do.

            Originally posted by teladog01 View Post
            Did some testing. The Pushover app is now correctly displaying the line breaks. However, there is now a weird issue where the message overflows the table cell when viewing the message list. Everything seems correct when viewing the individual message.
            I am afraid that does look like a Pushover app issue to me, now I have confirmed I am sending the messages correctly then perhaps there are other issues with formatting. I will ask and see what they say...
            My Plugins:

            Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
            Yeelight 3P | Nanoleaf 3P

            Comment


            • I have posted version .17 to the first post, I have made the system default sound as the first sound in the list by default. I have not looked at the text area field yet but will do at some point and/or ask HST to create a jQuery one and see what the reply is.
              My Plugins:

              Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
              Yeelight 3P | Nanoleaf 3P

              Comment


              • Hi mrhappy,

                I've installed 0.0.0.17 and ALL is running OK now !

                (also sending to my different devices)

                Thanks,
                Fischi

                Comment


                • Does version 0.0.0.17 work with Linux?? I am getting the following error:
                  Unknown Exception in Pushmessage: Object reference not set to an instance of an object. I have triple check my configurations keys and they appear to be correct.
                  Thanks
                  John

                  Comment


                  • Originally posted by jmmorgan View Post
                    Does version 0.0.0.17 work with Linux?? I am getting the following error:
                    Unknown Exception in Pushmessage: Object reference not set to an instance of an object. I have triple check my configurations keys and they appear to be correct.
                    Thanks
                    John
                    Have you upgraded from a particularly old version or from the last version? I have had an entertaining hour or so fighting with a VM of Linux & HS and I think that I have found the issue and I think it is likely to have come around when I added the application setting to the plugin (v0.0.0.10) as it seems to get to the point it needs to look at the Hashtable containing the application lists then it fails. As I use the same in windows (I am using my own config) I think it is the mono adaptation of it - I will need to look further. If you have upgraded from the last released version then I am at a complete loss.
                    My Plugins:

                    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                    Yeelight 3P | Nanoleaf 3P

                    Comment


                    • I'm still convinced that it is an application issue - possibility that some of the events may be trying to send the wrong application name to the plugin and then it is failing. I have put in a fix so that it if it cannot find the application name then it just picks the first out of the table but it may be that you need to double check your events in the application name are correct. If you only have one application then you can probably just get away with this version and leaving it alone.

                      This version also fixes the debug logging in Linux.

                      Could you please try it and let me know how you get on - https://drive.google.com/file/d/0B5D...ew?usp=sharing
                      My Plugins:

                      Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                      Yeelight 3P | Nanoleaf 3P

                      Comment


                      • GREAT!!!! That worked. I did upgrade from an older version that I was using on my windows system. Unfortunately, the window computer crashed and burned, so I was trying to run Homeseer on RPi2. The software runs on the RPi2 just as well as on a PC. The challenge has been getting key plug in to run under Linux. Your plug in is great!! Thanks for all of your help.
                        John

                        Comment


                        • Message Body optional possible ?

                          Originally posted by teladog01 View Post
                          One more feature suggestion...

                          Would it be possible to make the message body entry element a textarea instead of a textbox? This would make the entry of multiline messages much easier.
                          Actually I'd like to see the Message Body as optional. Try sending a push without completing that field and PO generates this erro Pushover 3P Unknown Exception in Pushmessage: Object reference not set to an instance of an object

                          As soon as you enter a subject the event collapses as if it has all the data it needs. It would be very nice if PO would work in that state.

                          Sometimes a simple status push using the subject line would be adequate so why require the body of the message?


                          Comment


                          • I'll fix that error, it does behave a little oddly and I tried changing the auto post back before iirc and it did nothing. I have to send something as a message, you can't just send the title (although you can send a message with no title) - https://pushover.net/api
                            My Plugins:

                            Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                            Yeelight 3P | Nanoleaf 3P

                            Comment


                            • Originally posted by Kitar View Post
                              Actually I'd like to see the Message Body as optional. Try sending a push without completing that field and PO generates this erro Pushover 3P Unknown Exception in Pushmessage: Object reference not set to an instance of an object

                              As soon as you enter a subject the event collapses as if it has all the data it needs. It would be very nice if PO would work in that state.

                              Sometimes a simple status push using the subject line would be adequate so why require the body of the message?


                              I have tried to mess with the auto post back that tries to collapse the event but I am not sure on the best way to approach it, I have to do it at some point because pressing the yellow arrow to collapse the event does not appear to behave the same by calling ActionProcessPostUI. I've tried adding a button but can't get that to behave the same either but that is likely to be my issue. I'll need to do some more work on it really because of the optional/required fields that need to be handled correctly.
                              My Plugins:

                              Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                              Yeelight 3P | Nanoleaf 3P

                              Comment


                              • Originally posted by mrhappy View Post
                                I have tried to mess with the auto post back that tries to collapse the event but I am not sure on the best way to approach it, I have to do it at some point because pressing the yellow arrow to collapse the event does not appear to behave the same by calling ActionProcessPostUI. I've tried adding a button but can't get that to behave the same either but that is likely to be my issue. I'll need to do some more work on it really because of the optional/required fields that need to be handled correctly.
                                You must live to code. And for that we should be grateful. It is more of an observation than complaint regarding the collapse of the event element when the data is populated. Your PO plugin rocks and frankly I am surprised it is free. The only fault I can give it is the design of PO for requiring download of the sound clips which seems to me to be a bit backwards but when it fails the error handling runs amok.

                                Comment

                                Working...
                                X