Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by JxxxIxxx View Post
    First, Thank you so much for this incredibly useful plugin. It is really amazing that it is for free. Is is really an extensive and well designed package, much more complete than some other plugins that I have paid money for and was quite dissapointing in functionality by comparison.
    Then for my question: Regarding the 512 character message text limit, is this still applicable? According to the Pushover API docs the limit is 1024? When testing I am able to send messages up to 1024 characters from the Pushover web interface, so that seems to confirm that this is the current limit..
    So maybe the maximum limit has been changed at some point?
    If that is the case, would it be possible to update the plugin to accept up to 1024 characters? I have some HS notifications that contain quite a lot of information and I am bumping up against the 512 c limit and need to split the notifications, which makes them less readable and understandable.
    Thank you for the kind words, the 512 limit certainly used to be the limit but if the API has been changed to 1024 chars then I should be able to change that easily. They must've changed it quietly as I never noticed...I'll double check there are no other changes and post a new version in the updater.
    My Plugins:

    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
    Yeelight 3P | Nanoleaf 3P

    Comment


    • Originally posted by mrhappy View Post

      Thank you for the kind words, the 512 limit certainly used to be the limit but if the API has been changed to 1024 chars then I should be able to change that easily. They must've changed it quietly as I never noticed...I'll double check there are no other changes and post a new version in the updater.
      There were no other changes that I could see apart from the message length, I've updated the plugin and given it a little test and seems to work OK. I've submitted it to the updater (Version .45) however I don't know what the HS staffing is like over Christmas as to when this might appear.
      My Plugins:

      Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
      Yeelight 3P | Nanoleaf 3P

      Comment


      • Originally posted by mrhappy View Post

        There were no other changes that I could see apart from the message length, I've updated the plugin and given it a little test and seems to work OK. I've submitted it to the updater (Version .45) however I don't know what the HS staffing is like over Christmas as to when this might appear.
        Update installed and tested. Seems to work perfectly with the 1024 character limit.
        Thanks a lot for a rapid response.

        Comment


        • Feature Request:

          It would be nice to be able to know which user Acknowledged an Emergency message and use that in any event. So one John asked the message HS3 could send out another standard message that says "John acknowledged the message" so other users know who did it.

          It would also be nice to know which emergency message was acknowledged so when acknowledging you could run different events based on the emergency message that was acknowledged. That way my smoke alarm and co alarm could have different acknowledge events.
          HomeSeer Version: HS3 Standard Edition 3.0.0.531 | Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:02:17 UTC 2019)
          Linux version: Linux auto 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
          IP Address: 10.0.2.16 | Number of Devices: 417 | Number of Events: 667 | Available Threads: 399 | HSTouch Enabled: True

          Enabled Plug-Ins: AirplaySpeak: 3.0.0.13 | BLBackup: 2.0.61.0 | EasyTrigger: 3.0.0.65 | LiftMaster MyQ: 1.3.7006.42100
          mcsMQTT: 4.0.2.2 | PHLocation2: 3.0.0.53 | Pushover 3P: 0.0.0.45 | Z-Wave: 3.0.1.262

          Z-Net version: 1.0.23 using a HomeSeer SmartStick+: 6.04 (ZDK 6.81.3)

          Comment


          • Originally posted by Timon View Post
            Feature Request:

            It would be nice to be able to know which user Acknowledged an Emergency message and use that in any event. So one John asked the message HS3 could send out another standard message that says "John acknowledged the message" so other users know who did it.

            It would also be nice to know which emergency message was acknowledged so when acknowledging you could run different events based on the emergency message that was acknowledged. That way my smoke alarm and co alarm could have different acknowledge events.
            I will have a look at this again but the reasoning behind not doing that to start with was that I would have to try and log all of the user data and then try and figure out which user sent the message to start with. That is slightly different now as I do store (for debug purposes really) some of the messages in a mini database but I would probably need to start storing the message ID numbers and attempt to match them to a user.
            My Plugins:

            Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
            Yeelight 3P | Nanoleaf 3P

            Comment


            • I'm more interested in knowing which message was acknowledged than which user acknowledged it. Knowing which user would be a nice added bonus, though.

              Comment


              • I have just updated the plugin and now the messages are no longer sent. I see this in my HS3 logs
                Feb-01 1:08:00 AM Pushover 3P Unknown Exception in Pushmessage Object reference not set to an instance of an object.
                Feb-01 1:08:00 AM Pushover 3P WebException Error The underlying connection was closed: An unexpected error occurred on a receive.
                ‘I have updated all of my events but still get this message. Any advice on how to fix this appreciated.

                Comment


                • I'm having an issue with sending an image. Using a script I'm using this for the last parameter.

                  CO(8) = "C:/ContaCam/Garage/snapshot_thumb.jpg"

                  The message shows up but not the image. There are no errors in the log. Am I formatting this correctly?

                  Thanks
                  Don

                  Comment


                  • Bump
                    Don

                    Comment


                    • I am guessing this is no longer supported, seems a few plugins are going the same way, paid or free


                      Sent from my iPad using Tapatalk

                      Comment


                      • Originally posted by ozinnewy View Post
                        I am guessing this is no longer supported, seems a few plugins are going the same way, paid or free


                        Sent from my iPad using Tapatalk
                        Still seems to be supported to me... Maybe he's on vacation? It's only been four or five days.

                        Comment


                        • Originally posted by ozinnewy View Post
                          I am guessing this is no longer supported, seems a few plugins are going the same way, paid or free


                          Sent from my iPad using Tapatalk
                          As far as I know this is still supported and mrhappy may be on vacation or have other things he's attending to.

                          Comment


                          • Have any of you successfully sent an image? If so could you share how?

                            Thanks
                            Don

                            Comment


                            • Originally posted by donstephens View Post
                              Have any of you successfully sent an image? If so could you share how?

                              Thanks
                              Just tried it too and not working for me either from an event or script.
                              HS 3.0.0.548: 1965 Devices 1146 Events
                              Z-Wave 3.0.1.262: 122 Nodes on one Z-Net

                              Comment


                              • Well, I'm glad it not just me. Thanks for checking.
                                Don

                                Comment

                                Working...
                                X