Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Here is another capture of the start up, interesting it says Sendmessage is False device value is 0.
    Not sure if that's something?

    Sub Main() Called
    Connecting to server at 127.0.0.1...
    Connected, waiting to be initialized...
    [8/21/2014 1:41:01 PM] Plugin Starting
    [8/21/2014 1:41:01 PM] emerExpiry: 300
    [8/21/2014 1:41:01 PM] emerInterval: 60
    [8/21/2014 1:41:01 PM] pushToken: aPAFiHUUgedh9XsikJGRmSTQXef4cB
    [8/21/2014 1:41:01 PM] Attempting Sound Download....
    [8/21/2014 1:41:01 PM] Downloading sounds from Pushover
    [8/21/2014 1:41:01 PM] rSound Download: <?xml version="1.0" encoding="UTF-8"?>
    <hash>
    <sounds>
    <pushover>Pushover (default)</pushover>
    <bike>Bike</bike>
    <bugle>Bugle</bugle>
    <cashregister>Cash Register</cashregister>
    <classical>Classical</classical>
    <cosmic>Cosmic</cosmic>
    <falling>Falling</falling>
    <gamelan>Gamelan</gamelan>
    <incoming>Incoming</incoming>
    <intermission>Intermission</intermission>
    <magic>Magic</magic>
    <mechanical>Mechanical</mechanical>
    <pianobar>Piano Bar</pianobar>
    <siren>Siren</siren>
    <spacealarm>Space Alarm</spacealarm>
    <tugboat>Tug Boat</tugboat>
    <alien>Alien Alarm (long)</alien>
    <climb>Climb (long)</climb>
    <persistent>Persistent (long)</persistent>
    <echo>Pushover Echo (long)</echo>
    <updown>Up Down (long)</updown>
    <none>None (silent)</none>
    </sounds>
    <status type="integer">1</status>
    <request>3bc1c0da6404dea5c7d1f398587a73e0</request>
    </hash>

    [8/21/2014 1:41:01 PM] Adding: 0 - pushover - Pushover (default)
    [8/21/2014 1:41:01 PM] Adding: 1 - bike - Bike
    [8/21/2014 1:41:01 PM] Adding: 2 - bugle - Bugle
    [8/21/2014 1:41:01 PM] Adding: 3 - cashregister - Cash Register
    [8/21/2014 1:41:01 PM] Adding: 4 - classical - Classical
    [8/21/2014 1:41:01 PM] Adding: 5 - cosmic - Cosmic
    [8/21/2014 1:41:01 PM] Adding: 6 - falling - Falling
    [8/21/2014 1:41:01 PM] Adding: 7 - gamelan - Gamelan
    [8/21/2014 1:41:01 PM] Adding: 8 - incoming - Incoming
    [8/21/2014 1:41:01 PM] Adding: 9 - intermission - Intermission
    [8/21/2014 1:41:01 PM] Adding: 10 - magic - Magic
    [8/21/2014 1:41:01 PM] Adding: 11 - mechanical - Mechanical
    [8/21/2014 1:41:01 PM] Adding: 12 - pianobar - Piano Bar
    [8/21/2014 1:41:01 PM] Adding: 13 - siren - Siren
    [8/21/2014 1:41:01 PM] Adding: 14 - spacealarm - Space Alarm
    [8/21/2014 1:41:01 PM] Adding: 15 - tugboat - Tug Boat
    [8/21/2014 1:41:01 PM] Adding: 16 - alien - Alien Alarm (long)
    [8/21/2014 1:41:01 PM] Adding: 17 - climb - Climb (long)
    [8/21/2014 1:41:01 PM] Adding: 18 - persistent - Persistent (long)
    [8/21/2014 1:41:01 PM] Adding: 19 - echo - Pushover Echo (long)
    [8/21/2014 1:41:01 PM] Adding: 20 - updown - Up Down (long)
    [8/21/2014 1:41:01 PM] Adding: 21 - none - None (silent)
    [8/21/2014 1:41:01 PM] Downloaded 22 sounds from Pushover - Adding Device Defaul
    t
    [8/21/2014 1:41:01 PM] Attempting to produce a client/group list...
    [8/21/2014 1:41:01 PM] Clients: iphone=Nothing
    [8/21/2014 1:41:01 PM] Current Line 0: iphone Current Line 1: Nothing
    [8/21/2014 1:41:02 PM] Found IFACE_NAME, exit
    [8/21/2014 1:41:02 PM] End Of Enumerator - Create Devices: False
    [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 222 Name: Pushover 3P Root Devic
    e
    [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 223 Name: Pushover 3P Enabled/Di
    sabled
    [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 224 Name: Pushover 3P Last Messa
    ge Sent
    [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 228 Name: Pushover 3P Disable No
    n-Emergency Messages
    [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 230 Name: Pushover 3P Applicatio
    n Messages Remaining
    [8/21/2014 1:41:02 PM] Array: bCode(0) - 222
    [8/21/2014 1:41:02 PM] Array: bCode(1) - 223
    [8/21/2014 1:41:02 PM] Array: bCode(2) - 224
    [8/21/2014 1:41:02 PM] Array: bCode(3) - 228
    [8/21/2014 1:41:02 PM] Array: bCode(4) - 230
    [8/21/2014 1:41:02 PM] Sending Status: False Device Value: 0
    [8/21/2014 1:41:02 PM] ****** InitIO Ended ******

    Comment


    • #92
      OK that appears all normal, can you try sending a message, I am interested in what appears in the developer mode when you do (unless you did in those snapshots? If so something is clearly wrong, the logs you posted look like you have gone into and out of the event actions but nothing else) try and send a message.

      Please edit out your API key though, no need to post that here.
      My Plugins:

      Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
      Yeelight 3P | Nanoleaf 3P

      Comment


      • #93
        The first one i posted was with a message attempt the second was just start-up. This one is also with a message attempt


        Sub Main() Called
        Connecting to server at 127.0.0.1...
        Connected, waiting to be initialized...
        [8/21/2014 1:41:01 PM] Plugin Starting
        [8/21/2014 1:41:01 PM] emerExpiry: 300
        [8/21/2014 1:41:01 PM] emerInterval: 60
        [8/21/2014 1:41:01 PM] pushToken: XXXXXX
        [8/21/2014 1:41:01 PM] Attempting Sound Download....
        [8/21/2014 1:41:01 PM] Downloading sounds from Pushover
        [8/21/2014 1:41:01 PM] rSound Download: <?xml version="1.0" encoding="UTF-8"?>
        <hash>
        <sounds>
        <pushover>Pushover (default)</pushover>
        <bike>Bike</bike>
        <bugle>Bugle</bugle>
        <cashregister>Cash Register</cashregister>
        <classical>Classical</classical>
        <cosmic>Cosmic</cosmic>
        <falling>Falling</falling>
        <gamelan>Gamelan</gamelan>
        <incoming>Incoming</incoming>
        <intermission>Intermission</intermission>
        <magic>Magic</magic>
        <mechanical>Mechanical</mechanical>
        <pianobar>Piano Bar</pianobar>
        <siren>Siren</siren>
        <spacealarm>Space Alarm</spacealarm>
        <tugboat>Tug Boat</tugboat>
        <alien>Alien Alarm (long)</alien>
        <climb>Climb (long)</climb>
        <persistent>Persistent (long)</persistent>
        <echo>Pushover Echo (long)</echo>
        <updown>Up Down (long)</updown>
        <none>None (silent)</none>
        </sounds>
        <status type="integer">1</status>
        <request>3bc1c0da6404dea5c7d1f398587a73e0</request>
        </hash>

        [8/21/2014 1:41:01 PM] Adding: 0 - pushover - Pushover (default)
        [8/21/2014 1:41:01 PM] Adding: 1 - bike - Bike
        [8/21/2014 1:41:01 PM] Adding: 2 - bugle - Bugle
        [8/21/2014 1:41:01 PM] Adding: 3 - cashregister - Cash Register
        [8/21/2014 1:41:01 PM] Adding: 4 - classical - Classical
        [8/21/2014 1:41:01 PM] Adding: 5 - cosmic - Cosmic
        [8/21/2014 1:41:01 PM] Adding: 6 - falling - Falling
        [8/21/2014 1:41:01 PM] Adding: 7 - gamelan - Gamelan
        [8/21/2014 1:41:01 PM] Adding: 8 - incoming - Incoming
        [8/21/2014 1:41:01 PM] Adding: 9 - intermission - Intermission
        [8/21/2014 1:41:01 PM] Adding: 10 - magic - Magic
        [8/21/2014 1:41:01 PM] Adding: 11 - mechanical - Mechanical
        [8/21/2014 1:41:01 PM] Adding: 12 - pianobar - Piano Bar
        [8/21/2014 1:41:01 PM] Adding: 13 - siren - Siren
        [8/21/2014 1:41:01 PM] Adding: 14 - spacealarm - Space Alarm
        [8/21/2014 1:41:01 PM] Adding: 15 - tugboat - Tug Boat
        [8/21/2014 1:41:01 PM] Adding: 16 - alien - Alien Alarm (long)
        [8/21/2014 1:41:01 PM] Adding: 17 - climb - Climb (long)
        [8/21/2014 1:41:01 PM] Adding: 18 - persistent - Persistent (long)
        [8/21/2014 1:41:01 PM] Adding: 19 - echo - Pushover Echo (long)
        [8/21/2014 1:41:01 PM] Adding: 20 - updown - Up Down (long)
        [8/21/2014 1:41:01 PM] Adding: 21 - none - None (silent)
        [8/21/2014 1:41:01 PM] Downloaded 22 sounds from Pushover - Adding Device Defaul
        t
        [8/21/2014 1:41:01 PM] Attempting to produce a client/group list...
        [8/21/2014 1:41:01 PM] Clients: iphone=Nothing
        [8/21/2014 1:41:01 PM] Current Line 0: iphone Current Line 1: Nothing
        [8/21/2014 1:41:02 PM] Found IFACE_NAME, exit
        [8/21/2014 1:41:02 PM] End Of Enumerator - Create Devices: False
        [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 222 Name: Pushover 3P Root Devic
        e
        [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 223 Name: Pushover 3P Enabled/Di
        sabled
        [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 224 Name: Pushover 3P Last Messa
        ge Sent
        [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 228 Name: Pushover 3P Disable No
        n-Emergency Messages
        [8/21/2014 1:41:02 PM] Devices Owned By Plugin: 230 Name: Pushover 3P Applicatio
        n Messages Remaining
        [8/21/2014 1:41:02 PM] Array: bCode(0) - 222
        [8/21/2014 1:41:02 PM] Array: bCode(1) - 223
        [8/21/2014 1:41:02 PM] Array: bCode(2) - 224
        [8/21/2014 1:41:02 PM] Array: bCode(3) - 228
        [8/21/2014 1:41:02 PM] Array: bCode(4) - 230
        [8/21/2014 1:41:02 PM] Sending Status: False Device Value: 0
        [8/21/2014 1:41:02 PM] ****** InitIO Ended ******
        [8/21/2014 4:12:30 PM] ActionConfigured Called DataIn IsNothing: False
        [8/21/2014 4:12:30 PM] ActionConfigured - 3295 Action Keys Count: 0
        [8/21/2014 4:12:30 PM] Call to DeSerialize the Information
        [8/21/2014 4:12:30 PM] Return from DeSerialize Key Count: 7
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mKey_3295_5375_A0 Actions: All Cli
        ents
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mTitle_3295_5375_A0 Actions: Messa
        ge Title
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mMessage_3295_5375_A0 Actions: Mes
        sage Body
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mPriority_3295_5375_A0 Actions: No
        rmal
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mSound_3295_5375_A0 Actions: pusho
        ver
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mURL_3295_5375_A0 Actions:
        [8/21/2014 4:12:30 PM] sKey ActionConfigured: mURLTitle_3295_5375_A0 Actions:
        [8/21/2014 4:12:30 PM] itemsConfigured: 5
        [8/21/2014 4:12:30 PM] Configured: True
        [8/21/2014 4:12:30 PM] *********
        [8/21/2014 4:12:30 PM] ActionCount() 7
        [8/21/2014 4:12:30 PM] ActionCount() 7
        [8/21/2014 4:12:30 PM] ActionName() 1
        [8/21/2014 4:12:30 PM] ActionName Return: Send Pushover Message
        [8/21/2014 4:12:30 PM] ActionBuildUI Called UID: 3295 DataIn IsNothing: False
        [8/21/2014 4:12:30 PM] TANumber: 1 SubTANumber: 0
        [8/21/2014 4:12:30 PM] sUnique: _5375_A0
        [8/21/2014 4:12:30 PM] DeSerialize Called
        [8/21/2014 4:12:30 PM] Action Keys Count: 7
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mKey_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mTitle_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mMessage_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mPriority_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mSound_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mURL_3295_5375_A0
        [8/21/2014 4:12:30 PM] sKey ActionBuildUI: mURLTitle_3295_5375_A0
        [8/21/2014 4:12:30 PM] *********
        [8/21/2014 4:12:35 PM] ActionConfigured Called DataIn IsNothing: False
        [8/21/2014 4:12:35 PM] ActionConfigured - 3295 Action Keys Count: 7
        [8/21/2014 4:12:35 PM] Call to DeSerialize the Information
        [8/21/2014 4:12:35 PM] Return from DeSerialize Key Count: 7
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mKey_3295_5375_A0 Actions: All Cli
        ents
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mTitle_3295_5375_A0 Actions: Messa
        ge Title
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mMessage_3295_5375_A0 Actions: Mes
        sage Body
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mPriority_3295_5375_A0 Actions: No
        rmal
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mSound_3295_5375_A0 Actions: pusho
        ver
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mURL_3295_5375_A0 Actions:
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mURLTitle_3295_5375_A0 Actions:
        [8/21/2014 4:12:35 PM] itemsConfigured: 5
        [8/21/2014 4:12:35 PM] Configured: True
        [8/21/2014 4:12:35 PM] *********
        [8/21/2014 4:12:35 PM] ActionProcessPostUI Called
        [8/21/2014 4:12:35 PM] PostData.Count: 7
        [8/21/2014 4:12:35 PM] mKey_3295_5375_A0
        [8/21/2014 4:12:35 PM] mTitle_3295_5375_A0
        [8/21/2014 4:12:35 PM] mMessage_3295_5375_A0
        [8/21/2014 4:12:35 PM] mPriority_3295_5375_A0
        [8/21/2014 4:12:35 PM] mSound_3295_5375_A0
        [8/21/2014 4:12:35 PM] mURL_3295_5375_A0
        [8/21/2014 4:12:35 PM] mURLTitle_3295_5375_A0
        [8/21/2014 4:12:35 PM] Returns Count: 1
        [8/21/2014 4:12:35 PM] *********
        [8/21/2014 4:12:35 PM] HandleAction Called
        [8/21/2014 4:12:35 PM] PushMessage Sub Called - DeviceName: All Clients
        [8/21/2014 4:12:35 PM] Priority: normal
        [8/21/2014 4:12:35 PM] Emergency Priority - Second Check
        [8/21/2014 4:12:35 PM] SendStatus Is False - Do Not Send The Message
        [8/21/2014 4:12:35 PM] *********
        [8/21/2014 4:12:35 PM] ActionConfigured Called DataIn IsNothing: False
        [8/21/2014 4:12:35 PM] ActionConfigured - 3295 Action Keys Count: 7
        [8/21/2014 4:12:35 PM] Call to DeSerialize the Information
        [8/21/2014 4:12:35 PM] Return from DeSerialize Key Count: 7
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mKey_3295_5375_A0 Actions: All Cli
        ents
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mTitle_3295_5375_A0 Actions: Messa
        ge Title
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mMessage_3295_5375_A0 Actions: Mes
        sage Body
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mPriority_3295_5375_A0 Actions: No
        rmal
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mSound_3295_5375_A0 Actions: pusho
        ver
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mURL_3295_5375_A0 Actions:
        [8/21/2014 4:12:35 PM] sKey ActionConfigured: mURLTitle_3295_5375_A0 Actions:
        [8/21/2014 4:12:35 PM] itemsConfigured: 5
        [8/21/2014 4:12:35 PM] Configured: True
        [8/21/2014 4:12:35 PM] *********
        [8/21/2014 4:12:35 PM] ActionCount() 7
        [8/21/2014 4:12:35 PM] ActionCount() 7
        [8/21/2014 4:12:35 PM] ActionName() 1
        [8/21/2014 4:12:35 PM] ActionName Return: Send Pushover Message
        [8/21/2014 4:12:35 PM] ActionBuildUI Called UID: 3295 DataIn IsNothing: False
        [8/21/2014 4:12:35 PM] TANumber: 1 SubTANumber: 0
        [8/21/2014 4:12:35 PM] sUnique: _5375_A0
        [8/21/2014 4:12:35 PM] DeSerialize Called
        [8/21/2014 4:12:35 PM] Action Keys Count: 7
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mKey_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mTitle_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mMessage_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mPriority_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mSound_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mURL_3295_5375_A0
        [8/21/2014 4:12:35 PM] sKey ActionBuildUI: mURLTitle_3295_5375_A0
        [8/21/2014 4:12:35 PM] *********

        Comment


        • #94
          Sorry you are right, this is the issue:

          [8/21/2014 4:12:35 PM] SendStatus Is False - Do Not Send The Message

          When I updated the plugin to this new version you should have a couple of devices, one of these devices is a master enabled/disabled device. It appears that this has been set to disabled and as such no messages are being sent. Can you try setting this device to enabled please. If this is the case then I will double check that this is enabled by default and add a warning to the log when messages are sent with the device disabled.

          If it shows as enabled then can you try just cycling the device a couple of times see if that causes it to go to life.
          My Plugins:

          Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
          Yeelight 3P | Nanoleaf 3P

          Comment


          • #95
            Originally posted by mrhappy View Post
            Sorry you are right, this is the issue:

            [8/21/2014 4:12:35 PM] SendStatus Is False - Do Not Send The Message

            When I updated the plugin to this new version you should have a couple of devices, one of these devices is a master enabled/disabled device. It appears that this has been set to disabled and as such no messages are being sent. Can you try setting this device to enabled please. If this is the case then I will double check that this is enabled by default and add a warning to the log when messages are sent with the device disabled.

            If it shows as enabled then can you try just cycling the device a couple of times see if that causes it to go to life.
            Thanks for your help Adam. The plugin is working great and now it's time to update all of my scripts to take advantage of it.

            Thanks again,

            Judd

            Comment


            • #96
              Originally posted by jpape View Post
              Thanks for your help Adam. The plugin is working great and now it's time to update all of my scripts to take advantage of it.

              Thanks again,

              Judd
              Thanks for the patience testing it I have checked and like an idiot I did set the device to disabled when it was created I've changed it and will upload a new version. The only other changes are a warning in the logs when there is an error with sending the data and a warning gets sent to the log if the message is sent with the device disabled. I'll upload it in a couple of days...there is no rush for anyone to update to it there is nothing really new in it apart from those minor fixes.
              My Plugins:

              Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
              Yeelight 3P | Nanoleaf 3P

              Comment


              • #97
                Sorry to bother you again but where do I set the device to enable?

                Comment


                • #98
                  Originally posted by mrhappy View Post
                  When I updated the plugin to this new version you should have a couple of devices, one of these devices is a master enabled/disabled device. It appears that this has been set to disabled and as such no messages are being sent. Can you try setting this device to enabled please. If this is the case then I will double check that this is enabled by default and add a warning to the log when messages are sent with the device disabled.
                  Hi Adam,

                  That's what it was. I changed it to "Enabled" and all is good.

                  Cheers
                  Al
                  HS 3.0.0.548: 1976 Devices 1156 Events
                  Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                  Comment


                  • #99
                    Originally posted by FernandoSolanes View Post
                    Sorry to bother you again but where do I set the device to enable?
                    Hi Fernando,

                    Under Device Management, if you filter on "Pushover 3P", you should see the following devices.

                    Cheers
                    Al
                    Attached Files
                    HS 3.0.0.548: 1976 Devices 1156 Events
                    Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                    Comment


                    • Haha I thought I was going crazy, when I filtered under Pushover I had no devices. Then clicked show all and there it was Disabled.
                      I enabled it and works like a charm.
                      Thank you MrHappy and all for your input and help

                      Comment


                      • Originally posted by FernandoSolanes View Post
                        Haha I thought I was going crazy, when I filtered under Pushover I had no devices. Then clicked show all and there it was Disabled.
                        I enabled it and works like a charm.
                        Thank you MrHappy and all for your input and help
                        Glad you got it working in the end, it should have been my first thing to check but they are a recent addition and I completely forgot about them.
                        My Plugins:

                        Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                        Yeelight 3P | Nanoleaf 3P

                        Comment


                        • Error when installing plugin

                          Hi, I used your Hs2 P3 plugin and loved it (receiving alarm push messages being on holidays in the South of France and now just started to use Hs3 I also wanted to install the Hs3 version. After downloading the latest file, i copied it into the Hs3(pro) directory and went to the manage plugin tab. There the plug shows up than clicking enable, the plugin will initialised and shows up in the list showing an error!



                          Having a look at the log Hs3 mentions: Unable to initialize Pushover P3 : either no license or trail period expired?
                          Apparently something went wrong i the file you provided? So what to do?

                          Wiechert.
                          Attached Files

                          Comment


                          • That error unfortunately is quite a generic and common one and difficult to find out what has caused it but apparently it is due to spending too much time in the InitIO function. Can you click to enable developer mode please then restart the plugin, take a look at the console window that will come up on the computer and copy and paste the entries here (you can edit out any API/user keys) and I should be able to see what is happening.
                            My Plugins:

                            Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                            Yeelight 3P | Nanoleaf 3P

                            Comment


                            • Thanks for the fast reply. I activated the developer mode. Now when enabling the plugin again I see a black terminal screen poping up for a few seconds saying something like: connecting to 127.0.000 etc. Than it ends. And the message as shown in the image comes up again. I can not copy anything from the terminal window since its only there for a few seconds.

                              Some other strange thing occurd (I already noticed it before) the .exe file was deleted from the Hs3 dir everytime the enabling was started. First I thought it was some cleaver thing Hs3 had build in. But than I saw that, My virusscanner had deleted the file since it found out that it holds an Trojan Virus! It says its: SONAR. HEURISTIC.120
                              So this might be the problem?

                              W.

                              Comment


                              • Originally posted by nl_user View Post
                                Thanks for the fast reply. I activated the developer mode. Now when enabling the plugin again I see a black terminal screen poping up for a few seconds saying something like: connecting to 127.0.000 etc. Than it ends. And the message as shown in the image comes up again. I can not copy anything from the terminal window since its only there for a few seconds.

                                Some other strange thing occurd (I already noticed it before) the .exe file was deleted from the Hs3 dir everytime the enabling was started. First I thought it was some cleaver thing Hs3 had build in. But than I saw that, My virusscanner had deleted the file since it found out that it holds an Trojan Virus! It says its: SONAR. HEURISTIC.120
                                So this might be the problem?

                                W.
                                That's fine I have seen what I need to. If it does not even connect then that is the first problem, what looks very wrong is the IP address should be 127.0.0.1 so something is interfering with that. I think problem #2 needs to be fixed first.

                                If you search around for SONAR.HEURISTIC.120 on the internet it seems to suggest that it is a false positive and not in fact a virus, I guess that it is interfering with the process of connecting in some capacity. It might be worth looking at adding some sort of exception to the HSPI_PUSHOVER.exe file (if you can, I don't know what AV software you use) because if it puts your mind at rest I have just scanned it with Microsoft Security Essentials and there are no threats found. I think that needs to be sorted out first.
                                My Plugins:

                                Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                                Yeelight 3P | Nanoleaf 3P

                                Comment

                                Working...
                                X