Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by MNB View Post
    Thanxs Randy, re the links I noticed that I'm not the only one that seems to have issue, I get the following (just went to 1st post of this thread) error below, so I do not know what's special about the "mile high" region, is it possible to post a copy of the document for those of us who can not gain access? Update: Never mind it helps when one reads your post correctly...

    Thanxs for information re replaceable values, I will try the single $Time, Mike
    This still begs the question of why you need to embed the time and date in a message that has a time and date stamp.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • "Because!" (as the child responded)

      Normally when I look at my pushover messages depending on device type (screen size) iPhone vs tablet I normally look at the title first and secondly the message body and this depends on where/when I view a notification. I know KISS principle should be obeyed but when one gets opportunities to elaborate using PushOver I'm exploring the potential, I just got my camera motion detection which just gave me text notification to also now include the camera snapshot which makes the notification better as I would have to go to my BI app to view my home camera's. Mike
      Computer: CUK Intel NUC7i7BNH
      Op System: Windows 10 Pro - Work Station
      HS Version: HS3 Pro Edition 3.0.0.435

      Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

      Comment


      • I just noticed some thing interesting, I was trying to update my previous PushOver message body and no matter what I type in and depress "Update" the new text simply disappears can someone else confirm I'm currently using HS3 v.511 and Pushover v.63, Mike
        Computer: CUK Intel NUC7i7BNH
        Op System: Windows 10 Pro - Work Station
        HS Version: HS3 Pro Edition 3.0.0.435

        Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

        Comment


        • I just tried it, and it correctly updated to the new text. However, I am at HS3Pro V.500 and Pushover v.45.

          Comment


          • Thanxs Joe, I did the PI disable/re-enable and the browser cache clear Ctl-F5 with no success so.. I will do a HS3 restart in the hopes that solves my issue. Mike

            Update: Well did an HS3 restart and again no success, I then decided to create another send Pushover message within the same event and it allowed my to update but it then exploded (my event screen) displayed what looked like a html like code (was able to duplicate) when I closed the browser tab and reinitialized a event screen everything look fine, so I deleted the old PushOver Message and was able to finish the replacement PushOver Message with no problem. Soo.. somehow I had a corrupt event trigger but I'm glad I'm operation once again. Mike
            Computer: CUK Intel NUC7i7BNH
            Op System: Windows 10 Pro - Work Station
            HS Version: HS3 Pro Edition 3.0.0.435

            Plug-Ins: BLBackup, BLGData, BLRoombaWifi, Device History, EasyTrigger, ImperiHome, Nest, PHLocation, Pushover 3P, Restart, Sonos, UltraCID3, UltraWeatherWU3, Z-Wave, and Jon00 scripts.

            Comment


            • Hey guys...glad to hear Adam is ok. Any chance anyone has a copy of the setup document? Or any chance someone could see if Adam could post it as a sticky thread? Thanks

              Comment


              • As an FYI in case anyone else is wondering, Adam is ok, but recently started a new job that has kept him extremely busy.

                Thanks for the head's up.
                Don

                Comment


                • Just checked and see that I’m still on V.45.....with the domain down, is it possible to get the update somewhere else here? Are there release notes on what’s changed since .45?


                  Sent from my iPad using Tapatalk
                  HS3 3.0.0.500 &HSTouch Designer 3.0.71 with 782 Devices, 479 Events
                  Plugin's:
                  BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee,
                  EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
                  weatherXML, Jon00 Alexa Helper, Network Monitor, Z-Wave 3.0.1.252

                  Comment


                  • According to the documentation for the Pushover Glances API:

                    To clear a previously-updated field, send the field with a blank (empty string) value.
                    The reason I need to clear the Count and Percentage fields, is that the Pushover complication on the Infograph watch face will not display the Text field if there is a value set on either the Count or Percentage fields (per Pushover support).

                    When I try to enter an empty string in either the Count or the Percentage field, I get an error after clicking the Update button. Am I doing it wrong or is this a bug?


                    Click image for larger version

Name:	Screenshot 2019-02-28 12.43.15.png
Views:	11
Size:	20.1 KB
ID:	1288796

                    Click image for larger version

Name:	Screenshot 2019-02-28 12.43.49.png
Views:	11
Size:	12.5 KB
ID:	1288797

                    Click image for larger version

Name:	Screenshot 2019-02-28 12.44.10.png
Views:	11
Size:	20.1 KB
ID:	1288798

                    Click image for larger version

Name:	Screenshot 2019-02-28 12.44.18.png
Views:	11
Size:	11.3 KB
ID:	1288799

                    Comment


                    • The plugin documentation link is offline, does anyone have a copy?

                      I am specifically needing to see the details for PluginFunction PushScript. I found this post, but it doesn't say what the last three parameters are.

                      Comment


                      • Originally posted by teladog01 View Post
                        The plugin documentation link is offline, does anyone have a copy?

                        I am specifically needing to see the details for PluginFunction PushScript. I found this post, but it doesn't say what the last three parameters are.
                        I am specifically wondering if the PushScript can send a message that has an attachment? Is one of the parameters for specifying the filename of the attachment?

                        Comment


                        • Originally posted by teladog01 View Post

                          I am specifically wondering if the PushScript can send a message that has an attachment? Is one of the parameters for specifying the filename of the attachment?
                          It can send a small image file, but no other attachments.
                          HS 3.0.0.532: 1963 Devices 1141 Events
                          Z-Wave 3.0.1.261: 122 Nodes on one Z-Net

                          Comment


                          • Try leaving the quotes off "device_name".
                            Don

                            Comment


                            • Originally posted by teladog01 View Post

                              I am specifically wondering if the PushScript can send a message that has an attachment? Is one of the parameters for specifying the filename of the attachment?
                              So I figured out through trial and error that there are now nine parameters for the pushover object when using PushScript, with the last one being the full path filename to the image attachment.

                              Still would like to see the official documentation though...

                              Comment


                              • Can anybody post documentation for the script? Would really be helpful.

                                Also how can I send a message to two groups?

                                Code:
                                Dim pushoverParams(8) As Object
                                pushoverParams(0) = "Group 1, Group 2" 'Device/Group - must matched with a device name already in the plugin or 'All Clients' CASE SENSITIVE
                                pushoverParams(1) = "Message..." 'Message Body
                                pushoverParams(2) = "Title..." 'Message Title
                                pushoverParams(3) = "normal" 'low/normal/high/emergency
                                pushoverParams(4) = Nothing 'Message Sound - must match from list already in HomeSeer
                                pushoverParams(5) = Nothing 'Message URL
                                pushoverParams(6) = Nothing 'Message URL Title
                                pushoverParams(7) = Nothing 'API String
                                pushoverParams(8) = Nothing 'Attachment
                                
                                hs.PluginFunction("Pushover 3P", "", "Pushscript", pushoverParams)

                                Comment

                                Working...
                                X