Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Pricey1985 View Post
    Thanks, I have just experimented several times while watching the Log.


    - I ran the event to send the message and instantly got a Log saying the event has run.
    - 55 Seconds later i got 'Pushover Notification Sent' in the Log
    - 1 Second later The Notification came through.
    Well thats me eating my words already, do you have anything unusual in your network setup on your HS PC - multiple gateways, VPN connections etc? I will put together a short test script to test if thats OK which will determine whether or not the issue is in the plugin or could be elsewhere.
    My Plugins:

    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
    Yeelight 3P | Nanoleaf 3P

    Comment


    • Originally posted by mrhappy View Post

      Well thats me eating my words already, do you have anything unusual in your network setup on your HS PC - multiple gateways, VPN connections etc? I will put together a short test script to test if thats OK which will determine whether or not the issue is in the plugin or could be elsewhere.
      No VPN, however i have 2 modems.
      One is setup as an access point for all wireless connections.
      HS pc is using this wireless access point.

      Comment


      • Trying to access the documentation referenced on the store page to set this plugin up. The link is http://seriousface.ddns.net/plugins/...#Pushover%203P but that seems to be currently down?

        Comment


        • Originally posted by Pricey1985 View Post

          No VPN, however i have 2 modems.
          One is setup as an access point for all wireless connections.
          HS pc is using this wireless access point.
          My fault my IP was incorrect on my Dynamic DNS - should be back up now.
          My Plugins:

          Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
          Yeelight 3P | Nanoleaf 3P

          Comment


          • Originally posted by Pricey1985 View Post

            No VPN, however i have 2 modems.
            One is setup as an access point for all wireless connections.
            HS pc is using this wireless access point.
            OK can you go into command prompt and pick api.pushover.net and see what sort of times you are getting?
            My Plugins:

            Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
            Yeelight 3P | Nanoleaf 3P

            Comment


            • Originally posted by mrhappy View Post

              OK can you go into command prompt and pick api.pushover.net and see what sort of times you are getting?
              Sorry you have lost me on that one. Windows command prompt?
              I googled how to send via cURL Windows command prompt and my head started to hurt.

              Comment


              • I think he want you to send a ping to api.pushover.net in the cmd.exe


                i think the command in windows is :

                ping api.pushover.net

                Comment


                • Originally posted by MattL0 View Post
                  I think he want you to send a ping to api.pushover.net in the cmd.exe

                  i think the command in windows is :
                  ping api.pushover.net
                  Thanks MattL0


                  Attached Files

                  Comment


                  • Originally posted by Pricey1985 View Post

                    Thanks MattL0

                    Sorry it was my auto correct that corrected ping to pick, your results are a little slower than I would expect (I get a ping of 88ms, I'm on a fairly average ADSL line) but it should not introduce a delay of that long. I will drop you a PM if that is OK to run through a few things.
                    My Plugins:

                    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                    Yeelight 3P | Nanoleaf 3P

                    Comment


                    • Is there a way to automatically reset the Pushover message count at the beginning of the month?



                      Edit:
                      OK, this is weird, it did reset. I guess I never saw it on the first of the month last month.

                      Comment


                      • Originally posted by Dan-O View Post
                        Is there a way to automatically reset the Pushover message count at the beginning of the month?



                        Edit:
                        OK, this is weird, it did reset. I guess I never saw it on the first of the month last month.
                        I set this device with data from the HTTP header replies from Pushover when you send a message, some more detail is on their API page;

                        Once message limits have been reached, requests will be rejected with a 429 HTTP status code. Message limits are reset at00:00:00 Central Time on the 1st of each month. Per-day and per-month usage statistics can be viewed on each application's page, as well as through HTTP headers returned in each API call to the messages endpoint showing your app's monthly message limit (plus any additional purchased capacity), the number of messages sent this month, and the Unix timestamp of when the count will reset.
                        X-Limit-App-Limit: 7500
                        X-Limit-App-Remaining: 7496
                        X-Limit-App-Reset: 1393653600
                        My Plugins:

                        Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                        Yeelight 3P | Nanoleaf 3P

                        Comment

                        Working...
                        X