Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OK - my faulty memory then - thanks guys.

    Comment


    • HS3 running on a Pi Linux Version (Standard Lic)

      Plug in looks like it starts fine.. Enabled but when I click configuration in plugins for Pushover3p >>> Error?

      here is what it looks like on terminal side
      07:11:02:4399:[Starting Plug-In]->Pushover 3P loaded in 15076 milliseconds
      07:11:02:4635:[Plug-In]->Finished initializing plug-in Pushover 3P
      07:11:03:8551:[Info]->Plugin Pushover 3P has connected. IP:127.0.0.1:37174
      07:11:03:8852:[Starting Plug-In]->Initializing plugin Pushover 3P ...
      Connected, waiting to be initialized...
      [2019-10-25 7:11:04 AM] Plugin Starting - Checking if HS4/HS3...
      07:11:04:2955:[Pushover 3P]->Plugin Starting - Checking if HS4/HS3...
      [2019-10-25 7:11:04 AM] HS3 Detected, Continue...
      07:11:04:4201:[Pushover 3P]->HS3 Detected, Continue...
      [2019-10-25 7:11:04 AM] ****** InitIO Ended ******
      07:11:04:7881:[Starting Plug-In]->Plugin Pushover 3P started successfully in 902 milliseconds
      [2019-10-25 7:11:05 AM] BackGround Thread Started
      07:11:05:2997:[Pushover 3P]->CreateTable Entered
      [2019-10-25 7:11:05 AM] AddToTable : Plugin Started Row Count: 0
      [2019-10-25 7:11:10 AM] RegisterWebPage Called: PushConfig - Configuration - Pushover 3P Configuration
      07:11:10:5650:[Pushover 3P]->RegisterWebPage Called: PushConfig - Configuration - Pushover 3P Configuration
      [2019-10-25 7:11:10 AM] User Key: N/K
      [2019-10-25 7:11:10 AM] Emergency Expiry: 0
      [2019-10-25 7:11:10 AM] Emergency Interval: 0
      [2019-10-25 7:11:10 AM] No User Key Specified, please enter in config page
      07:11:10:9460:[Pushover 3P]->No User Key Specified, please enter in config page
      [2019-10-25 7:11:19 AM] Found Plugin Devices, Exit
      [2019-10-25 7:11:20 AM] End Of Enumerator - Create Devices False
      [2019-10-25 7:11:29 AM] Devices Owned By Plugin 83 Name: Pushover 3P Root Device
      [2019-10-25 7:11:29 AM] Devices Owned By Plugin 84 Name: Pushover 3P Enabled/Disabled
      [2019-10-25 7:11:29 AM] Devices Owned By Plugin 85 Name: Pushover 3P Last Message Sent
      [2019-10-25 7:11:29 AM] Devices Owned By Plugin 86 Name: Pushover 3P Disable Non-Emergency Messages
      [2019-10-25 7:11:30 AM] Devices Owned By Plugin 87 Name: Pushover 3P Application Messages Remaining
      [2019-10-25 7:11:30 AM] Array bCode(0) - 83
      [2019-10-25 7:11:30 AM] Array bCode(1) - 84
      [2019-10-25 7:11:30 AM] Array bCode(2) - 85
      [2019-10-25 7:11:30 AM] Array bCode(3) - 86
      [2019-10-25 7:11:30 AM] Array bCode(4) - 87
      [2019-10-25 7:11:30 AM] Sending Status True Device Value: 100
      07:11:30:7185:[Pushover 3P]->Sending Status True Device Value: 100
      [2019-10-25 7:11:30 AM] Starting Flood Control Timer
      07:11:30:9011:[Pushover 3P]->Starting Flood Control Timer
      [2019-10-25 7:11:31 AM] Glance Message Delay Value 20
      07:11:31:1104:[Pushover 3P]->Glance Message Delay Value 20
      [2019-10-25 7:11:31 AM] Worker Thread Completed
      [2019-10-25 7:12:45 AM] GetPagePlugin Called


      any ideas
      Attached Files

      Comment


      • Originally posted by Ravell View Post
        HS3 running on a Pi Linux Version (Standard Lic)

        Plug in looks like it starts fine.. Enabled but when I click configuration in plugins for Pushover3p >>> Error?

        here is what it looks like on terminal side
        07:11:02:4399:[Starting Plug-In]->Pushover 3P loaded in 15076 milliseconds
        07:11:02:4635:[Plug-In]->Finished initializing plug-in Pushover 3P
        07:11:03:8551:[Info]->Plugin Pushover 3P has connected. IP:127.0.0.1:37174
        07:11:03:8852:[Starting Plug-In]->Initializing plugin Pushover 3P ...
        Connected, waiting to be initialized...
        [2019-10-25 7:11:04 AM] Plugin Starting - Checking if HS4/HS3...
        07:11:04:2955:[Pushover 3P]->Plugin Starting - Checking if HS4/HS3...
        [2019-10-25 7:11:04 AM] HS3 Detected, Continue...
        07:11:04:4201:[Pushover 3P]->HS3 Detected, Continue...
        [2019-10-25 7:11:04 AM] ****** InitIO Ended ******
        07:11:04:7881:[Starting Plug-In]->Plugin Pushover 3P started successfully in 902 milliseconds
        [2019-10-25 7:11:05 AM] BackGround Thread Started
        07:11:05:2997:[Pushover 3P]->CreateTable Entered
        [2019-10-25 7:11:05 AM] AddToTable : Plugin Started Row Count: 0
        [2019-10-25 7:11:10 AM] RegisterWebPage Called: PushConfig - Configuration - Pushover 3P Configuration
        07:11:10:5650:[Pushover 3P]->RegisterWebPage Called: PushConfig - Configuration - Pushover 3P Configuration
        [2019-10-25 7:11:10 AM] User Key: N/K
        [2019-10-25 7:11:10 AM] Emergency Expiry: 0
        [2019-10-25 7:11:10 AM] Emergency Interval: 0
        [2019-10-25 7:11:10 AM] No User Key Specified, please enter in config page
        07:11:10:9460:[Pushover 3P]->No User Key Specified, please enter in config page
        [2019-10-25 7:11:19 AM] Found Plugin Devices, Exit
        [2019-10-25 7:11:20 AM] End Of Enumerator - Create Devices False
        [2019-10-25 7:11:29 AM] Devices Owned By Plugin 83 Name: Pushover 3P Root Device
        [2019-10-25 7:11:29 AM] Devices Owned By Plugin 84 Name: Pushover 3P Enabled/Disabled
        [2019-10-25 7:11:29 AM] Devices Owned By Plugin 85 Name: Pushover 3P Last Message Sent
        [2019-10-25 7:11:29 AM] Devices Owned By Plugin 86 Name: Pushover 3P Disable Non-Emergency Messages
        [2019-10-25 7:11:30 AM] Devices Owned By Plugin 87 Name: Pushover 3P Application Messages Remaining
        [2019-10-25 7:11:30 AM] Array bCode(0) - 83
        [2019-10-25 7:11:30 AM] Array bCode(1) - 84
        [2019-10-25 7:11:30 AM] Array bCode(2) - 85
        [2019-10-25 7:11:30 AM] Array bCode(3) - 86
        [2019-10-25 7:11:30 AM] Array bCode(4) - 87
        [2019-10-25 7:11:30 AM] Sending Status True Device Value: 100
        07:11:30:7185:[Pushover 3P]->Sending Status True Device Value: 100
        [2019-10-25 7:11:30 AM] Starting Flood Control Timer
        07:11:30:9011:[Pushover 3P]->Starting Flood Control Timer
        [2019-10-25 7:11:31 AM] Glance Message Delay Value 20
        07:11:31:1104:[Pushover 3P]->Glance Message Delay Value 20
        [2019-10-25 7:11:31 AM] Worker Thread Completed
        [2019-10-25 7:12:45 AM] GetPagePlugin Called


        any ideas
        Have you tried directly by the IP address rather than by MyHS? It might behave the same but this error is particularly vague and unhelpful so I don't really know where to start. Did you build the Pi and install the packages yourself or have you purchased it from HS? Do other plugin config pages work OK?
        My Plugins:

        Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
        Yeelight 3P | Nanoleaf 3P

        Comment


        • Just a heads-up for Pushover users. I noticed a delay in notifications for the past couple of days, just some erratic behavior in general, and I had to re-register a couple of devices due to DDoS attacks on their server. Explained here for those interested: https://blog.pushover.net/posts/2019...25-ddos-attack

          Comment


          • Originally posted by mrhappy View Post

            Have you tried directly by the IP address rather than by MyHS? It might behave the same but this error is particularly vague and unhelpful so I don't really know where to start. Did you build the Pi and install the packages yourself or have you purchased it from HS? Do other plugin config pages work OK?
            yes I never use myhs.. always direct shell or a local pc. I did not have really have a need for push notifs. so can go on without it. ill reach back out when i do get around to reinstalling it. I have a twillio account so may possibly down the roads use that for sms notif. Thanks mrHappy enjoy the weekend. PS yea it a pi i built and installed raspbian then HS3

            Comment


            • Originally posted by Ravell View Post

              yes I never use myhs.. always direct shell or a local pc. I did not have really have a need for push notifs. so can go on without it. ill reach back out when i do get around to reinstalling it. I have a twillio account so may possibly down the roads use that for sms notif. Thanks mrHappy enjoy the weekend. PS yea it a pi i built and installed raspbian then HS3
              OK you might be missing one of the Mono libraries for web pages if you have issues on more than my plugin and you have self built...the reason I asked re MyHS is that it does appear you are using it to access the page because in that screenshot it is accessing connected2.homeseer.com which is one of the MyHS URL's. It shouldn't cause an issue but don't know of much else that will cause a problem.

              My Plugins:

              Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
              Yeelight 3P | Nanoleaf 3P

              Comment


              • Ahh right, yea I was trying everything I don’t even remember taking that screen capture but more than likely trying it from my office .. however local or remotely same error.. hmm wonder What library I could be missing.. I’ll try a fresh install shortly (over next few days) and report back in, I like that I can pop in a new micro sd card and start over if no progress pop the old one back in

                Comment


                • Originally posted by mrhappy View Post

                  Strange one - but you can try and add it manually. Try the following;

                  1) Stop the plugin
                  2) Open your HS3PushoverConf.ini file which is in your \Config directory
                  3) If you don't have an [APITokens] section then add this to the bottom of the file
                  4) Then enter a key like this appname=appkey and save the file
                  5) Restart the plugin, see if the application name is now in the event actions

                  It should look something like this;

                  Code:
                  [Settings]
                  UsrKey=KWnsGKueetY17to66uAypaJn6xxxxx
                  eInterval=60
                  eExpiry=200
                  WantDevices=False
                  FloodNumber=50
                  [Clients]
                  iPad=removed
                  nexus7=removed
                  iPhone=removed
                  redminote4=removed
                  cttiphone=removed
                  honor9lite=Nothing
                  [APITokens]
                  HomeSeer=cJvZXLNqBGifwKv2AcqfR5namxxxxx
                  default=cJvZXLNqBGifwKv2AcqfR5namxxxxx
                  Just wanted to chime in that I was trying to set up the plugin from scratch today and ran into the same issue adding my application. Editing the INI file manually worked.

                  Great plugin so far!!

                  Comment


                  • I have a search but came up with nothing so apologise if this is somewhere in this 78 page thread..... wondering what happens if the internet is down, does this plug-in retry until it succeeds or is there a simple way to achieve this via Homeseer?

                    Great plugin and thank you!

                    Comment


                    • Originally posted by jdee View Post
                      I have a search but came up with nothing so apologise if this is somewhere in this 78 page thread..... wondering what happens if the internet is down, does this plug-in retry until it succeeds or is there a simple way to achieve this via Homeseer?!
                      In my experience, the message simply fails to send. It would be nice if the plugin could keep a queue of messages that fail and then send them once the internet connection is back up.

                      Comment


                      • You could use this plugin via a script, and if the send fails, continue to try until it succeeds. That will only work for you if the plugin function returns failure information, which I am not sure about as I have not tried.

                        Comment


                        • Originally posted by jdee View Post
                          I have a search but came up with nothing so apologise if this is somewhere in this 78 page thread..... wondering what happens if the internet is down, does this plug-in retry until it succeeds or is there a simple way to achieve this via Homeseer?

                          Great plugin and thank you!
                          It's a fair point to raise and one I had not really thought about since the plugin was made all those years ago as I probably had the naive belief that most people would have a connection that is relatively stable or have some sort of backup. At the minute all that will happen is that the message will not go and you will get an error in the log, it will not try to send it again.

                          I will see if I can put in a timer or queue if I get a web timeout exception and add the message to a list for periodic retrying.

                          My Plugins:

                          Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                          Yeelight 3P | Nanoleaf 3P

                          Comment


                          • Originally posted by mrhappy View Post

                            It's a fair point to raise and one I had not really thought about since the plugin was made all those years ago as I probably had the naive belief that most people would have a connection that is relatively stable or have some sort of backup. At the minute all that will happen is that the message will not go and you will get an error in the log, it will not try to send it again.

                            I will see if I can put in a timer or queue if I get a web timeout exception and add the message to a list for periodic retrying.
                            Completely agree, internet is typically stable other than power outages, but in my case on the odd (very odd) occasion I have a glitch where things like weather or QNAP reports not being able to connect.

                            Only recently started with Homeseer and looking at its potential to be a mini intruder system, notifying me when sensors are triggered, and came across this plugin. My Homeseer is on a UPS but modem/router isn't (will add one down the track) hence was just a thought to ensure best possible receiving a notification.

                            Comment

                            Working...
                            X