Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by hankli View Post
    I'm having trouble attaching an image file. The Plugin keeps reporting the file does not exist inside HS log. Attached is a screenshot of the event I created. Anyone has any suggestions as to what I'm doing wrong? I've already verified that the file does exist by pasting the file path directly onto the command line and using "dir" command in a cmd window.

    The quotes in the path are likely to be causing an issue - have you tried the path without the quotes - does that work? If not I might need to add some functionality to cope with spaces in filenames.

    Comment


    • Originally posted by hankli View Post
      I'm having trouble attaching an image file. The Plugin keeps reporting the file does not exist inside HS log. Attached is a screenshot of the event I created. Anyone has any suggestions as to what I'm doing wrong? I've already verified that the file does exist by pasting the file path directly onto the command line and using "dir" command in a cmd window.
      I have a similar event and just have the path set as below, no quotes at all:

      C:\Program Files (x86)\HomeSeer HS3\html\netcam\CurrentImage.jpg

      Click image for larger version

Name:	Capture.PNG
Views:	88
Size:	3.9 KB
ID:	1388002
      Attached Files

      Comment


      • Why are there quotes around the Program Files and HS Homeseer directories?

        Comment


        • Thanks kazibole and pcgirl. It works without the quotes. I thought that the file path required DOS convention which apparently are not required. LoL

          Comment


          • I'm trying to send a message to two devices in a script. This works fine:

            hs.PluginFunction("Pushover 3P", "", "Pushscript", New Object() {"myphone1", Message, "Melding fra HS", "Normal", "pushover", Nothing, Nothing, Nothing, Nothing})

            However, when adding a second device, separating the two devices with a pipe as described in the documentation, the message is never recieved on either device:

            hs.PluginFunction("Pushover 3P", "", "Pushscript", New Object() {"myphone1 | myphone2", Message, "Melding fra HS", "Normal", "pushover", Nothing, Nothing, Nothing, Nothing})

            I guess there's a syntax error here, but I can't find it...

            Comment


            • Just a wild guess... maybe the spaces surrounding the | ?
              stefxx

              Comment


              • Yep I would check if the spaces are the issue, if not let me know and I will do some checking in the code.

                Comment

                Working...
                X