Announcement

Collapse
No announcement yet.

HS3 Pushover Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by teladog01 View Post
    Well check this out...

    Click image for larger version Name:	Screen Shot 2021-09-08 at 11.58.49 PM.png Views:	0 Size:	14.5 KB ID:	1494529

    Not only does Pushover have the "Delivery Groups" feature I didn't know about, the plugin actually already supports it. And it works! How 'bout dat


    Sorry for all the commotion here, folks. Carry on...
    Dang! I just realized you found the answer on your own. I was so excited I actually had something to contribute to the forum for a change, I missed that.

    ;-)

    Comment


      Originally posted by ScottAtlanta View Post

      Dang! I just realized you found the answer on your own. I was so excited I actually had something to contribute to the forum for a change, I missed that.

      ;-)
      Haha ๐Ÿ˜„ you're right, I did figure it out finally. I feel like a dunce for not know about the Delivery Groups feature. But hey, I never had a need for it before so just never looked for it.

      Anyway, thanks for taking time and posting the instructions. And the extra tidbit about the All Devices option on existing events is good to know ๐Ÿ‘

      Comment


        Everyone -
        Has anyone seen/posted instructions on how to configure Pushover to work with HS4? I'm not sure if that's been released since the latest entries in this thread (Sep 2020)...?
        Any help would be appreciated -

        Comment


          Originally posted by brian@bunkey.org View Post
          Everyone -
          Has anyone seen/posted instructions on how to configure Pushover to work with HS4? I'm not sure if that's been released since the latest entries in this thread (Sep 2020)...?
          Any help would be appreciated -
          I don't think there is any difference. The first post in this thread contains the documentation.
          RJ_Make On YouTube

          Comment


            That's exactly what I needed. Thanks very much. This whole Pushover is awesome!

            Comment


              I know that Pushover isn't really supported in HS4, but I am wondering if anyone else here has run into this same problem and was able to fix it.
              (I am running HS4 version 4.2.5.0, and Pushover 0.52)
              I have been successfully using Pushover in HS3 for a couple of years. I just recently moved everything to a new HomeTrollerPlus box. (Did not go so well). I am rebuilding the majority of my events.
              I now have Pushover sending a notification, but only the first one works. I will not get any more. There is an error that shows up in the event code (sometime after it runs) that indicates "Error calling the plug-in to get the Action UI: Object reference not set to an instance of an object."
              When I try to run an event that sends a Pushover notification again, nothing shows up in either the HS4 log, or the Pushover log.
              Any ideas? Thanks


              Comment


                I've got HS4 version 4.2.0.0 running and installed Pushover 3P version 0.52. I'm not able to send anything. I get the following noted in the HS log.

                "Pushover Reply Exception: Value cannot be null. Parameter name: s"
                "Other Exception: Object reference not set to an instance of an object"

                "Pushover Plugin WebException Error: The operation has timed out. "

                Any ideas as to what I can do to fix this is greatly appreciated.

                Comment


                  I finally updated from 0.0.0.38 to .52 (after struggling with .42 a couple of years ago) and now sending from script doesnโ€™t work any more.

                  No errors in the log, regular event pushover messages are working as before.

                  This is the script:
                  Dim pushArr(8) As Object
                  pushArr(0) = identifierHim
                  pushArr(1) = message
                  pushArr(2) = "HomeSeer"
                  pushArr(3) = pri
                  pushArr(4) = Nothing
                  pushArr(5) = Nothing
                  pushArr(6) = Nothing
                  pushArr(7) = Nothing
                  pushArr(8) = Nothing
                  hs.PluginFunction("Pushover 3P", "", "Pushscript", pushArr)
                  hs.WriteLog("Info", "Sending Pushover-notify to him (" & message & " / pri: "& pri & ")")

                  (identifierHim, message and pri are strings set higher up in the script)

                  Any ideas or do I need to downgrade again?

                  Running on Ubuntu 32-bit, if it matters.

                  Comment


                    In post #1272 is a patch, to version 0.0.0.54.



                    Comment


                      How do you install the patch version 0.0.0.54?

                      I have the following system:
                      Version: HS4 Standard Edition 4.2.5.0 (Linux)
                      MONO Version: Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:14:25 UTC 2019)

                      Thank you

                      Comment


                        I noticed that the Pushover messaging platform upgraded back in April 2021 and can allow custom mp3 message on the Iphone. Can this be done in HS? If not, does anyone know if the Pushover Plugin will be upgraded for this feature?

                        Thanks,

                        Ronnie

                        Comment


                          Originally posted by zwolfpack View Post
                          In post #1272 is a patch, to version 0.0.0.54.
                          That seems to have solved it - thanks!

                          Comment


                            Can someone please tell me how to install version .54. I have the .zip file. If someone can point me to the steps to install that would be wonderful.

                            I have the following system:
                            Version: HS4 Standard Edition 4.2.5.0 (Linux)
                            MONO Version: Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:14:25 UTC 2019)

                            Comment


                              Assuming you have the plugin already installed...you would shutdown Homeseer, unzip the file and place HSPI_PUSHOVER.exe in Homeseer's root directory, replacing the existing file. Then restart Homeseer.
                              Jon

                              Comment


                                Hi Jon
                                Thanks for this info. I do have the version .52 plug-in installed however I get the errors noted in my first post so want to move to .54.
                                When I ssh I don't see the HSPI_PUSHOVER.exe in the first directory nor when I cd to the HomeSeer directory so I'm not sure where to copy that file.
                                Thanks again for your help.

                                Comment

                                Working...
                                X