Announcement

Collapse
No announcement yet.

Running HS3 as a service?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running HS3 as a service?

    Has anyone succeeded in running HS3 as a service?

    I've tried but the startup log reports "~!~Error~!~ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified" three times and the service startup fails.

    I tried putting HomeSeerUtil.dll in the system32 directory; adding the homeseer directory to the OS path; using the admin account vs. the local system; all to no effect.

    I haven't tried specifiying any dependencies simply because I don't know what they would be.

    Thanks, all.

  • #2
    You don't need to, although I would also like native service support. You can use the system startup tasks to launch HS without needing to log into the machine. This results in behavior similar to running it as a service. Do a search on the forum and you can find some threads with step by step instructions.

    Comment


    • #3
      Task scheduler run at startup? Seems like a good workaround - thanks.

      Comment


      • #4
        HomeSeer HS3 3.0.0.208 licensed
        Windows 10 Pro Version 1511

        I have been running HS3 as a service (local system account) using nssm. UAC is at the default level and I log in and out of the server via RDP.

        HS3 runs just fine (z-wave, hstouch etc.) however I get the following error in the log 3 times at start up (which does not appear to affect anything).

        ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

        Any ideas what this error is?

        Thanks for you help

        Comment


        • #5
          Try moving your installation to a folder on the root of the C: drive.
          C:\Homeseer

          I had similar permission issues running as a service (AlwaysUp), until I did this.

          Comment


          • #6
            How to launch HS3 on your PC without logging in:

            http://board.homeseer.com/showthread.php?t=184724

            Comment


            • #7
              Same problem

              I've followed all the directions in the video and I am seeing the same errors in my log as mentioned above. I am also using Thrag's HA Bridge and when I launch HS3 via the task scheduler, I cannot use the HA Bridge, I get an asp.net error "Object not set to reference" which seems likely to be related. Any suggestions? I don't really want to move my HS3 install to the root if I don't have to.

              Thanks!

              Comment


              • #8
                I run HS3 and HA Bridge - both load as a service using NSSM.
                I'm running on Server 2012R2.
                HS is in its default directory, Program Files (x86)
                No errors here.

                Comment


                • #9
                  I have now tried out NSSM and no aspx pages load. On startup I get these errors:
                  Nov-23 5:17:58 PM
                  *
                  Error
                  ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
                  Nov-23 5:17:58 PM
                  *
                  Error
                  ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
                  Nov-23 5:17:58 PM
                  *
                  Error
                  ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
                  If I go to the test.aspx page, I get these errors:
                  Nov-23 5:21:59 PM
                  *
                  Error
                  Processing ASP.NET page: Object reference not set to an instance of an object.
                  Nov-23 5:21:49 PM
                  *
                  Error
                  Processing ASP.NET page: Object reference not set to an instance of an object.
                  Nov-23 5:21:49 PM
                  *
                  Startup
                  ASP.NET application host created
                  Nov-23 5:21:49 PM
                  *
                  Error
                  ASP.Net page: Could not load file or assembly 'HomeSeerUtil, Version=3.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
                  Nov-23 5:21:49 PM
                  *
                  Startup
                  Creating ASP.NET application host...
                  Logs are in reverse chronological order (latest on top). Anyone have any suggestions? I'm on Windows 10.

                  Comment


                  • #10
                    I've figured out a workaround for the problem that I was having with the aspx files. I'm still not certain why this fixed the problem, but I installed Visual Studio 2015 on the machine that is running HomeSeer so I could debug the problem with the page. After rebooting the machine, the aspx pages work fine after starting HomeSeer with nssm.

                    Comment

                    Working...
                    X