Announcement

Collapse
No announcement yet.

"Max number of queued events exceeded" - Solution!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Max number of queued events exceeded" - Solution!

    Team,

    Every now and then my log file is flooded with these messages:

    jan-31 8:58:28 Warning
    Max number of queued events exceeded, event SYSTEM Jon00 Network not processed
    Max number of queued events exceeded, event FTP Send CHARTS not processed
    Max number of queued events exceeded, event Camera CAM Front-door not processed

    this appears in the log every second

    - HS 3.0.0.208
    - The events:
    >> Jon00 Network - Every 5 minutes, no other options
    Run the script: Jon00RCCNMHS3_A.vben
    >> FTP send charts - Every 1 hour, no other options
    1.Run Jon00 DB Chart manual update
    2.Wait 8 seconds
    3.Run immediate script: FTP file
    (steps 1-3 repeating 4 times)
    >> Camera CAM Front-door - Every 15 minutes, no other options
    Run script xx, wait for script to finish before continuing
    Wait 8 seconds
    Run immediate script: FTP file

    - I don't see something that these events have in common..

    Any idea what's causing this message? Does it have anything to do with these specific events?

  • #2
    It is something to do with the network commands, I'm seeing the same every now and again and I don't know why it gets into this state and needs a restart to sort it out. I only started seeing the errors after I created a script that pulls data from the internet using hs.GetURL, I'm just having to keep an eye on it.
    My Plugins:

    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
    Yeelight 3P | Nanoleaf 3P

    Comment


    • #3
      I'm also having this same problem. I thought it was due to that I migrated HS3 v208 from Win 7 32 bit box to a new 64 bit (Win7) box yesterday. This problem started today and main change I have done today is that I have installed Jon00's RCCNM package. I don't, however, know whether these messages are due to this new package or not.
      Last edited by jlikonen; January 31st, 2016, 10:51 PM.

      Comment


      • #4
        I have seen this error with Homeseer 2 but not Homeseer 3 and logs indicated issue only with one event 2 RFID plugins versus multiple different types of events or plugins.

        IE: I have an event which checks 3 RFID receivers and creates a virtual RFID on and off variable.

        Personally here it related to RFID stuff events only and it would shut down the HS event engine after a time rendering HS dysfunctional over time.

        I would also have to force a shut down of Homeseer and reboot machine to get it going again.

        Thinking it might be some sort of circular reference that I am causing creating a blind loop. (maybe I am not seeing the nested loop?)

        I did a quickie search here on my HS2 logs using Ultralog.

        9/26/2015 10:05:23 AM Warning Max number of queued events exceeded, event car2-Home-ON not processed
        9/26/2015 10:05:27 AM Warning Max number of queued events exceeded, event car1-Home-ON not processed
        9/26/2015 10:05:27 AM Warning Max number of queued events exceeded, event car2-Home-ON not processed
        9/26/2015 10:05:27 AM Warning Max number of queued events exceeded, event car1-Home-ON not processed
        9/26/2015 10:05:27 AM Warning Max number of queued events exceeded, event car2-Home-ON not processed
        9/26/2015 10:05:31 AM Warning Max number of queued events exceeded, event car1-Home-ON not processed
        Last edited by Pete; January 31st, 2016, 03:24 PM.
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

        Comment


        • #5
          I disabled Jon00's network control events about 4 hours ago and I haven't got these warning messages any more. I'll do more testing tomorrow.

          I never had this problem under HS2.

          Comment


          • #6
            Don't know if it's related but I have jons network and blue tooth plugins to set my house to home mode. I've noticed it's been triggering twice in a row ignoring the cannot run again for 10 minutes setting in the homeseer event. Tonight it triggered 3 times in row.

            an-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
            Jan-31 6:03:14 PM Monoprice AmpInfo Virtual Public_Announcement Set To: _On
            Jan-31 6:03:14 PM Device Control Device: 1st Floor Main Lock to Unlock (0)
            Jan-31 6:03:14 PM Device Control Device: Virtual Virtual Home to Home (100)
            Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
            Jan-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
            Jan-31 6:03:14 PM Device Control Device: 1st Floor Main Lock to Unlock (0)
            Jan-31 6:03:14 PM Device Control Device: Virtual Virtual Home to Home (100)
            Jan-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
            Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
            Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
            Last edited by happnatious1; January 31st, 2016, 09:50 PM.
            If it ain't broke, don't fix it!

            Comment


            • #7
              Originally posted by happnatious1 View Post
              Don't know if it's related but I have jons network and blue tooth plugins to set my house to home mode. I've noticed it's been triggering twice in a row ignoring the cannot run again for 10 minutes setting in the homeseer event. Tonight it triggered 3 times in row.

              an-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
              Jan-31 6:03:14 PM Monoprice AmpInfo Virtual Public_Announcement Set To: _On
              Jan-31 6:03:14 PM Device Control Device: 1st Floor Main Lock to Unlock (0)
              Jan-31 6:03:14 PM Device Control Device: Virtual Virtual Home to Home (100)
              Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
              Jan-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
              Jan-31 6:03:14 PM Device Control Device: 1st Floor Main Lock to Unlock (0)
              Jan-31 6:03:14 PM Device Control Device: Virtual Virtual Home to Home (100)
              Jan-31 6:03:14 PM Event Event Trigger "Manually Triggered Bills phone detected"
              Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
              Jan-31 6:03:14 PM Event Event Trigger "Automatic Bills Phone Detected via BT"
              You need to post this in Jon00's forum so he knows about this.
              -Rupp
              sigpic

              Comment


              • #8
                This bug has been going back for years:

                http://bugzilla.homeseer.com/bugzill...ug.cgi?id=1710

                See also:

                http://board.homeseer.com/showthread.php?t=171054
                Jon

                Comment


                • #9
                  Jon,

                  Many thanks for this tip. I'll have to try your application later today. I have now been running the network monitoring for 6 hours without any problems but I deleted the virtual device for checking the internet connection (to www.homeseer.com).

                  It is somewhat strange that HST hasn't fixed this bug. It is really annoying and severe as it killed my HS more or less completely because none of the scripts were working anymore and my HS log was flooded with all error messages.

                  Comment


                  • #10
                    Thanks Jon, totally forgot about this bug. The work around posted by another user at the end of the bugzilla seamed worth a try, so I disabled my jonbt detected event, changed the cannot re-run time from 10 minutes to 9 minutes and then re-enabled. then I did the same thing for the event "phone detected" that is manually triggered event that gets called. ran single test and it only triggered once. I'll have to keep testing but that would be funny if it fixed it.
                    If it ain't broke, don't fix it!

                    Comment


                    • #11
                      Originally posted by jon00 View Post
                      My HS crashed yesterday evening so the problem was back again. I setup Jon's event trigger and I have been running it overnight without any problems.

                      THIS PROBLEM IS REALLY ANNOYING AND SERIOUS SO HST PLEASE FIX IT ASAP, THANKS!!!!!

                      Comment


                      • #12
                        I have seen reports about this before, and I would LOVE to fix it, but I have not been able to re-create it. I need some help. I need someone to figure out exactly what in their system is causing this? Is it a script, if so, which one? Is it a plugin? Which one exactly.

                        I will say I worked with a user who was having a problem with hs.GetURL and I posted some code that worked around the issue. If you are using a script that uses GetURL and I can give you an alternative.
                        website | buy now | support | youtube

                        Comment


                        • #13
                          In my case the problem has occurred after several hours (at least ~6-7 hours) HS3 was last time restarted. When the problem occurs, all my recurring events/vb.net scripts fail. I don't have that much experience in this problem because I setup a new Win7 box with 64 bit OS only couple of days ago. In my previous HS box (with 32 bit Win7) I was running HS3 for a month or so and I didn't have this problem. Another "new" setup is that I started to use Jon00's remote computer control plugin in my new box so I don't know whether this problem is related to 64 bit OS or to Jon00's plugin. I don't know whether this plugin is using hs.GetURL or not. Perhaps Jon00 can comment on this.

                          Comment


                          • #14
                            No it does not use hs.GetURL.

                            Rich, I think you need to look at your recurring event code again. I wrote a very simple remote plugin that connects to HS3 and uses a system timer to run the hs.runevent command on a recurring basis. That never seem to fail. If you then run the same event on the same recurring basis using the HS3 event engine, the error posted 'can' appear.

                            From this I don't believe it has anything to do with the event action/script.

                            If you re-read the Bugzilla reports, something happens and multiple triggers occur immediately filling up the event queue. The fact that multiple triggers can occur within milliseconds of each other (and as a result also running the action multiple times) is the probable cause of the HS3 crashes.

                            Adding a 'cannot re-trigger' option on the event does not seem to prevent this happening.
                            Jon

                            Comment


                            • #15
                              Jon,

                              I don't know whether you are running 32 or 64 bit OS but I have had this problem only with 64 bit OS. My HS3 was running under 32bit OS for a month or so without this problem.

                              Comment

                              Working...
                              X