Announcement

Collapse
No announcement yet.

Starting with Raspberry

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Try rebooting, connect the Ethernet, and see an IP address gets assigned.

    Comment


      #47
      Originally posted by zwolfpack View Post
      Try rebooting, connect the Ethernet, and see an IP address gets assigned.
      I'm not lucky...

      Comment


        #48
        And UP is not shown

        Comment


          #49
          I'm sure I've seen UP.
          In what I think are the data or packages of RX and TX, numbers appeared.

          It's strange, now yes, not now.

          Comment


            #50
            Check contents of this file

            Code:
            more /etc/network/interfaces

            Comment


              #51
              Click image for larger version

Name:	thumbnail_IMG_9713.jpg
Views:	137
Size:	77.7 KB
ID:	1305993

              Comment


                #52
                OK, I've recreated your issue.

                Upon bootup, on the console appears a prompt "Enter r then press ENTER within 10 seconds to reset the network settings"

                Doing this will disable Ethernet !!!

                To fix:

                sudo rm /etc/network/interfaces

                To prevent it happening ever again

                sudo rm /var/www/Main/interfaces_default

                HomeSeer really needs to update their Linux scripting - the stuff that worked two OS releases ago doesn't necessarily work forever!!

                Comment


                  #53
                  So:
                  First
                  sudo rm / etc / network / interfaces
                  enter

                  And then
                  sudo rm / var / www / Main / interfaces_default
                  enter

                  Or directly
                  sudo rm / var / www / Main / interfaces_default

                  Comment


                    #54
                    No spaces between the "/" characters -

                    Code:
                    sudo rm /etc/network/interfaces /var/www/Main/interfaces_default
                    will remove them both at once.

                    Comment


                      #55
                      You are a crack ...
                      Now if the system appears on find.homeseer.com

                      Thank you very much for the time you have taken to help me.
                      Thanks also to the other members who also contributed.
                      I'm very happy!!

                      Comment


                        #56
                        Great!

                        Some more info, for anyone interested...

                        The file content shown in post #51 photo is from /var/www/Main/interfaces_default. This file is copied to /etc/network/interfaces when R+Enter is entered at bootup. [ The script that does this is located at /var/www/Main/checkkb, called from /etc/rc.local ]. This is not a valid interfaces file for the OS version of the HS3Pi3v5. With this in place, wireless LAN works, but wired LAN is disabled.

                        For the current OS, the /etc/network/interfaces file isn't required if a "basic" connection is all that's required. So removing the file altogether was used in this case to get things back on track.

                        Comment


                          #57
                          PS. I've reported this issue to support@homeseer.com.

                          Comment

                          Working...
                          X