No announcement yet.

HS3-Pi on a regular linux box. HS4-Pi limitations

  • Filter
  • Time
  • Show
Clear All
new posts

    HS3-Pi on a regular linux box. HS4-Pi limitations

    Any reason I can't run my HS3-Pi license on a plain old linux box? I have outgrown my Pi and don't want to have it sitting around just to host HS3 when it can be with the rest of my junk on my new machine.

    Additionally, do we know anything about the HS4-Pi restrictions yet? I don't want to miss the current sale waiting to upgrade my license if HS4-Pi is going to be nerfed too much.

    Welcome to the Homeseer forum Tim. Lots of friendly folks here.

    Any reason I can't run my HS3-Pi license on a plain old linux box?


    Here ran the first Zee HS3 software on Ubuntu Linux ARM, Intel and AMD CPU computers mostly to see how it would run.

    All you need is Mono to be running on the computer for HS3 to run.

    Homeseer is just a directory and can be installed anyplace on the computer or copied over to another computer.

    I use Homeseer Lite here to test new plugins while using Homeseer 3 Pro for day to day activities.

    Recently tested it running on an S912 ARM 8 core mini TV Box using the built in 64Gb eMMC drive. Tiny thing includes Gb, WLAN and Bluetooth for around $60
    _______ _____ ____
    |_   _\ \/ / _ \  |  _ \ _ __ ___  
      | |  \  / (_) | | |_) | '__/ _ \
      | |  /  \\__, | |  __/| | | (_) |
      |_| /_/\_\ /_/  |_|   |_|  \___/
    Welcome to Ubuntu Bionic with Armbian Linux 5.1.0-rc1-aml-s912
    System load:   0.07 0.02 0.00      Up time:       7 days        
    Memory usage:  18 % of 2840MB     IP:  
    CPU temp:      44°C              
    Usage of /:    41% of 29G        
    [ General system configuration (beta): armbian-config ]
    TX9_HS3Lite:~# uname -a
    Linux TX9_HS3Lite 5.1.0-rc1-aml-s912 #5.78 SMP PREEMPT Fri Apr 12 11:16:06 MSK 2019 aarch64 aarch64 aarch64 GNU/Linux
    TX9_HS3Lite:~# mono -V
    Mono JIT compiler version (tarball Tue Sep 24 01:27:01 UTC 2019)
    Lately been testing it on a BeeLink BT3 Pro which is an Intel Atom based CPU with 4Gb of DDR3 RAM (another TV Box purchase of around $65). The box did come with Windows 10 which I wiped for Ubuntu. Nice thing about Intel is that I can also run Oracle Virtual box and I am running a Windows 7 embedded instance on the same box.

    BTPro_HS3Lite:~# uname -a
    Linux BTPro_HS3Lite 5.0.0-29-generic #31~18.04.1-Ubuntu SMP Thu Sep 12 18:29:21 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    BTPro_HS3Lite:~# mono -V
    Mono JIT compiler version (tarball Tue Sep 24 01:21:28 UTC 2019)
    Click image for larger version  Name:	HS3-BeeLinkBT3Pro.jpg Views:	0 Size:	58.2 KB ID:	1330120

    This box also has Gb, WiFi and Bluetooth and utilizes around 10 watts of power.
    - Pete

    Auto mator
    Homeseer 3 Pro - (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
    Homeseer Zee2 (Lite) - (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
    HS4 Lite - Ubuntu 22.04 / Lenovo Tiny M900 / 32Gb Ram

    HS4 Pro - V4.1.18.1 - Ubuntu 22.04 / Lenova Tiny M900 / 32Gb Ram
    HSTouch on Intel tabletop tablets - Asus AIO

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Alexa, Cheaper RFID, W800 and Home Assistant


      Thanks for that! I went ahead and tried it in docker container using the HS3 full container in the hub as a template. Had a couple of hiccups but it works great!


        I’ve tried to run the pi version under a standard install of Ubuntu but check password doesn’t work...