Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Loggin Out of HS3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loggin Out of HS3

    Could someone please indicate how to Log Out of a HomeSeer HS3 HomeTroller Zee S2 ?

    I know this sounds weird but anywhere on my local network and from any browser, I remain logged in. I suspect this has some to do with me not understanding the rather interesting documentation & nomenclature that HS uses (sorry to say this, but face it, HS doesn't even have a WiKi given the massive amount of info, unless I just stumbled onto it like all the other oddities). Thinking it may be strange behavior like the Android app, I've created a few additional accounts (with different settings) and now have slightly different behavior given the browsers I use to test (I receive a log in dialog box now). I simply go right to the Device List page.

    On the web interface >Tools >Log Out (nice location for user activity, rather than selecting an icon on the main interface) the screen blanks/goes gray and then a message for that browser atop the screen indicates 'Logged Out, Redirecting' and then the browser returns to the page I just supposedly logged out from; or I receive a log in credentials dialog box, I hit cancel and the the Devices page loads. I've tried this after flushing/clearing the cache (Cookies, data, logins, etc) on three different workstations each with 4 different browsers -Vivaldi, Firefox, Edge & Internet Explorer (I won't use Chrome). I've even tried a new workstation on my network (a virtual machine actually)with no history on my network and can log in without any credentials, sweet.

    This can't be how HS works, is it? Maybe it is how the HomeSeer HS3 on the HomeTroller Zee S2 works, I dunno.

    Please be kind in your response. I've been far beyond patient for what I have researched & believe to be a very powerful & detailed location automation system. Though my opinion on the documentation available is that of a rather paltry offering, bear in mind I am one who likes to read about specific details rather than endless searches of user commentary from their trials n errors, although they too can be of merit. Though HS has been around for the likes of twenty years, I cannot find some of the most rudimentary details in this environment.

    Much appreciate the help & the vast arena of these forums..
    Jeff

    # As for the comment towards HS documentation & nomenclature, directly from their documentation (https://help.homeseer.com/help/HS3/static/#.network):
    [If a user is set to "Local", that user is used when accessing the system from the local network and the "No Password Required for Local Login" setting is enabled.]
    OK, so then where _is_ the setting disabled for "No Password Required for Local Login"? The wording used suggests enable & disable are available, but where?
    # Here's one from the Web Interface:
    >Plug-Ins >Manage >Installed Plug-Ins, lists Plug-Ins; however under >Additional Interfaces are additional Plug-Ins; Makes more sense to word as Additional Interfaces & Plug-Ins vs just Additional Interfaces; otherwise I wouldn't have found it before I stumbled onto it.
    # Here's one for the Android Interface:
    Selecting Back, Back from within the app; Simply hitting the 'Home' button; Multitask to another app -Any of these methods will exit the app, however you are never logged out, even after a reboot of Android. There's no option for an automatic log in, but it's there if you simply don't log out; I had to make an phone call after trying to figure out if I want to create another admin user just for my cell vs the check box for remembering my user credentials.
    Paltry documentation on Android usage for something this simple; instead you, yep, stumble onto it.

  • #2
    HomeSeer on linux is really HomeSeer that works with mono. It is still a windows product. Shutting down HS3 in Linux is tricky. I am still struggling getting HS3 to reboot cleanly as a service when I don't use built in tools. I have read the forum and used some of the techniques but still doesn't die. The web interface doesn't stop until you shutdown the program.

    As for the No Password. Go to Tools->Setup. Choose the Network tab. Under web server setting it is 7 lines down. I use HSTouch so can't help on the third point. On the second I will wait and see what happens when HS4 comes out of Beta.

    Click image for larger version  Name:	Screenshot from 2020-02-21 20-20-58.png Views:	0 Size:	131.8 KB ID:	1365045

    Hope this is of some value to you.

    Comment


    • #3
      I wrote about this problem 4 years ago in this post - https://forums.homeseer.com/forum/ho...-user-accounts

      What I found was if you click logout twice, quickly, you will be prompted to login. If you just click logout, you will get the experience you described above. Frankly, the web authentication and session management in HS3 web's interface is buggy at best. Personally I wouldn't dare expose it to the Internet.

      In the end I was able to give up the web interface for my wife (the main reason I created 2 users to simply the view) as she prefers talking to Alexa.

      Comment


      • #4
        If you expose this to the net...i guess there are other way to set a password for the interface that do not use the hs implentation?

        is that something nginx can do?

        this is something that I will do in the future. So I didn’t go in deep into subjet

        Comment


        • #5
          As for the No Password. Go to Tools->Setup. Choose the Network tab. Under web server setting it is 7 lines down.
          Well, that's definitely good to know, although IMO an obscure location; a somewhat contrary initial phone call I had, persuaded me not to look into the granular details.

          And, like:
          the web authentication and session management in HS3 web's interface is buggy at best. Personally I wouldn't dare expose it to the Internet.
          I _prefer_ to drill/read into the details before simply turning stuff on & slapping on lan with other things. Like all cameras remaining on a separate vlan due to their manufacturing location.
          Along those lines, I'm hapPy to see something baked in HS similar to NGrok vs port forwarding. Though I'm keeping isolated as I build & understand.

          Just not fond of digging for answers when proper documentation perhaps could have elucidated saving some time/frustration, or even better that elusive WiKi.

          1Noting all this & much _greatly_ appreciate the help, just not the part about getting bitten' :\

          Comment


          • #6
            ....now onto another post for something else.

            Comment

            Working...
            X