No announcement yet.

Problem with relays board.

  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by drhtmal View Post

    Perhaps you are miunderstanding me when I said

    "There are certian pins in the Raspberry Pi that you should not use in your setup."

    What I mean by this is, there are certain pins on Raspberry Pi that you should not use in your setup. The fix is very simple. Don't use pins (like pin 8) because those pins transisions from high to low when the PI boots. Use a different pin.
    Why can't I use it if it's possible to use it in the configuration? Pin 8 (GPIO 14) has the option to be used as in or out. Why doesn't the same happen with GPIO 15 ?.

    Thank you for your attention and excuse my English.


      In my project I am using all the GPIO ...


        Pin 8 (GPIO 14) is the UART transmit output (TxD). On boot this will be high, serial idle state. Additionally, in the default Raspberry Pi image, console output is sent to the UART, so TxD will toggle while the boot messages are output.

        GPIO 15 is the UART receive pin (RxD) which is an input. So that's not going to toggle.

        To disable sending console output to the UART, check the file /boot/cmdline.txt, and remove the following clause if preset:
        To disable the internal UART function, add this to /boot/config.txt *
        # disable internal UART
        * I haven't tried this, but it should work. See /boot/overlays/README


          Hello zwolfpack ...
          Thank you very much for answering !!!

          Sorry not to answer before, a lot of work the first week of August and we have also been a few days outside of Spain ...

          I have tried what you indicate, but, once I want to save the modified file, it does not allow to do so, it shows Permission Denied.

          I have seen, in file properties, that the permissions for owner are activated, but I cannot save.

          I am accessing the cmdline.txt file using WinSCP.

          Thank you very much again, you are very kind to take the time to help me !!!


            These files are system owned, so to modify them you need elevated privilege. Easiest way is to do it from the Linux command line

            sudo nano /boot/cmdline.txt
            sudo nano /boot/config.txt


              Thanks for answering !!

              This can be difficult for me ...
              I am going to try...


                Do I have to connect a monitor and keyboard ?, or can I do it from System / Linux Tools?


                  You won't be able to run nano from Linux Tools. You'll need to ssh in, or connect a monitor/keyboard.


                    I have done everything you have told me and ... it works correctly !!!!!.

                    Now when turning on RPi the relay stays off.

                    It has been very exciting for me to do this, I have learned some more things ...

                    If there is something better to know is to help and teach ...

                    1001 thanks again ...