Announcement

Collapse
No announcement yet.

***Arduino For HS3 Beta Now Available.***

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Jakob.Sand View Post
    would it be possible to set a fallback state for the digital outputs when the arduino looses connection?
    In the new beta version there is a feature called Alive Pin this is what it is for.

    Greig

    Sent from my HTC One using Tapatalk
    Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


    • Super where do I find the beta? Is it stable?

      Comment


      • Originally posted by Jakob.Sand View Post
        Super where do I find the beta? Is it stable?
        It is in the beta section of the updater.

        Greig

        Sent from my HTC One using Tapatalk
        Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


        • Hi,

          I'm using your plugin (great plugin BTW !) and I noticed something strange. I have it monitoring 3 input pins and 2 output pins.

          Whenever I decrease the debounce time of the input pins, 2 of them get a new 'last changed' datetime, but 1 doesn't. Do you have any clue why that is ?

          Comment


          • Originally posted by kriz83 View Post
            Hi,

            I'm using your plugin (great plugin BTW !) and I noticed something strange. I have it monitoring 3 input pins and 2 output pins.

            Whenever I decrease the debounce time of the input pins, 2 of them get a new 'last changed' datetime, but 1 doesn't. Do you have any clue why that is ?
            Is this the HS2 Script or the HS3 plugin? if it is the HS2 script sorry but I do not support this any longer. If it is the HS3 plugin then please post Here: http://board.homeseer.com/forumdisplay.php?f=1222.

            Thanks,

            Greig.
            Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
            Scripts =
            Various

            Comment


            • Wooops, sorry !
              HS3, will cross post the question

              Comment


              • Input errors

                Hi,

                I have problems with the input signals. They switch on and off, but also when I do not want to ....
                My longest cable (utp6) with a switch is 25 meters from the Arduino located and, I think, and the cable picks up disturbance.
                Now I want to change the input method to:
                Code:
                If (input signal == LOW)
                {
                wait for 500ms
                 if  (input signal still is LOW) 
                 {
                 send status to homeseer
                 }
                else
                {
                do nothing with this input
                }
                }
                If this is implemented in the sourcecode I prevent that a wrong (peak) signal will activate some events in homeseer and wake me up at 3am .

                I already set the debounce but this makes no difference (tried it with 5000ms in homeseer and in the arduino code, but switch is directly on in homeseer)
                I did also some hardware on the input (10nF to ground,100R to +VDD , 10uF over the input.) but no real changes.


                Must I change it here:
                Code:
                //********************************Input Setup*******************************
                byte InPinArray[30] = { 0 };
                byte Debounce = 5000;
                byte count = 0; 
                byte NoOfInPins = 0; 
                int InStateArray  [(sizeof(InPinArray) / sizeof(InPinArray[0]))];
                unsigned long PrevDebounce [(sizeof(InPinArray) / sizeof(InPinArray[0]))];
                
                void InputCheck(){
                  byte pinread;
                  for (count=0;count<NoOfInPins;count++) {
                    if(millis() - PrevDebounce[count] > Debounce){
                      pinread = (digitalRead (InPinArray[count]));
                      if (InStateArray[count] != pinread){
                        InStateArray[count] = pinread;
                        PrevDebounce[count] = millis();
                        SendByte(BoardAdd); 
                        SendChar(" I ");
                        SendByte(count+1); 
                        SendChar(" ");  
                        SendByte(pinread); 
                        Sendln();
                      }
                    }
                  }
                }
                or here:

                Code:
                 case 'I':
                      pinMode(Byte4, INPUT);
                      digitalWrite(Byte4, HIGH); 
                      if (Byte3 > NoOfInPins){
                        NoOfInPins = Byte3;
                      }
                      InPinArray[Byte3-1] = Byte4;
                      break;
                I tested i with HS3.0.0.208 and Arduino plugin 1.0.0.36 and 1.0.0.85


                Alex

                Comment


                • Hi Alex,

                  Yes it looks like there is a bug with debounce. I will see if I can get it fixed soon for you.

                  If you have any more problems Please post Here: http://board.homeseer.com/forumdisplay.php?f=1222. as this thread was used before I got a section on the board.

                  Thanks,

                  Greig.
                  Zwave = Z-Stick, 3xHSM100 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
                  X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
                  Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
                  Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
                  Scripts =
                  Various

                  Comment


                  • Originally posted by enigmatheatre View Post
                    Hi Alex,

                    Yes it looks like there is a bug with debounce. I will see if I can get it fixed soon for you.

                    If you have any more problems Please post Here: http://board.homeseer.com/forumdisplay.php?f=1222. as this thread was used before I got a section on the board.

                    Thanks,

                    Greig.
                    Hi Greig,

                    I finally solved the problem!
                    Code:
                    //******* modification for  input errors **************** 20151026 Alex Houben
                    //*********************************Input Setup*******************************
                    byte InPinArray[30] = { 0 };
                    byte Debounce = 300;
                    byte count = 0;
                    byte NoOfInPins = 0;
                    int InStateArray  [(sizeof(InPinArray) / sizeof(InPinArray[0]))];
                    unsigned long PrevDebounce [(sizeof(InPinArray) / sizeof(InPinArray[0]))];
                    
                    void InputCheck() {
                      byte pinread;
                      byte pinread2;
                    
                      for (count = 0; count < NoOfInPins; count++) {
                        if (millis() - PrevDebounce[count] > Debounce) {
                          pinread = (digitalRead (InPinArray[count]));
                    
                    
                            for (int w = 0; w < 10; w++)
                            {
                              delay (1);
                              pinread2 = (digitalRead (InPinArray[count])); //digital read is approximately  9ms
                              if (pinread != pinread2)
                              {
                                return;
                              }
                            }

                    It works now for a few day's without anyerror!


                    Alex
                    Last edited by dreambox; November 10th, 2015, 07:26 AM.

                    Comment


                    • Hello Greig,


                      I want to see the log for input buttons.When i set login for input i see no input data.The buttons are working.
                      When I set the login for all, then I see the input buttons.
                      Is this in my system fault or is this a bug!!

                      Thanks Ed.

                      Comment


                      • I just got my arduinio was going to get it setup for Vera to pull my blinds with some servo. But this sounds like a better solution.

                        Says that it can be control via ethernet, so what's preventing it from using WiFi?

                        Comment


                        • I suggest you take the API code and replace the Ethernet library with a wifi library and see if it compiles. I've found an issue with maxpacketsize statement and various encj28 libraries that's stopped me using non w5100 boards. I've ordered some wifi stuff myself to do exactly this :-)

                          Sent from my Nexus 7 using Tapatalk
                          HS 2.2.0.11

                          Comment


                          • Originally posted by petez69 View Post
                            I suggest you take the API code and replace the Ethernet library with a wifi library and see if it compiles. I've found an issue with maxpacketsize statement and various encj28 libraries that's stopped me using non w5100 boards. I've ordered some wifi stuff myself to do exactly this :-)

                            Sent from my Nexus 7 using Tapatalk
                            I had the night to think about it and thought, why not use W5100 board with POE. One less wire to run up the Windows. I think I may have a solution for myself. Also with WiFi, everytime you power cycle you have to plug in to reconnect to the WiFi. The POE approach is much cleaner and no re-engineering needed on the HomeSeer side.

                            Comment


                            • Hi all,

                              Just thought I would mention a problem that I have just resolved.
                              I have setup an Arduino to work with my HomeSeer server (Raspberry PI) and all works fine when the Arduino is plugged into the same router. When I plug my Arduino into a router that I have configured as a range extender HomeSeer cannot connect to the Arduino. I have tried different cables etc. and I have a WDmyDrive plugged in to the same router as the Arduino and it works fine.

                              The Answer is:
                              I put a default gateway in the HS config file -

                              IPAddress gateway(192, 168, 1, 1);

                              Comment

                              Working...
                              X