Announcement

Collapse
No announcement yet.

JowiHue Philips Hue control beta now available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I removed the plugin through the updater and tried it again this time the installation fails (copied updater_override to the root folder as well)

    Comment


    • I am really close.. Wim has gotten be running. Config not entirely there, and lost my CC plugin.. but advancing...
      Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

      Comment


      • Originally posted by kideon View Post
        I removed the plugin through the updater and tried it again this time the installation fails (copied updater_override to the root folder as well)
        Kideon,

        I am sure there is something in the log that tells something that went wrong?
        Is there errors in the log you are seeing?

        Also, did you try to create this directory under bin, to see if it is a rights issue?

        Regards,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • Ok I got it installed and get this in the log when I try to initialize it:

          Initializing plug-in(2): JowiHue Instance::Could not load file or assembly 'System.Data.SQLite, Version=1.0.92.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The system cannot find the file specified.0STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()

          Comment


          • I had to manually create the JOWIHUE folder but no files were placed there. What should I copy over?

            Comment


            • Originally posted by kideon View Post
              I had to manually create the JOWIHUE folder but no files were placed there. What should I copy over?
              You need to copy the DLL's from the zip file there. Two SQLLite DLL's and the newtonsoft.json.dll

              But I do wonder why it is not creating the folder as the install.txt is holding correcct info. What OS are you using? Win8?

              Regards,

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • Woo Hoo !!!! factory reset on my HUE, and restart of HS..

                I Have it All !!!!
                Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

                Comment


                • Geary,

                  Good to hear it works now, sorry you needed to disable the cc plugin
                  In a future version I will add the ability to also connect in a different way.

                  Happy playing!!

                  Regards,

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • Hi Wim,
                    This PI is great! One thing that is stopping me from moving to your plug-in fully is the sliders in HSTouch. When I slide them to 0 and the light reacts they don't turn off, but increase back to 1 and the light stays dim. They track ok in HStouch unless they are off, if they are off they show the last bri setting which makes it is difficult to know if they are actually off. I know I could add the light on/off device to HST but that means 2 devices to control the light.
                    Is it possible to have the slider show 0 when it is off?

                    Cheers
                    J

                    edit : pressing off on the hue device drops the slider to 1 also then pressing on switches it to 254 Bri and HStouch tracks this.
                    I think its because I am switching them off with Jon00's plugin and the 0 setting can't be tracked with your Bri slider?
                    Last edited by Skinnez; September 4th, 2014, 02:28 PM.

                    Comment


                    • Originally posted by Skinnez View Post
                      Hi Wim,
                      This PI is great! One thing that is stopping me from moving to your plug-in fully is the sliders in HSTouch. When I slide them to 0 and the light reacts they don't turn off, but increase back to 1 and the light stays dim. They track ok in HStouch unless they are off, if they are off they show the last bri setting which makes it is difficult to know if they are actually off. I know I could add the light on/off device to HST but that means 2 devices to control the light.
                      Is it possible to have the slider show 0 when it is off?

                      Cheers
                      J

                      edit : pressing off on the hue device drops the slider to 1 also then pressing on switches it to 254 Bri and HStouch tracks this.
                      I think its because I am switching them off with Jon00's plugin and the 0 setting can't be tracked with your Bri slider?
                      Skinnez,

                      Challenge is that this plugin is following the values reported by the bridge. And the bridge won't go lower then 1. It will only switch off with the command to switch off.

                      You can see it if you'd use the slider on the device utility page. You will see the device drop back to 0, but when the report of the bridge comes in, it will jump back to 1. Make sure the refreshrate on the configuration page is set at 2000 (it seems the last version had defaults set to 10ms, which is way to fast! so make sure to check)

                      I did not yet do further tests with hstouch.

                      Maybe a work around could be setting up an event in homeseer to swithch off the device if the Bri device becomes 0. Also with HStouch slider it will be 0 for a moment. The event should then trigger and do want you want, switch the light off? It might work....
                      Otherwise there might be no other choice then using two devices.

                      Do you use a different version of HSTouch now? My last tests were disappointing for me?

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • Originally posted by w.vuyk View Post
                        Skinnez,

                        Challenge is that this plugin is following the values reported by the bridge. And the bridge won't go lower then 1. It will only switch off with the command to switch off.

                        You can see it if you'd use the slider on the device utility page. You will see the device drop back to 0, but when the report of the bridge comes in, it will jump back to 1. Make sure the refreshrate on the configuration page is set at 2000 (it seems the last version had defaults set to 10ms, which is way to fast! so make sure to check)

                        I did not yet do further tests with hstouch.

                        Maybe a work around could be setting up an event in homeseer to swithch off the device if the Bri device becomes 0. Also with HStouch slider it will be 0 for a moment. The event should then trigger and do want you want, switch the light off? It might work....
                        Otherwise there might be no other choice then using two devices.

                        Do you use a different version of HSTouch now? My last tests were disappointing for me?

                        Wim
                        Aaaaaah ok, I have seen the off/1 problem before when I used to use VERA. I did have the refresh rate set to 10 also, so I've fixed that.
                        I've added an event and it triggers the OFF ok, although it still pops back upto 1. I might just add a toggle device on HST.
                        I think I have updated HSTouch server recently but it didn't make any difference for me either.
                        It nearly works properly, it seems sliding them to 0 works most times. I have a group slider that works - occasionally.
                        Still I think I'll move over fully this weekend
                        Cheers
                        J

                        Comment


                        • Where's the beef?

                          Been loosely following the thread for a few weeks now and would like to try out the plugin now, but I can't seem to find it.

                          The first post says the install is HS3 standard method, but I don't see it in any of the categories on plugin Manage page. And I'm not seeing any zip file to download on the first post either...

                          Feeling dense here...

                          Comment


                          • Teladog,

                            I understood that HST would make the plugin available through the interface, was hoping they had all the information so I could do the last step.

                            But appearently I am waiting for that last confirmation from HST...
                            I expected it for yesterday am now hoping for today.
                            Otherwise I will package the override procedure for the release version so you could reach it for the weekend ok?

                            Regards,

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • Originally posted by w.vuyk View Post
                              Teladog,

                              I understood that HST would make the plugin available through the interface, was hoping they had all the information so I could do the last step.

                              But appearently I am waiting for that last confirmation from HST...
                              I expected it for yesterday am now hoping for today.
                              Otherwise I will package the override procedure for the release version so you could reach it for the weekend ok?

                              Regards,

                              Wim
                              No worries, thanks for clearing that up. I'm happy to just wait until it is available in the interface, I just thought maybe I was being an idiot and couldn't find it.

                              Good to know I'm not an idiot, at least not yet

                              Comment


                              • Thanks ! Did the disable / enable thing and I now Have GROUPS !!
                                my only questions so far is that the colors reflected in the device is no where near the bulb

                                moving along.. get to play this week-end
                                Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

                                Comment

                                Working...
                                X