Announcement

Collapse
No announcement yet.

JowiHue Philips Hue control beta now available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by bartbakels View Post
    Win,

    my model no`s are;

    Hues: LCT001
    Living color old gen: LLC006
    Living color New gen: LLC006
    Living White: LWB001

    so the living colors seem to have the same no.

    By the way, there are also the iris , bloom, ledstrips, new GU10, en the TAP Switch. Exact model nos can prob ably found at everyhue.com

    and at http://www2.meethue.com/en-us/the-range/hue-lights/

    regards

    bart
    Bart,

    Thanks. I had the models mentioned at meethue in the plugin already. but was having doubts on the old gen living color and whites. Now i am sure having the right set pretty complete.
    Will finish up on the release candidate on Friday if time lets me

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #62
      Hi,

      I've tried the PI today, and I too have the same problem as Kenrad and Vanisher
      Should the PI have created the bin\JowiHue folder??
      Where is the PI .ini file kept, inside the Config Folder ??

      Cheers
      J

      Comment


      • #63
        Skinnez,

        if you have the same issue as Kenrad, then your error message is referring to the SQLite.Interop.dll right? In that case I cannot help you, how much I would like to.

        Did you try to delete the SQLite.Interop.dll from the HS installation directory and did you have the same challenges as Kenrad?
        If you disable plugins, disabling which plugin solves your issue?
        Is there a plugin that you have in common with Kenrad (look at his signature) or Vanisher?

        If I only knew which plugin is causing these difficulties for other plugins.... but I do need the help from you all to find the causing plugin?

        And to make things 100% sure, you did also download the interop.zip and placed the contents in the bin\JowiHue directory?

        Regards,

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #64
          Yes, I have done all that..
          Should the plugin have created the folder bin\JowiHue ??
          I had to create it.
          I cannot find an .ini file in the CONFIG directory? Should there be one, or would it be created once the plugin has succesfully started? (It hasn't so there isn't one?)

          I was wondering if it was related to Windows 8.1 since Kenrad is on that as I am?
          I also copied System.Data.SQLite.dll to the Bin\JowiHue folder so there are just 2 .dll's in that folder. The version of System.Data.SQLite.dll I have is 1.0.87.0 and the error refers to 1.0.92.0, would that version help?

          Cheers
          J

          edit : found the config file in the HS3 root

          Comment


          • #65
            Yes, the installation should have created the bin\jowihue directory. Did you follow the process with the updater_overide.txt? Because that should have created the necessary directories. There should be 3 files in the directory, also Newtonsoft.Json.dll should exist there.

            There is no ini file for this plugin as all data is in the database.

            The sqllite dll's in the zip file should be the correct ones.

            I am not using windows 8, so don't know if it is following a more critical path... will have to check on that tomorrow. But an important question in this is if you also have a SQLite.Interop.dll in the installation root of HS as Kenrad has?

            Regards,

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #66
              Got it!!
              The Bin\JowiHue folder wasn't created.. so no .dll's
              I think it may be a Windows 8 UAC problem? I have used the updater_overide.txt loads of times before.
              Anyway, copying the wrong versions of the files to the bin folder causes it to fail.
              Once I got the correct versions from your install zip it works.
              Newtonsoft.Json.dll
              SQLite.Interop.dll
              System.Data.SQLite.dll
              are in the Bin\JowiHue
              I'll delete it all and install again tomorrow just to check the install fails, once ive played with the plugin!
              Windows 8 strikes again

              Cheers
              J

              Comment


              • #67
                If it was a problem in windows 8.1 I would expect to see errors in the HS3 log coming from the updater shile copying files.
                Maybe you could check what happened in the log? If it was an UAC problem I would still exepect some lines in the log about that.

                I would suggest not to delete it, but wait while I will publish the release candidate today. I have to do one more test here and I can deliver it in this thread.

                Regards,

                Wim
                -- Wim

                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                650 devices ---- 336 events ----- 40 scripts

                Comment


                • #68
                  Wim,

                  Great news, waiting for the RC ,

                  BTW probabaly i get my Hue lightstrip and tap today. todo some further testing


                  Bart
                  Regards Bart
                  ------------------------------------------
                  Win7 64Bit on Intel NUCI7 with SSD
                  HSPRO 3.
                  Devices; 1370 Events; 691

                  Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                  Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                  Comment


                  • #69
                    Release candidate available

                    The release candidate 0.9.0.0 is is now available.

                    Changes since the last beta:

                    Version 0.9.0.0
                    August, 2014: Release candidate 1;
                    Bugs

                    • Fixed several small issues.
                    • Error handling of bridge improved

                    Functionality

                    • Added color conversions to scenes page
                    • Changed handling of scenes. The plugin will now only send the command part related to the correct color mode needed for the command. Either CIE color mode (x,y values), Whites (color temperature/ct) or Hue/Sat command is send.
                    • Changed scene creativity page to simplify addressing the correct fields.
                    • Added alert to scenes
                    • Added Event triggers and conditions
                    • Added device icons to approach the Philips light connected to the device
                    • Added functionality to match the Philips light connected (white bulbs, living color not capable to show whites etc.)
                    • Added script commands for direct control of the plugin

                    Look for details in the documentation.

                    Happy testing!

                    If you find issue, please report them in this thread.

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #70
                      Wim,

                      The living Whites images are not correct, Type no is LWB001 but the images have the LWB004 name. I renamed them which solves this issue.

                      In addition when showing only the jowihue devices i got this message in the log;

                      aug-22 13:26:47 Warning Image file does not exist, returning blank image: C:\Program Files (x86)\Homeseer HS3\html\images/Devices/Image-Not-Selected_small

                      The file is there but i think its the forward slash that is causing this error.


                      Bart
                      Regards Bart
                      ------------------------------------------
                      Win7 64Bit on Intel NUCI7 with SSD
                      HSPRO 3.
                      Devices; 1370 Events; 691

                      Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                      Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                      Comment


                      • #71
                        Originally posted by bartbakels View Post
                        Wim,

                        The living Whites images are not correct, Type no is LWB001 but the images have the LWB004 name. I renamed them which solves this issue.

                        In addition when showing only the jowihue devices i got this message in the log;

                        aug-22 13:26:47 Warning Image file does not exist, returning blank image: C:\Program Files (x86)\Homeseer HS3\html\images/Devices/Image-Not-Selected_small

                        The file is there but i think its the forward slash that is causing this error.


                        Bart
                        Bart,

                        I noticed I did not add the LWB001 icons. missing them and am surprised it replaces it with the lux. Will look into that. Would you havee a pointer for me for the correct image? then I can take it from there.

                        For your second point, I would like to know which image is replaced by this link. Is there adevice with missing icons? As the plugin does not have a function replacing icons if they do not exist.

                        Thanks! Wim
                        -- Wim

                        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                        650 devices ---- 336 events ----- 40 scripts

                        Comment


                        • #72
                          Wim,I cant find the LivingWhites in the images folder, so i used the Lux devices for now....


                          btw why does this appear in the log during startup:

                          aug-22 14:52:17 JowiHue Unknown setting:Refreshrate Value:2000

                          In addition, the plugin now crashes... dont know why exactly. so this could be a more serious issue..

                          Click image for larger version

Name:	jowihue.jpg
Views:	1
Size:	66.0 KB
ID:	1174648
                          Last edited by bartbakels; August 22nd, 2014, 07:39 AM.
                          Regards Bart
                          ------------------------------------------
                          Win7 64Bit on Intel NUCI7 with SSD
                          HSPRO 3.
                          Devices; 1370 Events; 691

                          Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                          Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                          Comment


                          • #73
                            Hmm the plugin is restarting everytime,

                            I will try to reboot whole PC, otherwise do i clean plugin install. Maybe its because i also added the lightstrips and tap?


                            see debug log:

                            Code:
                            aug-22 15:38:07	 	JowiHue	Debug: :InitDevices: Searching for Hue devices
                            aug-22 15:38:02	 	JowiHue	Debug: :InitPlugin:Starting Device checks
                            aug-22 15:38:01	 	JowiHue	Bridge found, initializing devices
                            aug-22 15:38:01	 	JowiHue	Debug: :Connected to Hue bridge at IP 192.168.0.143 ID=001788fffe0a3079
                            aug-22 15:38:01	 	JowiHue	Debug: :Found Hue bridge at IP 192.168.0.143 ID=001788fffe0a3079
                            aug-22 15:38:01	 	JowiHue	Debug: :BridgesAvailable::1 bridge(s) found in this network
                            aug-22 15:38:00	 	JowiHue	InitIO:Plugin Initialisation done
                            aug-22 15:38:00	 	JowiHue	Debug: :MainWatchThread: Checking plugin health
                            aug-22 15:38:00	 	JowiHue	Unknown setting:Refreshrate Value:2000
                            aug-22 15:37:59	 	JowiHue	InitIO: Starting plugin JowiHUe
                            aug-22 15:37:59	 	Info	Plugin JowiHue has connected. IP:127.0.0.1:50571
                            aug-22 15:37:59	 	Warning	I/O interface JowiHue is down, executable is not running, restarting ...
                            aug-22 15:37:57	 	Info	Plugin JowiHue with instance: has disconnected
                            aug-22 15:37:49	 	JowiHue	Debug: :MainWatchThread: Starting UpdateThreads
                            aug-22 15:37:49	 	JowiHue	Plugin succesfully started
                            aug-22 15:37:49	 	JowiHue	Debug: :InitPlugin:Config Done: True
                            aug-22 15:37:49	 	JowiHue	2 Animations are available for use
                            aug-22 15:37:49	 	JowiHue	12 Scenes are available for use
                            aug-22 15:37:49	 	JowiHue	3 Groups are available on this bridge
                            aug-22 15:37:49	 	JowiHue	10 lights are connected to this bridge
                            aug-22 15:37:48	 	JowiHue	Debug: :InitPlugin:Starting Bridge
                            aug-22 15:37:36	 	JowiHue	Debug: :InitDevices: Searching for Hue devices
                            aug-22 15:37:31	 	JowiHue	Debug: :InitPlugin:Starting Device checks
                            aug-22 15:37:30	 	JowiHue	Bridge found, initializing devices
                            aug-22 15:37:30	 	JowiHue	Debug: :Connected to Hue bridge at IP 192.168.0.143 ID=001788fffe0a3079
                            aug-22 15:37:30	 	JowiHue	Debug: :Found Hue bridge at IP 192.168.0.143 ID=001788fffe0a3079
                            aug-22 15:37:30	 	JowiHue	Debug: :BridgesAvailable::1 bridge(s) found in this network
                            aug-22 15:37:29	 	Plug-In	Finished initializing plug-in JowiHue
                            aug-22 15:37:29	 	JowiHue	InitIO:Plugin Initialisation done
                            aug-22 15:37:28	 	JowiHue	Debug: :MainWatchThread: Checking plugin health
                            aug-22 15:37:28	 	JowiHue	Unknown setting:Refreshrate Value:2000
                            aug-22 15:37:27	 	JowiHue	InitIO: Starting plugin JowiHUe
                            aug-22 15:37:27	 	Info	Plugin JowiHue has connected. IP:127.0.0.1:50457
                            Regards Bart
                            ------------------------------------------
                            Win7 64Bit on Intel NUCI7 with SSD
                            HSPRO 3.
                            Devices; 1370 Events; 691

                            Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                            Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                            Comment


                            • #74
                              Still, no luck, I am rolling back to the old version, hopefully this still works...
                              Regards Bart
                              ------------------------------------------
                              Win7 64Bit on Intel NUCI7 with SSD
                              HSPRO 3.
                              Devices; 1370 Events; 691

                              Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                              Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                              Comment


                              • #75
                                Wim,

                                It probably has something to do with the addition of the HUE Tap or the Hue lightstrips, I rolled back to 0.7 and i still see issues with the plugin. Im now trying to do a clean install of 0.9, so empty database etc and post back.

                                EDIT: this wont help either...back at 0.7 with issue.. conclusion it has something todo with the addition of the TAP and or Lightstrips

                                Bart
                                Regards Bart
                                ------------------------------------------
                                Win7 64Bit on Intel NUCI7 with SSD
                                HSPRO 3.
                                Devices; 1370 Events; 691

                                Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                                Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                                Comment

                                Working...
                                X