Announcement

Collapse
No announcement yet.

JowiHue Philips Hue control beta now available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Bart,

    Did the tap add devices to HS3? Because I would not expect this as I think this would be a bridge only device. If possibe check it.
    For the lightstrip I would not expect issues as it is just another living color.
    Could you try enabling debug and send me this? It will be in the HS3 log, did not yet prepare a separate log
    Filter it on JowiHue?

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #77
      Checked the part of the log you posted, including the console part - bit unsharp to see, but it seems it is trying to add 11th device, which suggest the tap would add itself.

      Challenge is I did not find much on the tap.
      Would it be possible for you to send me the debug log of your bridge?

      goto <IP address bridge>\debug\clip with your browser
      In this window enter: /api/HS3JowiHue2014 and press the get button.

      Send the log by PM or to w.vuyk at upcmail.nl

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #78
        Bart,

        I have found the issue . It is the livingwhite causing this issue.
        Will post a update shortly

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #79
          Bart,

          Please download the plugin again from the first post.
          It should solve your issue or at least survive with correct errors.

          Sorry for the inconvenience

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #80
            Wim,

            After some time, it stabilized, so no restarting of the plugin anymore, in afew post before you saw the debug log...

            de TAP is not creating HS3 device.

            I will try to upgrade once more and let it sit there for an hour keep u posted.

            EDIT: Strangely enough 0.9 is running now without disconnecting the plugin... I really dont understand what happenend, i did not reboot anymore, and did this also this afternoon, and then it caused me disconnecting the plugin all the time.

            Bart
            Last edited by bartbakels; August 22nd, 2014, 11:48 AM.
            Regards Bart
            ------------------------------------------
            Win7 64Bit on Intel NUCI7 with SSD
            HSPRO 3.
            Devices; 1370 Events; 691

            Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

            Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

            Comment


            • #81
              Bart,

              I did update the plugin, but didn't change the version. You are running the updated version that is now handling the living whites correctly.

              That bug escaped on me as I did not test the living whites. Bit of the challenge when you do not have all the different types.
              Glad we caught it!

              Did the light strip show up nicely?

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #82
                Wim,

                It seems to work fine now. Ledstrip isvshowing up fine btw.

                Still need my bridge config?

                Thanks wim

                Bart
                Regards Bart
                ------------------------------------------
                Win7 64Bit on Intel NUCI7 with SSD
                HSPRO 3.
                Devices; 1370 Events; 691

                Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                Comment


                • #83
                  Bart,

                  No need anymore, we seem to have catched the bug.

                  Here is hoping it is the last one

                  Regards,

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • #84
                    Bart,

                    I have updated the installation with the correct images for the living white.The new images are in in the zip file in this post for you to seperately download, so you could correct your devices.

                    Thanks

                    Wim
                    Attached Files
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #85
                      'All Lights' Group Functionality Not Working

                      Hi,
                      I just installed .9 - lots of great changes from .5. Thank you!

                      The Group On/Off functionality no longer works with the default "All Lights" group. Here are the log entries:
                      • Error Calling SetIOMulti in plugin JowiHue:The given key was not present in the dictionary.
                      • JowiHue Debug: :SetDeviceByUserRequest:Start ref=221 Action:0
                      • Device Control Device: Entire House Philips Hue Lights All Lights to Group Off (0) by/from: CAPI Control Handler


                      The Group On/Off functionality works successfully on groups that I make. This group contains all lights as well.
                      • JowiHue Debug: :SetDeviceByUserRequest:End
                      • JowiHue Debug: :SetLights::
                      • JowiHue Debug: :[{"success":{"/groups/2/action/transitiontime":15}},{"success":{"/groups/2/action/on":false}}]
                      • JowiHue Debug: :SetDeviceByUserRequest:Start ref=233 Action:0
                      • Device Control Device: JowiHue JowiHue All Philips Lts to Group Off (0) by/from: CAPI Control Handler


                      Thanks for your help!

                      Comment


                      • #86
                        Wim,

                        Thanks, for the icons.

                        I also have that issue with the default all lights group. I tried deleting this group, even after plugin restart i still got the same message as Bridy.

                        Bart
                        Regards Bart
                        ------------------------------------------
                        Win7 64Bit on Intel NUCI7 with SSD
                        HSPRO 3.
                        Devices; 1370 Events; 691

                        Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

                        Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

                        Comment


                        • #87
                          I have the same issue myself. Will post an update soon, I think I know the cause behind this.

                          Regards,

                          Wim
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                          • #88
                            Hi,

                            I had the dictionary error on Group 0 too.
                            Has anyone tried any sliders in HStouch? They nearly work but I wasn't expecting them to work at all since the HStouch sliders are buggy. They dont track properly at first until you set the level, and moving the slider doesn't always change the bulb. This is only with the brightness, not tried the hue or sat.
                            Would be good to get this working if possible.

                            Cheers
                            J

                            Comment


                            • #89
                              All,

                              I have posted a new version 0.9.2.0. Please update the plugin for solving the issue with groups.

                              Thanks,

                              Wim
                              -- Wim

                              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                              650 devices ---- 336 events ----- 40 scripts

                              Comment


                              • #90
                                Originally posted by Skinnez View Post
                                Hi,

                                I had the dictionary error on Group 0 too.
                                Has anyone tried any sliders in HStouch? They nearly work but I wasn't expecting them to work at all since the HStouch sliders are buggy. They dont track properly at first until you set the level, and moving the slider doesn't always change the bulb. This is only with the brightness, not tried the hue or sat.
                                Would be good to get this working if possible.

                                Cheers
                                J
                                Skinnez,

                                I have tried really hard to get HSTouch to work with the devices. But it just won't work correctly. Especially the Hue values can't be handled with sliders. Bright and Sat, like you said are working only randomly. The plugin just doesn't get values from HSTouch, only now and then.

                                I sure would wish it works, as you could place sliders next to a Hue table (image)and follow the colors. Philips Hue light sure would folow the slider easily.

                                But I am afraid HSTouch still has some road to go to truly give the values to the plugin.

                                Trust me, this is high om my wish list

                                Wim
                                Last edited by w.vuyk; August 23rd, 2014, 04:50 PM.
                                -- Wim

                                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                                650 devices ---- 336 events ----- 40 scripts

                                Comment

                                Working...
                                X