Announcement

Collapse
No announcement yet.

JowiHue Philips Hue control beta now available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • David,

    I found a situation where the plugin could miss showing the button correctly. I am guessing you have this situation. Will have to check in more detail on this.

    But still, it should find your bridge. Can you try to ping the bridges ip address from the machine where the plugin runs?
    Also cycling the power on the bridge could help maybe?

    Regards,

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • Originally posted by w.vuyk View Post
      David,

      I found a situation where the plugin could miss showing the button correctly. I am guessing you have this situation. Will have to check in more detail on this.

      But still, it should find your bridge. Can you try to ping the bridges ip address from the machine where the plugin runs?
      Also cycling the power on the bridge could help maybe?

      Regards,

      Wim
      I can ping the bridge from my HS3 machine and arp -a from the command line also confirms that the MAC address matches the MAC address that shows up in the iPad app.

      Thanks
      -David

      Comment


      • David,

        Could you test this link in the browser from the HS3 machine?

        http://www.meethue.com/api/nupnp

        If this works I am out of options, other then doing a fresh restart of the plugin and the bridge itself.

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • Originally posted by w.vuyk View Post
          David,

          Could you test this link in the browser from the HS3 machine?

          http://www.meethue.com/api/nupnp

          If this works I am out of options, other then doing a fresh restart of the plugin and the bridge itself.

          Wim
          When I try to open the link from IE, I get asked if I want to Open or Save the file. If I select open, I get asked which program I want to open it with.

          -David

          Click image for larger version

Name:	jowihue02.jpg
Views:	1
Size:	26.3 KB
ID:	1174740

          Comment


          • Answers to your questions

            Originally posted by w.vuyk View Post
            Stech,

            *dunk* I was hoping to see a user with more then one bridge a bit later.
            The Philips Hue bridge itself is physically limited to 16 groups, so there is nothing I can change there. Only a wise spread over the two bridges would help for that part.
            Enabling a second bridge is a challenge, I guess I would need to allow multiple instances of the plugin for that. I will dive into that after the initial release for the plugin, so it surely will take time.

            For the release I could remove the 50 device limitation as I read the bridge is not really limiting to that number, but it is only a soft limitation for performance of the signals.
            That makes me wonder, how is your performance with this plugin so far? Is the light, controlled by the plugin that is fartest away from the bridge still responding fast, acceptable or starting to be slow?

            As for copying scenes, it is in my to do list after the release.

            A short list of my "to do" after release:

            - Enable recording of "on" hours per type of light ( at release)
            - Enable 'calculated' energy values (not measured as Phillips Hue does not deliver this)
            - Enable grouping of Scenes
            - Enable copying of Scenes (what you are asking for)
            - Thinking of implementing lampstealer in the plugin

            A final question, just tbecause I am getting nosy: is your setup for an office area? As I would think hue light would just be very nice in an office area and I couldn't imagine a simple home having 76 lights?

            Wim
            Excuse my limited programming background, but was thinking.. . .

            Do you have to keep the groups as a part of the hue device parameters? Can they not be set up as a part of the plugin under HS3 and pass the information to the bulbs accordingly, or will that give you the bulb by bulb startup as opposed to all on effect of the current groups? Approaching it from a different angle.

            On the 2 bridge subject, I was thinking dual instances for the plugin as well. . . . as long as the plugin is seen as a different entity by HS3 there should be no real issue. It can grab the bridge in the same manner as the current. Maybe simplistic thinking on my part.

            As for performance. . . .in a nutshell, my experience has been that while the bulbs are good conceptually the interface is weak at best. Even on a fresh network with no other items and 20 bulbs on a bridge, the reaction time is a joke. You have a cutting edge multinational company develop a great product then produce a lackluster interface poorly thought out with a lot of limitations.

            Try a music app. . .response time is so slow it looks like nothing more than random flickering lights.

            If anybody has any suggestions on performance enhancements I may be missing please share them.

            Great news on copies for scenes

            This install is in a residence. The entire house is HUE with around 550' of additional RGB LED around the interior soffits, perimeter and landscape. Still trying to sort how I will interface the LED control to Homeseer at this point.

            The client I work with has a great approach to building and design. . . .decide what you want and make it happen as opposed to see whats out there and design around that. This opens creativity and in every case we have been able to develop a solution.


            Thanks so much for your input and time.

            Comment


            • Originally posted by drule View Post
              When I try to open the link from IE, I get asked if I want to Open or Save the file. If I select open, I get asked which program I want to open it with.

              -David
              David,

              That is IE doing this. Can you try the same with Chrome?

              Did you also try a restart of the plugin an bridge?

              Regards,

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • Originally posted by w.vuyk View Post
                David,

                That is IE doing this. Can you try the same with Chrome?

                Did you also try a restart of the plugin an bridge?

                Regards,

                Wim
                That URL in Chrome gives me a page with just []. Restarting the plugin and bridge hasn't helped. I'm guessing the JSON script should have given me something more meaningful, such as an ip address? Is this pointing at a network/UPNP problem?

                -David

                Click image for larger version

Name:	jowihue03.jpg
Views:	1
Size:	22.7 KB
ID:	1174741

                Comment


                • I think this is pointing to the issue. I am getting the correct string:

                  Code:
                  [{"id":"xxxxxxxxxxxxxxx","internalipaddress":"xxxxxxxxxxxx","macaddress":"xx:xx:xx:xx:xx:xx","name":"Wim en Joy\u0027s hue"}]
                  Meethue is doing its search through this page and I do not know what ports are used by the link.
                  Could you test the same link on other devices, like Iphone/ipad or other PC's?

                  You could also temporary lower firewall settings on the HS3 PC? It is doing its magic inside the network, so I am not expecting it should involve your routers firewall.

                  Maybe we are on track

                  Wim
                  -- Wim

                  Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                  650 devices ---- 336 events ----- 40 scripts

                  Comment


                  • David,

                    I found this thread describing similar issues. One suggestion seems to work:

                    Code:
                    Solution for not finding online bridge
                    
                    Delete the meethue account 
                    My Hue, Settings, Delete account 
                    
                    then register again and the bridge pairs
                    Here is the link: http://www.everyhue.com/vanilla/disc...find-bridge/p3

                    maybe this helps?

                    Regards,

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • Originally posted by stech99 View Post
                      Excuse my limited programming background, but was thinking.. . .

                      Do you have to keep the groups as a part of the hue device parameters? Can they not be set up as a part of the plugin under HS3 and pass the information to the bulbs accordingly, or will that give you the bulb by bulb startup as opposed to all on effect of the current groups? Approaching it from a different angle.

                      On the 2 bridge subject, I was thinking dual instances for the plugin as well. . . . as long as the plugin is seen as a different entity by HS3 there should be no real issue. It can grab the bridge in the same manner as the current. Maybe simplistic thinking on my part.

                      As for performance. . . .in a nutshell, my experience has been that while the bulbs are good conceptually the interface is weak at best. Even on a fresh network with no other items and 20 bulbs on a bridge, the reaction time is a joke. You have a cutting edge multinational company develop a great product then produce a lackluster interface poorly thought out with a lot of limitations.

                      Try a music app. . .response time is so slow it looks like nothing more than random flickering lights.

                      If anybody has any suggestions on performance enhancements I may be missing please share them.

                      Great news on copies for scenes

                      This install is in a residence. The entire house is HUE with around 550' of additional RGB LED around the interior soffits, perimeter and landscape. Still trying to sort how I will interface the LED control to Homeseer at this point.

                      The client I work with has a great approach to building and design. . . .decide what you want and make it happen as opposed to see whats out there and design around that. This opens creativity and in every case we have been able to develop a solution.


                      Thanks so much for your input and time.
                      Stech99,

                      I never went that far with the bridge yet. I am controlling 6 lights now (hoping to get few more someday) and so far it is working fine here.
                      But I can imagine having a lot of bulb is generating a lot of signalling zigbee traffic in the house as commands are passed.

                      As far I understand one bridge can send 10 single light commands per second, and if you are using groups, 2 group comands per second.
                      The advantage of using groups is that lights respond based on their membership and will be faster to respond. As example, one group command could control 10 lights, so sending 2 group commands could control 20 lights in one second, where you would need 2 seconds to control 20 lights with light commands.

                      But like I said before, could not test this number myself. But I do notice group commands for 4 lights are faster responding then controlling each light by itself. And the group commmand makes response look more synchronised.

                      The music apps I know are sending commands per light... think back on the fact that the bridge can send 10 light commands per second - this means the music app can only change one light once per 2 seconds at the most if you have 20 lights... If you want a nice effect, you should only use every other light (or even one on every three) of the set to have some better response, while using deep color settings.

                      That is also why I prefer using the group functionality of the bridge instead of keeping track of groups in the plugin. It allows for more speed as long the group is holding a considerable amount of lights

                      If the number of groups need to be higher, I would think on adding an extra bridge (once the plugin supports it).

                      Much of the above answer is my assumption, based on what I could find on information from Phillips and other sources.

                      As for multiple bridges, I will have to look into this, so I need more bridges first I will work on that after the initial release.

                      Thanks for your ideas and input!

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • Originally posted by w.vuyk View Post
                        David,

                        I found this thread describing similar issues. One suggestion seems to work:

                        Code:
                        Solution for not finding online bridge
                        
                        Delete the meethue account 
                        My Hue, Settings, Delete account 
                        
                        then register again and the bridge pairs
                        Here is the link: http://www.everyhue.com/vanilla/disc...find-bridge/p3

                        maybe this helps?

                        Regards,

                        Wim
                        TADA! That seems to have done the trick. Thanks v much for your help

                        -David

                        Comment


                        • Owwww!!!! So glad it is not the plugin!!

                          Thanks David, you made me nervous hehehe

                          Wim
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                          • Originally posted by w.vuyk View Post
                            Kenrad,

                            Gearyt,
                            You also might have to remove both files SQLite.Interop.dll and System.Data.SQLite.dll from the installation directory, or did you figure it out already?

                            Regards,

                            Wim
                            Removed files from /bin
                            whoops wrong dir... will replace and remove from install

                            now I am a mess.. any easy way to start over ?

                            get..
                            Attached Files
                            Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

                            Comment


                            • here is where I am.. who do I keep,
                              Attached Files
                              Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

                              Comment


                              • and
                                Attached Files
                                Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

                                Comment

                                Working...
                                X