No announcement yet.

Monoprice HDMI Matrix Plugin?

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by jlrichar View Post
    No jumping of pin 4-5? I have HDX-404e switch. Is it the same one you have?
    Pins 4-5 need to be straight-through. It's a weird kind of 'half-null modem' cable. ;-)

    The plugin works with the HDX-402E and HDX-404E switches.



    • #17
      OK. I have the switch connected to the HS computer. Let me know when you need someone to test this plugin. Also--thanks for doing this!!!

      HS3 : HSpro ( on Win2012 (vm on ESXi)
      Plugins: HSTouch, UPBSpud, Kinect, Nest, IFTTT, DirecTV, EasyTrigger, Imperihome, Zwave, RFXcom, UltraMon3, UltraWeatherBug3, UltraGCIR3, UltraLog3, UltraPioneer, PHLocation, Pushover, Pushalot, MCSSPrinklers S, JowiHue
      Jon00 Plugins: Bluetooth Proximity, Performance Monitor, DB Chart, Links


      • #18
        Originally posted by jlrichar View Post
        These are the instructions that MonoPrice has:
        Hi jlrichar,
        did you make your own cable or did you buy it. Thanks for post the link.
        baby steps...starting again with HS3
        HS3Pro: Z-NET & 80 Z wave Devices,
        HSTouch: 4 Joggler (Android Kitkat), 2 iPhone, 3 iPads
        Whole House Audio: 5 SqueezePlay Jogglers w Bose Speakers
        In The Works: 10 Cameras Geovision, new Adecmo/Envisalink Alarm, Arduinos
        System: XP on Fanless Mini-ITX w/ SSD


        • #19
          HS plugin - old problem

          HEy guys !

          I've read a couple threads with the problem we are having regarding our monoprice 4x4 serial hdmi matrix. We can communicate with the matric with the small Windows software so it's homeseer related.

          Basically, the matrix cannot speak with the plugin which is configured to the right com port ( com11 ).

          Exception in COM:11: The I/O operation has been aborted because of either a thread exit or an application request. 2015-01-26 22:30:32 DR Monoprice HDX Plugin Connection failed! Watchdog timer restarting thread for matrix

          We get that in a loop when watchdog is activated. We also tried the IP / Serial plugin and it makes our homeseer crash whe sending a command. We seen a couple threads about this but no apparent solution for the hs2 version.

          We tried 2 different USB2Serial adapters to make sure it was not a compatibility issue but since the Windows test software controls it just fine, we grayed this option out.

          Any idea ?


          • #20
            I wrote a plugin for the

            You just chose which comport for it to use.

            You can rename the sources using the status page of the device. Since this HDMI device doesnt provide a response on the serial link I am not able to show the current status of each source. I use a USB to Serial cable. Works great for me.


            • #21
              Just download the zip file and extract the exe in the HS3 directory. It should show right up with a drop down to choose the comport.


              • #22
                We are running hs2, is it compatible you think ? Thx


                • #23
                  I wrote it for HS3. ALso I just saw drule that you made one too? Can I try yours as well?