Announcement

Collapse
No announcement yet.

Device Management Plugin Tabs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Device Management Plugin Tabs

    When I add a new device via the Device Management page, I get two tabs for active plugins, X10 and tenHsPanPbx (my own plugin). -- see attachment. If I disable my plugin and add a device, the tab is NOT there for tenHsPanPbx. Any device I create ends up with an Interface property of tenHsPanPbx (which causes it to act badly).

    What am I doing in my plugin that is causing this? How does HS3 decide to add the X10 or any other plugin tab to the Device Creation panel? There are many plugins enabled that do not appear there, only mine and X10?

    Any help is appreciated.

    tenholde
    Attached Files
    tenholde

  • #2
    I think it's the difference between http://homeseer.com/support/homeseer...nfigdevice.htm and http://homeseer.com/support/homeseer...gdeviceall.htm the X10 plugin likely has the all property set (not sure but it seems to appear on all virtual devices created), you may only have set the first option.
    My Plugins:

    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
    Yeelight 3P | Nanoleaf 3P

    Comment


    • #3
      I had SupportsConfigDevice set true, SupportsConfigDeviceAll set false.

      Set both to false, and still get same result.

      tenholde
      tenholde

      Comment


      • #4
        Solved it.

        I was setting SupportsAddDevice to True

        tenholde
        tenholde

        Comment

        Working...
        X