Announcement

Collapse
No announcement yet.

Monoprice 6 zone amplifier plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Thanks for pursuing this, happnatious1. I tried the updated plugin tonight. No issues yet, in terms of duplicate devices. However, unfortunately the MP Amp 2 plugin does not control the corresponding amp. The plugin for MP Amp 1 continues to function as always without issue, continuing to control MP Amp 1. MP Amp 2 is setup with a separate USB to Serial cable, controlling the second monoprice amp on Com10 (Com 10 appears/disappears in device manager when i plugin and unplug the respective cable). MP Amp 1 and MP Amp 2 are both set to 'master.' Any ideas?

    Thanks!

    Dave

    Comment


    • #47
      So, I noticed that the plugin version number for the October HSPI files (1.30.00) was identical to what it had been previously, despite the fact that two of the three executables (HSPIamp2 and HSPIamp3) that I had pasted into my HomeSeer directory had updated dates (10/21 for those two files, whereas the original HSPIamp file was from June). On the off chance that something was amiss (caching on my browser?), I went ahead and went through all the steps again, downloading the files from a different browser, rebooting the system, etc. THIS TIME IT WORKED. I can now reliably select and power up/down the different zones on Mp Amp 2!!!! I haven't tried switching sources within zones yet, but I doubt there would be any issues there. Additionally, there appears to be no duplication of devices with this latest version. It has been running for over a week (and the system was rebooted and HomeSeer was restarted several times in that period). Thanks again for your work with this Happnatious1!

      Now its time to see if I can pickup a third USB to serial cable, so I can try that third MonoPrice amp ...

      Comment


      • #48
        Well that's good news. It will be interesting to see if Amp3 works OK as there are some minor differences between 2 and 3.
        If it ain't broke, don't fix it!

        Comment


        • #49
          I'm still having the issue of duplicating all zones everytime i restart the plug-in on linux. Any way to have a check box for skipping checking if previous items exist until this is fully fixed?

          Comment


          • #50
            Sorry I haven't been around again, super busy with work. I also cant believe I get no notification whatsoever from this new board. I literately got a notification on 3 posts that took place on October 3rd when I logged in just now. When I search for recent posts on my user profile, this thread doesn't even show up.

            I made a mistake in not updating the version number when I re-posted the plugin at the beginning of this thread. It may be confusing. The plugin stores its settings in the devices, so (unfortunately), disable the plugin, delete all monoprice amp devices, then re enable the plugins. (Painful, I know)

            BTW, I run homeseer on a Linux lubuntu virtual machine but develop on windows 7.
            Last edited by happnatious1; November 16th, 2018, 11:11 PM. Reason: Added that I'm on linux.
            If it ain't broke, don't fix it!

            Comment


            • #51
              Originally posted by happnatious1 View Post
              Sorry I haven't been around again, super busy with work. I also cant believe I get no notification whatsoever from this new board. I literately got a notification on 3 posts that took place on October 3rd when I logged in just now. When I search for recent posts on my user profile, this thread doesn't even show up.

              I made a mistake in not updating the version number when I re-posted the plugin at the beginning of this thread. It may be confusing. The plugin stores its settings in the devices, so (unfortunately), disable the plugin, delete all monoprice amp devices, then re enable the plugins. (Painful, I know)

              BTW, I run homeseer on a Linux lubuntu virtual machine but develop on windows 7.
              Since this thread is not in one of your sub forums, you need to click on the 'subscribe' button at the top of the thread. I WISH there was an auto-subscribe to threads I post in option, but have not found it.

              Comment


              • #52
                I only ever downloaded the latest v1.3 Multi-Amp zip and am seeing duplicated devices every time I restart HomeSeer on a Windows 10 box. I only have one Amp so only copied over the first of the files, HSPI_Monoprice_Amp.exe. I downloaded from this forum in December as that is when I made the switch to HomeSeer from Vera, so I believe I have the latest files.

                Is the issue because I moved the Monoprice Amp devices to a different floor/ room?

                Comment


                • #53
                  Any update on the duplication of devices? Nothing I do seems to resolve the issue and if I do not clean up the devices then every single time I restart HomeSeer I get an additional 62 devices duplicating every time. Do you have a timeline on a paid version?

                  Comment

                  Working...
                  X