Announcement

Collapse
No announcement yet.

Really simple C# sample plugin available here!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #32
    I'm gonna ask here, but I will look into asking over at stackoverflow too.

    I can't get this working on my second laptop. As soon as I try and create a new project I get the attached error message in VS. Anyone have any ideas at all?
    Attached Files
    Thanks,
    Frank

    Comment


    • #33
      Originally posted by sirmeili View Post
      I'm gonna ask here, but I will look into asking over at stackoverflow too.

      I can't get this working on my second laptop. As soon as I try and create a new project I get the attached error message in VS. Anyone have any ideas at all?
      Ok, I actually just fixed it. I swear as soon as I ask something, it gets fixed. I had to change this setting in VS to get it to work:

      Tools -> Options-> Projects and Solutions-> General -> Setting: Save new projects when created (checked)
      Thanks,
      Frank

      Comment


      • #34
        * Long story short: **YOU MAY HAVE TO UNINSTALL THE OLD PLUGIN AND INSTALL THE NEW PLUGIN TO CONTINUE GETTING UPDATES** I thought I configured the original extension incorrectly in the Visual Studio marketplace, and Microsoft doesn't provide a way to change the setting I thought I messed up. So I removed the old extension from the gallery. That's why you get a 404 when you to go https://marketplace.visualstudio.com...eSeerTemplates. The new location's forever home is at https://marketplace.visualstudio.com...emplates-18379 (arrrggg). You can also search for the extension from within Visual Studio. I'm pretty frustrated by the whole experience and -- worse -- it doesn't even look like the setting makes a difference. I'm trying to automate the publishing of the VSIX to the marketplace from the CI build, but I just don't think it's possible anymore.

        Sorry for the minor inconvenience.

        Comment


        • #35
          I am following the instructions on this page http://hspi.readthedocs.io/en/latest...g-started.html However, it simply download the zip file. I have no idea where to copy these files to and how to register them with VS if that is necessary at all. Please advice.

          Comment


          • #36
            Originally posted by mulu View Post
            I am following the instructions on this page http://hspi.readthedocs.io/en/latest...g-started.html However, it simply download the zip file. I have no idea where to copy these files to and how to register them with VS if that is necessary at all. Please advice.
            Sorry you're having trouble. Please post your question on http://stackoverflow.com/questions/ask?tags=HSPI. Make sure you post with the HSPI tag. That way, we can dig in and find the root cause of the problem. For one thing, there is no zip file. You'll need to provide some additional details in the StackOverflow post.

            Thanks.

            Comment


            • #37
              Originally posted by sirmeili View Post
              Ok, I'm not used to using that options library. I looked it up and I got it to work. I had to do "-s xxx.xxx.xxx.xxx" instead of just "xxx.xxx.xxx.xxx" for the argument. It now works for me

              I have a plugin I already wrote using the other template on here, I'm going to see what it is like to rewrite it using your templates.
              And for the benefit of Newbies like me with the same problem - the answer is also detailed in the faq:
              http://hspi.readthedocs.io/en/latest...ss-and-or-port

              Many thanks for your work on this Alex - gives me some motivation to learn some coding doing something that interests me.

              Comment


              • #38
                Is this project still active? When I try to download the HomeSeer Templates from VS I get redirect to a page that says "BlobNotFound"

                Comment


                • #39
                  Originally posted by TexNeil View Post
                  Is this project still active? When I try to download the HomeSeer Templates from VS I get redirect to a page that says "BlobNotFound"
                  https://github.com/alexdresko/HSPI/archive/master.zip

                  Comment

                  Working...
                  X