Announcement

Collapse
No announcement yet.

INI files for remote plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • INI files for remote plugin

    How do I use INI files with a remote plugin?

    GetIniSettings works great locally, but when I move the PI to my remote server it doesn't work and I've not found a place to "stick" them remotely which HS can find. The PI comes up but says there's nothing to do.

    Is there a setting or environment variable that I've missed? Or, do I have to use my own GetIniSettings code?

  • #2
    My experience seems to be that if you run a plugin remotely then it will still access the ini files on the HS PC (which I guess is because of the connection), what sort of data do you wish to store? You have the option of storing the data now in the devices if you only need a bit of data.
    My Plugins:

    Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
    Yeelight 3P | Nanoleaf 3P

    Comment


    • #3
      That's what I thought would happen, but it doesn't seem to be working. I use the PI name (IFACE_NAME) as the local host name for the config file. When I run it locally it finds "HHCONTROL.INI", but remotely it's not finding "TESTXP.INI". I've confirmed that this is not a case-sensitive thing (unless running remote is changing cases on me). I even ran locally in debug and forced the name and it worked.

      My PI is simply to run and watch remote programs and keys, with corresponding HS devices for many/some/all of them. That way I can use HS to make sure that the programs I want running on my remote XP boxes are still running, to stop and start them as needed, and I can report key values (as HS strings) back.

      I am using XD to keep track of last status information. I am matching HS devices with my config at startup or creating new devices if needed.

      I hoped/planned/coded to use the INI file to avoid having to develop custom config screens -- which seems to be far more trouble than necessary for my simple config.

      Comment


      • #4
        It does work -- my bad.

        One more issue and I'm ready to go...I'll do the research before I ask.

        Thanks for the help.

        Rick

        Comment

        Working...
        X