Announcement

Collapse
No announcement yet.

Looking for experienced developer to help build plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Looking for experienced developer to help build plugin

    Hi,

    I am looking to co-develop a plugin for HomeSeer to control Rako Lighting.
    I am familiar with their APIs, and also have technical contacts within Rako.

    However i am new to building things in Homeseer. Im looking for someone with the following skills:

    - Parse XML from http to create devices and rooms
    - Set some commands for these devices, such as ON/OFF/DIM
    - Commands are sent over http using get
    - Listen to UDP ports to get currently active scenes

    It should be fairly straightforward for somebody with the above skills, i have some demo kit which i can test on as well.

    Please get in touch if you are interested,

    Guy

  • #2
    hi did you ever write a plugin?

    Comment


    • #3
      Originally posted by gedelstyn View Post
      Hi,

      I am looking to co-develop a plugin for HomeSeer to control Rako Lighting.
      I am familiar with their APIs, and also have technical contacts within Rako.

      However i am new to building things in Homeseer. Im looking for someone with the following skills:

      - Parse XML from http to create devices and rooms
      - Set some commands for these devices, such as ON/OFF/DIM
      - Commands are sent over http using get
      - Listen to UDP ports to get currently active scenes

      It should be fairly straightforward for somebody with the above skills, i have some demo kit which i can test on as well.

      Please get in touch if you are interested,

      Guy
      Well now isn't that interesting another person from Inwood?

      Comment


      • #4
        Originally posted by Simplex Technology View Post

        Well now isn't that interesting another person from Inwood?
        I see his location as Calgary...
        HS 3.0.0.500: 1984 Devices 1111 Events
        Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

        Comment


        • #5
          Originally posted by sparkman View Post

          I see his location as Calgary...
          I was going by his avatar sidebar location...

          Comment


          • #6
            lol, me too. Must be a weird forum bug...

            Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	7.4 KB
ID:	1274626
            HS 3.0.0.500: 1984 Devices 1111 Events
            Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

            Comment


            • #7
              Just sooo wrong.... these errors and constant "notifications" that i get because of "flagged" posts that won't go away... ohhh!!! I was hopeful the forum would start improving.....
              Click image for larger version

Name:	V0w6qr.png
Views:	1
Size:	10.9 KB
ID:	1274630

              Comment


              • #8
                macromark Hey Mark, see above for a weird forum bug. I'm assuming this is not specific to HS, so maybe something to report to the forum software devs.

                rprade Hi Randy, is this something you have seen before with the other forums that you manage?
                HS 3.0.0.500: 1984 Devices 1111 Events
                Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

                Comment


                • #9
                  Originally posted by sparkman View Post
                  macromark Hey Mark, see above for a weird forum bug. I'm assuming this is not specific to HS, so maybe something to report to the forum software devs.

                  rprade Hi Randy, is this something you have seen before with the other forums that you manage?
                  It is (sort of) a vBulletin bug. If you notice, the user has no posts. That is because he is not a registered user. I don't know if he was able to post as an unregistered user in 2016 or if he was subsequently deleted.

                  If a post is shown and not linked to a user in the database, the location will be the same as yours. I don't consider this a serious bug, since it will be a vanishingly small subset of this community.
                  Randy Prade
                  Aurora, CO
                  Prades.net

                  PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                  Comment


                  • #10
                    Ummmmmmm.
                    Attached Files
                    Originally posted by rprade
                    There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                    Comment


                    • #11
                      Originally posted by jjn42b View Post
                      hi did you ever write a plugin?
                      The user is no longer a member of this community.

                      Randy Prade
                      Aurora, CO
                      Prades.net

                      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                      Comment


                      • #12
                        Originally posted by rprade View Post

                        If a post is shown and not linked to a user in the database, the location will be the same as yours.
                        Whew! As a frequent traveler to Vegas, I'm glad that's not a REAL TIME bug!

                        --Barry

                        Comment


                        • #13
                          Originally posted by logman View Post

                          Whew! As a frequent traveler to Vegas, I'm glad that's not a REAL TIME bug!

                          --Barry
                          Lol
                          HS 3.0.0.500: 1984 Devices 1111 Events
                          Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

                          Comment


                          • #14
                            Originally posted by rprade View Post
                            It is (sort of) a vBulletin bug. If you notice, the user has no posts. That is because he is not a registered user. I don't know if he was able to post as an unregistered user in 2016 or if he was subsequently deleted.

                            If a post is shown and not linked to a user in the database, the location will be the same as yours. I don't consider this a serious bug, since it will be a vanishingly small subset of this community.
                            Agreed, I don't think it is serious either, and kind of funny in a way.
                            HS 3.0.0.500: 1984 Devices 1111 Events
                            Z-Wave 3.0.1.256: 114 Nodes on one Z-Net

                            Comment

                            Working...
                            X